From: Matthieu Baerts <matttbe@kernel.org>
To: Geliang Tang <geliang@kernel.org>, mptcp@lists.linux.dev
Cc: Geliang Tang <tanggeliang@kylinos.cn>
Subject: Re: [PATCH mptcp-next 0/5] add helpers and vars in mptcp_lib.sh, part 2
Date: Mon, 19 Feb 2024 13:21:03 +0100 [thread overview]
Message-ID: <2b450f0e-49aa-47ed-8070-019ffbc82561@kernel.org> (raw)
In-Reply-To: <cover.1708334850.git.tanggeliang@kylinos.cn>
Hi Geliang,
On 19/02/2024 10:29, Geliang Tang wrote:
> From: Geliang Tang <tanggeliang@kylinos.cn>
>
> Depends on:
> - dump for userspace pm
> - add helpers and vars in mptcp_lib.sh, part 1
>
> Geliang Tang (5):
> selftests: mptcp: unify namespace names to ns1/2/3/4
> selftests: mptcp: add mptcp_lib_ns_* helpers
> selftests: mptcp: add mptcp_lib_cleanup helper
> selftests: mptcp: add mptcp_lib_check_output helper
> selftests: mptcp: add mptcp_lib_evts_* helpers
Good idea to reduce duplicated code between selftests. Still, I think we
should not go "too far", and hide the use of some variables and files.
For example, I think it is important not to have hidden global
variables, or declare it on one file, and use it elsewhere (except if
they are prefixed with the name of the file: MPTCP_LIB_xxx).
Please see my comments on the individual patches.
Cheers,
Matt
--
Sponsored by the NGI0 Core fund.
prev parent reply other threads:[~2024-02-19 12:21 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-02-19 9:29 [PATCH mptcp-next 0/5] add helpers and vars in mptcp_lib.sh, part 2 Geliang Tang
2024-02-19 9:29 ` [PATCH mptcp-next 1/5] selftests: mptcp: unify namespace names to ns1/2/3/4 Geliang Tang
2024-02-19 12:21 ` Matthieu Baerts
2024-02-19 9:29 ` [PATCH mptcp-next 2/5] selftests: mptcp: add mptcp_lib_ns_* helpers Geliang Tang
2024-02-19 12:21 ` Matthieu Baerts
2024-02-19 9:29 ` [PATCH mptcp-next 3/5] selftests: mptcp: add mptcp_lib_cleanup helper Geliang Tang
2024-02-19 12:21 ` Matthieu Baerts
2024-02-19 9:29 ` [PATCH mptcp-next 4/5] selftests: mptcp: add mptcp_lib_check_output helper Geliang Tang
2024-02-19 12:21 ` Matthieu Baerts
2024-02-19 9:29 ` [PATCH mptcp-next 5/5] selftests: mptcp: add mptcp_lib_evts_* helpers Geliang Tang
2024-02-19 12:22 ` Matthieu Baerts
2024-02-19 12:21 ` Matthieu Baerts [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=2b450f0e-49aa-47ed-8070-019ffbc82561@kernel.org \
--to=matttbe@kernel.org \
--cc=geliang@kernel.org \
--cc=mptcp@lists.linux.dev \
--cc=tanggeliang@kylinos.cn \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox