MPTCP Linux Development
 help / color / mirror / Atom feed
From: Matthieu Baerts <matttbe@kernel.org>
To: Geliang Tang <geliang@kernel.org>, mptcp@lists.linux.dev
Cc: Geliang Tang <tanggeliang@kylinos.cn>
Subject: Re: [PATCH mptcp-next 1/5] selftests: mptcp: unify namespace names to ns1/2/3/4
Date: Mon, 19 Feb 2024 13:21:10 +0100	[thread overview]
Message-ID: <dd4b6d97-2851-4726-bc44-8a8384055ae9@kernel.org> (raw)
In-Reply-To: <c25c836349eff4348c67d17a36b779836173a177.1708334850.git.tanggeliang@kylinos.cn>

Hi Geliang,

On 19/02/2024 10:29, Geliang Tang wrote:
> From: Geliang Tang <tanggeliang@kylinos.cn>
> 
> Most scripts use ns1, ns2, ns3 and ns4 as namespace names, but ns and
> ns_sbox are used in diag.sh and mptcp_sockopt.sh. To maintain consistency
> with other scripts, this patch renames these variables:

If it is just for consistency, I don't think we should rename these
variables:

>     ns        -> ns1         in diag.sh

For me, adding a number as suffix means there are multiple netns
interacting with each others. Here, there is only one, that would be
confusing.

If this rename is not needed to fix something, I would then prefer to
avoid such modifications: that will "annoy" us in case of backports →
more risks of having conflicts, but mainly backports done by the stable
team will not detect issues where the wrong variable is used (the stable
team only compiles the .c code).

>     ns_sbox   -> ns3         in mptcp_sockopt.sh

To be honest, I'm not a big fan of having numbers as suffix: when
looking at the names, it is not clear what is the difference between
'ns1' and 'ns2' for example. We should have probably used "_client",
"_server", "_router", "_shaper", etc. from the beginning. Too late now.

Hence, I would prefer here to keep 'ns_sbox', otherwise we might think
that ns3 is connected to ns1 and/or ns2, which is not the case.

WDYT?

Cheers,
Matt
-- 
Sponsored by the NGI0 Core fund.

  reply	other threads:[~2024-02-19 12:21 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-02-19  9:29 [PATCH mptcp-next 0/5] add helpers and vars in mptcp_lib.sh, part 2 Geliang Tang
2024-02-19  9:29 ` [PATCH mptcp-next 1/5] selftests: mptcp: unify namespace names to ns1/2/3/4 Geliang Tang
2024-02-19 12:21   ` Matthieu Baerts [this message]
2024-02-19  9:29 ` [PATCH mptcp-next 2/5] selftests: mptcp: add mptcp_lib_ns_* helpers Geliang Tang
2024-02-19 12:21   ` Matthieu Baerts
2024-02-19  9:29 ` [PATCH mptcp-next 3/5] selftests: mptcp: add mptcp_lib_cleanup helper Geliang Tang
2024-02-19 12:21   ` Matthieu Baerts
2024-02-19  9:29 ` [PATCH mptcp-next 4/5] selftests: mptcp: add mptcp_lib_check_output helper Geliang Tang
2024-02-19 12:21   ` Matthieu Baerts
2024-02-19  9:29 ` [PATCH mptcp-next 5/5] selftests: mptcp: add mptcp_lib_evts_* helpers Geliang Tang
2024-02-19 12:22   ` Matthieu Baerts
2024-02-19 12:21 ` [PATCH mptcp-next 0/5] add helpers and vars in mptcp_lib.sh, part 2 Matthieu Baerts

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=dd4b6d97-2851-4726-bc44-8a8384055ae9@kernel.org \
    --to=matttbe@kernel.org \
    --cc=geliang@kernel.org \
    --cc=mptcp@lists.linux.dev \
    --cc=tanggeliang@kylinos.cn \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox