MPTCP Linux Development
 help / color / mirror / Atom feed
* Patches for netdev (for 6.7)
@ 2023-10-23  0:12 Matthieu Baerts
  2023-10-23 16:44 ` Mat Martineau
  0 siblings, 1 reply; 2+ messages in thread
From: Matthieu Baerts @ 2023-10-23  0:12 UTC (permalink / raw)
  To: Mat Martineau; +Cc: MPTCP Upstream, Paolo Abeni

Hi Mat,

Regarding the patches we might want to send to netdev this week, I think
all the ones for -net and net-next can go.

- Fixes for -net:

    - selftests: mptcp: run userspace pm tests slower (Geliang Tang)
    - selftests: mptcp: fix wait_rm_addr/sf parameters (Geliang Tang)
    - mptcp: userspace pm send RM_ADDR for ID 0 (Geliang Tang)


- Features for net-next:

    - mptcp: add a new sysctl for make after break timeout (Paolo Abeni)

    - tools: ynl: add uns-admin-perm to genetlink legacy (Davide Caratti)
    - tools: ynl-gen: add support for exact-len validation (Davide Caratti)
    - net: mptcp: convert netlink from small_ops to ops (Davide Caratti)
    - Documentation: netlink: add a YAML spec for mptcp (Davide Caratti)
    - uapi: mptcp: use header file generated from YAML spec (Davide Caratti)
    - net: mptcp: rename netlink handlers to
mptcp_pm_nl_<blah>_{doit,dumpit} (Davide Caratti)
    - net: mptcp: use policy generated by YAML spec (Davide Caratti)

    - mptcp: properly account fastopen data (Paolo Abeni)
    - mptcp: use plain bool instead of custom binary enum (Paolo Abeni)
    - tcp: define initial scaling factor value as a macro (Paolo Abeni)
    - mptcp: give rcvlowat some love (Paolo Abeni)
    - mptcp: use copy_from_iter helpers on transmit (Paolo Abeni)
    - mptcp: consolidate sockopt synchronization (Paolo Abeni)
    - mptcp: ignore notsent_lowat setting at the subflow level (Paolo Abeni)
    - mptcp: refactor sndbuf auto-tuning (Paolo Abeni)

    - mptcp: drop useless ssk in pm_subflow_check_next (Geliang Tang)
    - mptcp: use mptcp_check_fallback helper (Geliang Tang)
    - mptcp: use mptcp_get_ext helper (Geliang Tang)
    - mptcp: move sk assignment statement ahead (Geliang Tang)
    - mptcp: define more local variables sk (Geliang Tang)
    - selftests: mptcp: sockopt: drop mptcp_connect var (Geliang Tang)
    - selftests: mptcp: display simult in extra_msg (Geliang Tang)

    - mptcp: add mptcpi_subflows_total counter (Geliang Tang)
    - selftests: mptcp: add evts_get_info helper (Geliang Tang)
    - selftests: mptcp: add chk_subflows_total helper (Geliang Tang)
    - selftests: mptcp: update userspace pm test helpers (Geliang Tang)
    - selftests: mptcp: userspace pm create id 0 subflow (Geliang Tang)
    - mptcp: userspace pm rename remove_err to out (Geliang Tang)
    - selftests: mptcp: userspace pm remove initial subflow (Geliang Tang)
    - selftests: mptcp: userspace pm send RM_ADDR for ID 0 (Geliang Tang)

    - selftests: mptcp: add mptcp_lib_kill_wait (Geliang Tang)
    - selftests: mptcp: add mptcp_lib_is_v6 (Geliang Tang)
    - selftests: mptcp: add mptcp_lib_get_counter (Geliang Tang)
    - selftests: mptcp: add missing oflag=append (Geliang Tang)
    - selftests: mptcp: add mptcp_lib_make_file (Geliang Tang)
    - selftests: mptcp: add mptcp_lib_check_transfer (Geliang Tang)
    - selftests: mptcp: add mptcp_lib_wait_local_port_listen (Geliang Tang)



Just a few notes:

In -net, 2 patches introduce conflicts with what is queued for net-next:

- "selftests: mptcp: fix wait_rm_addr/sf parameters" conflicts with:
  - "selftests: mptcp: update userspace pm test helper"
    → the patch fixes the same issue but in different functions

- "mptcp: userspace pm send RM_ADDR for ID 0" conflicts with:
  - "net: mptcp: rename netlink handlers to
mptcp_pm_nl_<blah>_{doit,dumpit}"
    → the conflict is easy to fix: we want to put a function before one
that is being renamed

  - "mptcp: define more local variables sk"
    → also easy to fix: one line in the context that has changed

Because these fixes don't seem critical and because we are getting
closer to have a new release, I think it might be better to send these 3
fixes with the new feature (but keep them at the beginning of the
series). I guess if a note is added in the cover-letter message
explaining it is easier like that, and it is fine to delay the fixes, it
should be OK. WDYT?

Also, about the MPTCP NL YAML specs series where a v2 was needed: it
looks OK to me, but I don't know if Paolo wants to double-check the last
modifications from Davide before sending them. There is a conflict with
one patch from this series and one for -net (see above). I think it
might be better to send this YAML specs series first, then the other
patches.

I think Paolo's patches for net-next can be sent in parallel to Davide's
patches.


Do you think you can send all these patches, please? :)

Cheers,
Matt

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: Patches for netdev (for 6.7)
  2023-10-23  0:12 Patches for netdev (for 6.7) Matthieu Baerts
@ 2023-10-23 16:44 ` Mat Martineau
  0 siblings, 0 replies; 2+ messages in thread
From: Mat Martineau @ 2023-10-23 16:44 UTC (permalink / raw)
  To: Matthieu Baerts; +Cc: MPTCP Upstream, Paolo Abeni

[-- Attachment #1: Type: text/plain, Size: 2368 bytes --]

On Mon, 23 Oct 2023, Matthieu Baerts wrote:

> Hi Mat,
>
> Regarding the patches we might want to send to netdev this week, I think
> all the ones for -net and net-next can go.
>
> ...

Hi Matthieu -

Thanks for summarizing the state of our trees and the net/net-next 
conflicts.

> Just a few notes:
>
> In -net, 2 patches introduce conflicts with what is queued for net-next:
>
> - "selftests: mptcp: fix wait_rm_addr/sf parameters" conflicts with:
>  - "selftests: mptcp: update userspace pm test helper"
>    → the patch fixes the same issue but in different functions
>
> - "mptcp: userspace pm send RM_ADDR for ID 0" conflicts with:
>  - "net: mptcp: rename netlink handlers to
> mptcp_pm_nl_<blah>_{doit,dumpit}"
>    → the conflict is easy to fix: we want to put a function before one
> that is being renamed
>
>  - "mptcp: define more local variables sk"
>    → also easy to fix: one line in the context that has changed
>
> Because these fixes don't seem critical and because we are getting
> closer to have a new release, I think it might be better to send these 3
> fixes with the new feature (but keep them at the beginning of the
> series). I guess if a note is added in the cover-letter message
> explaining it is easier like that, and it is fine to delay the fixes, it
> should be OK. WDYT?
>

Ok, I agree that those -net patches are fine to go to net-next rather than 
introduce the net/net-next conflict issues or delay the other series. They 
will not be too delayed in getting to Linus' tree.

> Also, about the MPTCP NL YAML specs series where a v2 was needed: it
> looks OK to me, but I don't know if Paolo wants to double-check the last
> modifications from Davide before sending them. There is a conflict with
> one patch from this series and one for -net (see above). I think it
> might be better to send this YAML specs series first, then the other
> patches.
>

Yes, will send this v2 series first.

> I think Paolo's patches for net-next can be sent in parallel to Davide's
> patches.
>

While I normally try to avoid having more than one series waiting for 
review, this is a unique situation with the v2 series. It should work to 
set them up without any conflicts so I will try sending both (unless Paolo 
says "don't do that" :) )

>
> Do you think you can send all these patches, please? :)
>

I will - have a good week!


- Mat

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2023-10-23 16:44 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2023-10-23  0:12 Patches for netdev (for 6.7) Matthieu Baerts
2023-10-23 16:44 ` Mat Martineau

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox