Netdev List
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: Eric Dumazet <eric.dumazet@gmail.com>
Cc: Eric Dumazet <edumazet@google.com>,
	"David S. Miller" <davem@davemloft.net>,
	netdev@vger.kernel.org, Yuchung Cheng <ycheng@google.com>,
	Neal Cardwell <ncardwell@google.com>,
	Christoph Paasch <christoph.paasch@uclouvain.be>,
	Julia Lawall <julia.lawall@lip6.fr>
Subject: Re: [PATCH v3 net-next 1/3] ipv4: rename ip_options_echo to __ip_options_echo()
Date: Thu, 25 Sep 2014 13:49:23 -0700	[thread overview]
Message-ID: <1411678163.3460.9.camel@joe-AO725> (raw)
In-Reply-To: <1411677484.16953.43.camel@edumazet-glaptop2.roam.corp.google.com>

On Thu, 2014-09-25 at 13:38 -0700, Eric Dumazet wrote:
> On Thu, 2014-09-25 at 13:30 -0700, Joe Perches wrote:
> 
> > Unrelated:
> > 
> > I wonder how much effort, if any, should be made to convert
> > struct sk_buff * to const struct sk_buff * where appropriate.
> > 
> > For instance:
> > 
> > This __ip_options_echo could use const struct sk_buff *skb
> > if fib_compute_spec_dst was changed to const struct sk_buff *skb.
> 
> Well, this seems something certainly doable, as a follow up ;)

It's doable, but it seems a non-trivial inspection task.

I believe coccinelle does not have the ability to automate this.

  reply	other threads:[~2014-09-25 20:49 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-09-25 20:14 [PATCH v3 net-next 0/3] tcp: better TCP_SKB_CB layout Eric Dumazet
2014-09-25 20:14 ` [PATCH v3 net-next 1/3] ipv4: rename ip_options_echo to __ip_options_echo() Eric Dumazet
2014-09-25 20:30   ` Joe Perches
2014-09-25 20:38     ` Eric Dumazet
2014-09-25 20:49       ` Joe Perches [this message]
2014-09-26  5:29         ` Julia Lawall
2014-09-26  8:08           ` Joe Perches
2014-09-26  6:21         ` Julia Lawall
2014-09-25 20:14 ` [PATCH v3 net-next 2/3] ipv6: add a struct inet6_skb_parm param to ipv6_opt_accepted() Eric Dumazet
2014-09-25 20:14 ` [PATCH v3 net-next 3/3] tcp: better TCP_SKB_CB layout to reduce cache line misses Eric Dumazet
2014-09-27 16:46   ` Eric Dumazet

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1411678163.3460.9.camel@joe-AO725 \
    --to=joe@perches.com \
    --cc=christoph.paasch@uclouvain.be \
    --cc=davem@davemloft.net \
    --cc=edumazet@google.com \
    --cc=eric.dumazet@gmail.com \
    --cc=julia.lawall@lip6.fr \
    --cc=ncardwell@google.com \
    --cc=netdev@vger.kernel.org \
    --cc=ycheng@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox