* [PATCH net-next] tun: avoid unnecessary READ_ONCE in tun_net_xmit
@ 2017-12-06 3:11 Willem de Bruijn
2017-12-06 3:39 ` Jason Wang
2017-12-06 20:09 ` David Miller
0 siblings, 2 replies; 3+ messages in thread
From: Willem de Bruijn @ 2017-12-06 3:11 UTC (permalink / raw)
To: netdev; +Cc: jasowang, davem, Willem de Bruijn
From: Willem de Bruijn <willemb@google.com>
The statement no longer serves a purpose.
Commit fa35864e0bb7 ("tuntap: Fix for a race in accessing numqueues")
added the ACCESS_ONCE to avoid a race condition with skb_queue_len.
Commit 436accebb530 ("tuntap: remove unnecessary sk_receive_queue
length check during xmit") removed the affected skb_queue_len check.
Commit 96f84061620c ("tun: add eBPF based queue selection method")
split the function, reading the field a second time in the callee.
The temp variable is now only read once, so just remove it.
Signed-off-by: Willem de Bruijn <willemb@google.com>
---
drivers/net/tun.c | 4 +---
1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/drivers/net/tun.c b/drivers/net/tun.c
index 787cc35ef89b..c2ad8f3858d1 100644
--- a/drivers/net/tun.c
+++ b/drivers/net/tun.c
@@ -990,14 +990,12 @@ static netdev_tx_t tun_net_xmit(struct sk_buff *skb, struct net_device *dev)
struct tun_struct *tun = netdev_priv(dev);
int txq = skb->queue_mapping;
struct tun_file *tfile;
- u32 numqueues = 0;
rcu_read_lock();
tfile = rcu_dereference(tun->tfiles[txq]);
- numqueues = READ_ONCE(tun->numqueues);
/* Drop packet if interface is not attached */
- if (txq >= numqueues)
+ if (txq >= tun->numqueues)
goto drop;
if (!rcu_dereference(tun->steering_prog))
--
2.15.1.424.g9478a66081-goog
^ permalink raw reply related [flat|nested] 3+ messages in thread* Re: [PATCH net-next] tun: avoid unnecessary READ_ONCE in tun_net_xmit
2017-12-06 3:11 [PATCH net-next] tun: avoid unnecessary READ_ONCE in tun_net_xmit Willem de Bruijn
@ 2017-12-06 3:39 ` Jason Wang
2017-12-06 20:09 ` David Miller
1 sibling, 0 replies; 3+ messages in thread
From: Jason Wang @ 2017-12-06 3:39 UTC (permalink / raw)
To: Willem de Bruijn, netdev; +Cc: davem, Willem de Bruijn
On 2017年12月06日 11:11, Willem de Bruijn wrote:
> From: Willem de Bruijn <willemb@google.com>
>
> The statement no longer serves a purpose.
>
> Commit fa35864e0bb7 ("tuntap: Fix for a race in accessing numqueues")
> added the ACCESS_ONCE to avoid a race condition with skb_queue_len.
>
> Commit 436accebb530 ("tuntap: remove unnecessary sk_receive_queue
> length check during xmit") removed the affected skb_queue_len check.
>
> Commit 96f84061620c ("tun: add eBPF based queue selection method")
> split the function, reading the field a second time in the callee.
> The temp variable is now only read once, so just remove it.
>
> Signed-off-by: Willem de Bruijn <willemb@google.com>
> ---
> drivers/net/tun.c | 4 +---
> 1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/drivers/net/tun.c b/drivers/net/tun.c
> index 787cc35ef89b..c2ad8f3858d1 100644
> --- a/drivers/net/tun.c
> +++ b/drivers/net/tun.c
> @@ -990,14 +990,12 @@ static netdev_tx_t tun_net_xmit(struct sk_buff *skb, struct net_device *dev)
> struct tun_struct *tun = netdev_priv(dev);
> int txq = skb->queue_mapping;
> struct tun_file *tfile;
> - u32 numqueues = 0;
>
> rcu_read_lock();
> tfile = rcu_dereference(tun->tfiles[txq]);
> - numqueues = READ_ONCE(tun->numqueues);
>
> /* Drop packet if interface is not attached */
> - if (txq >= numqueues)
> + if (txq >= tun->numqueues)
> goto drop;
>
> if (!rcu_dereference(tun->steering_prog))
Acked-by: Jason Wang <jasowang@redhat.com>
Thanks
^ permalink raw reply [flat|nested] 3+ messages in thread* Re: [PATCH net-next] tun: avoid unnecessary READ_ONCE in tun_net_xmit
2017-12-06 3:11 [PATCH net-next] tun: avoid unnecessary READ_ONCE in tun_net_xmit Willem de Bruijn
2017-12-06 3:39 ` Jason Wang
@ 2017-12-06 20:09 ` David Miller
1 sibling, 0 replies; 3+ messages in thread
From: David Miller @ 2017-12-06 20:09 UTC (permalink / raw)
To: willemdebruijn.kernel; +Cc: netdev, jasowang, willemb
From: Willem de Bruijn <willemdebruijn.kernel@gmail.com>
Date: Tue, 5 Dec 2017 22:11:17 -0500
> From: Willem de Bruijn <willemb@google.com>
>
> The statement no longer serves a purpose.
>
> Commit fa35864e0bb7 ("tuntap: Fix for a race in accessing numqueues")
> added the ACCESS_ONCE to avoid a race condition with skb_queue_len.
>
> Commit 436accebb530 ("tuntap: remove unnecessary sk_receive_queue
> length check during xmit") removed the affected skb_queue_len check.
>
> Commit 96f84061620c ("tun: add eBPF based queue selection method")
> split the function, reading the field a second time in the callee.
> The temp variable is now only read once, so just remove it.
>
> Signed-off-by: Willem de Bruijn <willemb@google.com>
Applied, thanks Willem.
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2017-12-06 20:09 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2017-12-06 3:11 [PATCH net-next] tun: avoid unnecessary READ_ONCE in tun_net_xmit Willem de Bruijn
2017-12-06 3:39 ` Jason Wang
2017-12-06 20:09 ` David Miller
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox