Netdev List
 help / color / mirror / Atom feed
* [PATCH RESEND net-next] net: airoha: Make use of the helper function dev_err_probe()
@ 2026-06-30  1:52 Lei Zhu
  2026-06-30 10:38 ` Lorenzo Bianconi
  0 siblings, 1 reply; 4+ messages in thread
From: Lei Zhu @ 2026-06-30  1:52 UTC (permalink / raw)
  To: lorenzo, andrew+netdev, davem, edumazet, kuba, pabeni; +Cc: netdev, zhulei_szu

From: Lei Zhu <zhulei@kylinos.cn>

Use dev_err_probe() to reduce code size and simplify the code.

Signed-off-by: Lei Zhu <zhulei@kylinos.cn>
---
The last submission was when net-next is closed.Resending it.

 drivers/net/ethernet/airoha/airoha_eth.c | 21 +++++++++------------
 1 file changed, 9 insertions(+), 12 deletions(-)

diff --git a/drivers/net/ethernet/airoha/airoha_eth.c b/drivers/net/ethernet/airoha/airoha_eth.c
index 31cdb11cd78d..189f64e83a46 100644
--- a/drivers/net/ethernet/airoha/airoha_eth.c
+++ b/drivers/net/ethernet/airoha/airoha_eth.c
@@ -3071,10 +3071,9 @@ static int airoha_probe(struct platform_device *pdev)
 	eth->dev = &pdev->dev;
 
 	err = dma_set_mask_and_coherent(eth->dev, DMA_BIT_MASK(32));
-	if (err) {
-		dev_err(eth->dev, "failed configuring DMA mask\n");
-		return err;
-	}
+	if (err)
+		return dev_err_probe(eth->dev, err,
+				     "failed configuring DMA mask\n");
 
 	eth->fe_regs = devm_platform_ioremap_resource_byname(pdev, "fe");
 	if (IS_ERR(eth->fe_regs))
@@ -3087,10 +3086,9 @@ static int airoha_probe(struct platform_device *pdev)
 	err = devm_reset_control_bulk_get_exclusive(eth->dev,
 						    ARRAY_SIZE(eth->rsts),
 						    eth->rsts);
-	if (err) {
-		dev_err(eth->dev, "failed to get bulk reset lines\n");
-		return err;
-	}
+	if (err)
+		return dev_err_probe(eth->dev, err,
+				     "failed to get bulk reset lines\n");
 
 	xsi_rsts = devm_kcalloc(eth->dev,
 				eth->soc->num_xsi_rsts, sizeof(*xsi_rsts),
@@ -3105,10 +3103,9 @@ static int airoha_probe(struct platform_device *pdev)
 	err = devm_reset_control_bulk_get_exclusive(eth->dev,
 						    eth->soc->num_xsi_rsts,
 						    eth->xsi_rsts);
-	if (err) {
-		dev_err(eth->dev, "failed to get bulk xsi reset lines\n");
-		return err;
-	}
+	if (err)
+		return dev_err_probe(eth->dev, err,
+				     "failed to get bulk xsi reset lines\n");
 
 	eth->napi_dev = alloc_netdev_dummy(0);
 	if (!eth->napi_dev)
-- 
2.25.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH RESEND net-next] net: airoha: Make use of the helper function dev_err_probe()
  2026-06-30  1:52 [PATCH RESEND net-next] net: airoha: Make use of the helper function dev_err_probe() Lei Zhu
@ 2026-06-30 10:38 ` Lorenzo Bianconi
  2026-07-01  8:01   ` zhulei
  0 siblings, 1 reply; 4+ messages in thread
From: Lorenzo Bianconi @ 2026-06-30 10:38 UTC (permalink / raw)
  To: Lei Zhu; +Cc: andrew+netdev, davem, edumazet, kuba, pabeni, netdev

[-- Attachment #1: Type: text/plain, Size: 2262 bytes --]

> From: Lei Zhu <zhulei@kylinos.cn>
> 
> Use dev_err_probe() to reduce code size and simplify the code.
> 
> Signed-off-by: Lei Zhu <zhulei@kylinos.cn>
> ---
> The last submission was when net-next is closed.Resending it.
> 
>  drivers/net/ethernet/airoha/airoha_eth.c | 21 +++++++++------------
>  1 file changed, 9 insertions(+), 12 deletions(-)
> 
> diff --git a/drivers/net/ethernet/airoha/airoha_eth.c b/drivers/net/ethernet/airoha/airoha_eth.c
> index 31cdb11cd78d..189f64e83a46 100644
> --- a/drivers/net/ethernet/airoha/airoha_eth.c
> +++ b/drivers/net/ethernet/airoha/airoha_eth.c
> @@ -3071,10 +3071,9 @@ static int airoha_probe(struct platform_device *pdev)
>  	eth->dev = &pdev->dev;
>  
>  	err = dma_set_mask_and_coherent(eth->dev, DMA_BIT_MASK(32));

I do not think dma_set_mask_and_coherent() can return -EPROBE_DEFER, so there
is no point adding dev_err_probe() here.

Regards,
Lorenzo

> -	if (err) {
> -		dev_err(eth->dev, "failed configuring DMA mask\n");
> -		return err;
> -	}
> +	if (err)
> +		return dev_err_probe(eth->dev, err,
> +				     "failed configuring DMA mask\n");
>  
>  	eth->fe_regs = devm_platform_ioremap_resource_byname(pdev, "fe");
>  	if (IS_ERR(eth->fe_regs))
> @@ -3087,10 +3086,9 @@ static int airoha_probe(struct platform_device *pdev)
>  	err = devm_reset_control_bulk_get_exclusive(eth->dev,
>  						    ARRAY_SIZE(eth->rsts),
>  						    eth->rsts);
> -	if (err) {
> -		dev_err(eth->dev, "failed to get bulk reset lines\n");
> -		return err;
> -	}
> +	if (err)
> +		return dev_err_probe(eth->dev, err,
> +				     "failed to get bulk reset lines\n");
>  
>  	xsi_rsts = devm_kcalloc(eth->dev,
>  				eth->soc->num_xsi_rsts, sizeof(*xsi_rsts),
> @@ -3105,10 +3103,9 @@ static int airoha_probe(struct platform_device *pdev)
>  	err = devm_reset_control_bulk_get_exclusive(eth->dev,
>  						    eth->soc->num_xsi_rsts,
>  						    eth->xsi_rsts);
> -	if (err) {
> -		dev_err(eth->dev, "failed to get bulk xsi reset lines\n");
> -		return err;
> -	}
> +	if (err)
> +		return dev_err_probe(eth->dev, err,
> +				     "failed to get bulk xsi reset lines\n");
>  
>  	eth->napi_dev = alloc_netdev_dummy(0);
>  	if (!eth->napi_dev)
> -- 
> 2.25.1
> 

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 228 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re:Re: [PATCH RESEND net-next] net: airoha: Make use of the helper function dev_err_probe()
  2026-06-30 10:38 ` Lorenzo Bianconi
@ 2026-07-01  8:01   ` zhulei
  2026-07-01  8:17     ` Lorenzo Bianconi
  0 siblings, 1 reply; 4+ messages in thread
From: zhulei @ 2026-07-01  8:01 UTC (permalink / raw)
  To: Lorenzo Bianconi; +Cc: andrew+netdev, davem, edumazet, kuba, pabeni, netdev

At 2026-06-30 18:38:38, "Lorenzo Bianconi" <lorenzo@kernel.org> wrote:
>> From: Lei Zhu <zhulei@kylinos.cn>
>> 
>> Use dev_err_probe() to reduce code size and simplify the code.
>> 
>> Signed-off-by: Lei Zhu <zhulei@kylinos.cn>
>> ---
>> The last submission was when net-next is closed.Resending it.
>> 
>>  drivers/net/ethernet/airoha/airoha_eth.c | 21 +++++++++------------
>>  1 file changed, 9 insertions(+), 12 deletions(-)
>> 
>> diff --git a/drivers/net/ethernet/airoha/airoha_eth.c b/drivers/net/ethernet/airoha/airoha_eth.c
>> index 31cdb11cd78d..189f64e83a46 100644
>> --- a/drivers/net/ethernet/airoha/airoha_eth.c
>> +++ b/drivers/net/ethernet/airoha/airoha_eth.c
>> @@ -3071,10 +3071,9 @@ static int airoha_probe(struct platform_device *pdev)
>>  	eth->dev = &pdev->dev;
>>  
>>  	err = dma_set_mask_and_coherent(eth->dev, DMA_BIT_MASK(32));
>
>I do not think dma_set_mask_and_coherent() can return -EPROBE_DEFER, so there
>is no point adding dev_err_probe() here.
>
>Regards,
>Lorenzo
>
Hi Lorenzo,

Thanks for your review.

Before making this patch, I referred to the comments of dev_err_probe:
"even if @err is known to never be -EPROBE_DEFER, the benefit compared
to a normal dev_err() is the standardized format of the error code."

In the probe function, I noticed devm_platform_ioremap_resource_byname
already uses dev_err_probe, while other functions still use dev_err.
Replace them with dev_err_probe for consistency, more compact error paths,
and better readability of error codes.

Best regards
Lei


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH RESEND net-next] net: airoha: Make use of the helper function dev_err_probe()
  2026-07-01  8:01   ` zhulei
@ 2026-07-01  8:17     ` Lorenzo Bianconi
  0 siblings, 0 replies; 4+ messages in thread
From: Lorenzo Bianconi @ 2026-07-01  8:17 UTC (permalink / raw)
  To: zhulei; +Cc: andrew+netdev, davem, edumazet, kuba, pabeni, netdev

[-- Attachment #1: Type: text/plain, Size: 1820 bytes --]

> At 2026-06-30 18:38:38, "Lorenzo Bianconi" <lorenzo@kernel.org> wrote:
> >> From: Lei Zhu <zhulei@kylinos.cn>
> >> 
> >> Use dev_err_probe() to reduce code size and simplify the code.
> >> 
> >> Signed-off-by: Lei Zhu <zhulei@kylinos.cn>
> >> ---
> >> The last submission was when net-next is closed.Resending it.
> >> 
> >>  drivers/net/ethernet/airoha/airoha_eth.c | 21 +++++++++------------
> >>  1 file changed, 9 insertions(+), 12 deletions(-)
> >> 
> >> diff --git a/drivers/net/ethernet/airoha/airoha_eth.c b/drivers/net/ethernet/airoha/airoha_eth.c
> >> index 31cdb11cd78d..189f64e83a46 100644
> >> --- a/drivers/net/ethernet/airoha/airoha_eth.c
> >> +++ b/drivers/net/ethernet/airoha/airoha_eth.c
> >> @@ -3071,10 +3071,9 @@ static int airoha_probe(struct platform_device *pdev)
> >>  	eth->dev = &pdev->dev;
> >>  
> >>  	err = dma_set_mask_and_coherent(eth->dev, DMA_BIT_MASK(32));
> >
> >I do not think dma_set_mask_and_coherent() can return -EPROBE_DEFER, so there
> >is no point adding dev_err_probe() here.
> >
> >Regards,
> >Lorenzo
> >
> Hi Lorenzo,
> 
> Thanks for your review.
> 
> Before making this patch, I referred to the comments of dev_err_probe:
> "even if @err is known to never be -EPROBE_DEFER, the benefit compared
> to a normal dev_err() is the standardized format of the error code."
> 
> In the probe function, I noticed devm_platform_ioremap_resource_byname
> already uses dev_err_probe, while other functions still use dev_err.
> Replace them with dev_err_probe for consistency, more compact error paths,
> and better readability of error codes.
> 
> Best regards
> Lei
> 

I do not have a strong opinion about it, from my pov it is more clear if we use
dev_err_probe() when it really does something, but up to you.

Regards,
Lorenzo

[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 228 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2026-07-01  8:17 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-06-30  1:52 [PATCH RESEND net-next] net: airoha: Make use of the helper function dev_err_probe() Lei Zhu
2026-06-30 10:38 ` Lorenzo Bianconi
2026-07-01  8:01   ` zhulei
2026-07-01  8:17     ` Lorenzo Bianconi

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox