* [PATCH] Rename 'BRANCH' variable to 'SRC_BRANCH' for clearness @ 2015-08-21 21:38 Otavio Salvador 2015-08-21 21:49 ` Khem Raj 0 siblings, 1 reply; 7+ messages in thread From: Otavio Salvador @ 2015-08-21 21:38 UTC (permalink / raw) To: OpenEmbedded Core Mailing List; +Cc: Otavio Salvador The 'BRANCH' variable name has no explicit relation with the SRC_URI. Using 'SRC_BRANCH' makes it more obvious and easier to identify. This patch makes the use consistent across the metadata. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> --- meta/recipes-core/glibc/cross-localedef-native_2.22.bb | 4 ++-- meta/recipes-core/glibc/glibc_2.22.bb | 4 ++-- meta/recipes-devtools/mmc/mmc-utils_git.bb | 4 ++-- 3 files changed, 6 insertions(+), 6 deletions(-) diff --git a/meta/recipes-core/glibc/cross-localedef-native_2.22.bb b/meta/recipes-core/glibc/cross-localedef-native_2.22.bb index 2153ece..869cb3a 100644 --- a/meta/recipes-core/glibc/cross-localedef-native_2.22.bb +++ b/meta/recipes-core/glibc/cross-localedef-native_2.22.bb @@ -14,10 +14,10 @@ inherit autotools FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:" -BRANCH ?= "release/${PV}/master" +SRC_BRANCH ?= "release/${PV}/master" GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git" -SRC_URI = "${GLIBC_GIT_URI};branch=${BRANCH};name=glibc \ +SRC_URI = "${GLIBC_GIT_URI};branch=${SRC_BRANCH};name=glibc \ git://github.com/kraj/localedef;branch=master;name=localedef;destsuffix=git/localedef \ file://fix_for_centos_5.8.patch \ ${EGLIBCPATCHES} \ diff --git a/meta/recipes-core/glibc/glibc_2.22.bb b/meta/recipes-core/glibc/glibc_2.22.bb index 6aaf722..c02b6c8 100644 --- a/meta/recipes-core/glibc/glibc_2.22.bb +++ b/meta/recipes-core/glibc/glibc_2.22.bb @@ -9,11 +9,11 @@ DEPENDS += "gperf-native kconfig-frontends-native" SRCREV ?= "a34d1c6afc86521d6ad17662a3b5362d8481514c" -BRANCH ?= "release/${PV}/master" +SRC_BRANCH ?= "release/${PV}/master" GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git" -SRC_URI = "${GLIBC_GIT_URI};branch=${BRANCH};name=glibc \ +SRC_URI = "${GLIBC_GIT_URI};branch=${SRC_BRANCH};name=glibc \ file://0004-Backport-https-sourceware.org-ml-libc-ports-2007-12-.patch \ file://0005-fsl-e500-e5500-e6500-603e-fsqrt-implementation.patch \ file://0006-readlib-Add-OECORE_KNOWN_INTERPRETER_NAMES-to-known-.patch \ diff --git a/meta/recipes-devtools/mmc/mmc-utils_git.bb b/meta/recipes-devtools/mmc/mmc-utils_git.bb index 8950360..c6947e8 100644 --- a/meta/recipes-devtools/mmc/mmc-utils_git.bb +++ b/meta/recipes-devtools/mmc/mmc-utils_git.bb @@ -3,12 +3,12 @@ HOMEPAGE = "http://git.kernel.org/cgit/linux/kernel/git/cjb/mmc-utils.git/" LICENSE = "GPLv2" LIC_FILES_CHKSUM = "file://mmc.c;beginline=1;endline=17;md5=d7747fc87f1eb22b946ef819969503f0" -BRANCH ?= "master" +SRC_BRANCH ?= "master" SRCREV = "f4eb241519f8d500ce6068a70d2389be39ac5189" PV = "0.1" -SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git;branch=${BRANCH} \ +SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git;branch=${SRC_BRANCH} \ file://0001-mmc.h-don-t-include-asm-generic-int-ll64.h.patch" S = "${WORKDIR}/git" -- 2.5.0 ^ permalink raw reply related [flat|nested] 7+ messages in thread
* Re: [PATCH] Rename 'BRANCH' variable to 'SRC_BRANCH' for clearness 2015-08-21 21:38 [PATCH] Rename 'BRANCH' variable to 'SRC_BRANCH' for clearness Otavio Salvador @ 2015-08-21 21:49 ` Khem Raj 2015-08-21 21:58 ` Otavio Salvador 0 siblings, 1 reply; 7+ messages in thread From: Khem Raj @ 2015-08-21 21:49 UTC (permalink / raw) To: Otavio Salvador; +Cc: OpenEmbedded Core Mailing List [-- Attachment #1: Type: text/plain, Size: 3552 bytes --] > On Aug 21, 2015, at 2:38 PM, Otavio Salvador <otavio@ossystems.com.br> wrote: > > The 'BRANCH' variable name has no explicit relation with the > SRC_URI. Using 'SRC_BRANCH' makes it more obvious and easier to > identify. Look good to me, just may be avoid ‘_’ and call it SRCBRANCH > > This patch makes the use consistent across the metadata. > > Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> > --- > > meta/recipes-core/glibc/cross-localedef-native_2.22.bb | 4 ++-- > meta/recipes-core/glibc/glibc_2.22.bb | 4 ++-- > meta/recipes-devtools/mmc/mmc-utils_git.bb | 4 ++-- > 3 files changed, 6 insertions(+), 6 deletions(-) > > diff --git a/meta/recipes-core/glibc/cross-localedef-native_2.22.bb b/meta/recipes-core/glibc/cross-localedef-native_2.22.bb > index 2153ece..869cb3a 100644 > --- a/meta/recipes-core/glibc/cross-localedef-native_2.22.bb > +++ b/meta/recipes-core/glibc/cross-localedef-native_2.22.bb > @@ -14,10 +14,10 @@ inherit autotools > > FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:" > > -BRANCH ?= "release/${PV}/master" > +SRC_BRANCH ?= "release/${PV}/master" > GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git" > > -SRC_URI = "${GLIBC_GIT_URI};branch=${BRANCH};name=glibc \ > +SRC_URI = "${GLIBC_GIT_URI};branch=${SRC_BRANCH};name=glibc \ > git://github.com/kraj/localedef;branch=master;name=localedef;destsuffix=git/localedef \ > file://fix_for_centos_5.8.patch \ > ${EGLIBCPATCHES} \ > diff --git a/meta/recipes-core/glibc/glibc_2.22.bb b/meta/recipes-core/glibc/glibc_2.22.bb > index 6aaf722..c02b6c8 100644 > --- a/meta/recipes-core/glibc/glibc_2.22.bb > +++ b/meta/recipes-core/glibc/glibc_2.22.bb > @@ -9,11 +9,11 @@ DEPENDS += "gperf-native kconfig-frontends-native" > > SRCREV ?= "a34d1c6afc86521d6ad17662a3b5362d8481514c" > > -BRANCH ?= "release/${PV}/master" > +SRC_BRANCH ?= "release/${PV}/master" > > GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git" > > -SRC_URI = "${GLIBC_GIT_URI};branch=${BRANCH};name=glibc \ > +SRC_URI = "${GLIBC_GIT_URI};branch=${SRC_BRANCH};name=glibc \ > file://0004-Backport-https-sourceware.org-ml-libc-ports-2007-12-.patch \ > file://0005-fsl-e500-e5500-e6500-603e-fsqrt-implementation.patch \ > file://0006-readlib-Add-OECORE_KNOWN_INTERPRETER_NAMES-to-known-.patch \ > diff --git a/meta/recipes-devtools/mmc/mmc-utils_git.bb b/meta/recipes-devtools/mmc/mmc-utils_git.bb > index 8950360..c6947e8 100644 > --- a/meta/recipes-devtools/mmc/mmc-utils_git.bb > +++ b/meta/recipes-devtools/mmc/mmc-utils_git.bb > @@ -3,12 +3,12 @@ HOMEPAGE = "http://git.kernel.org/cgit/linux/kernel/git/cjb/mmc-utils.git/" > LICENSE = "GPLv2" > LIC_FILES_CHKSUM = "file://mmc.c;beginline=1;endline=17;md5=d7747fc87f1eb22b946ef819969503f0" > > -BRANCH ?= "master" > +SRC_BRANCH ?= "master" > SRCREV = "f4eb241519f8d500ce6068a70d2389be39ac5189" > > PV = "0.1" > > -SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git;branch=${BRANCH} \ > +SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/cjb/mmc-utils.git;branch=${SRC_BRANCH} \ > file://0001-mmc.h-don-t-include-asm-generic-int-ll64.h.patch" > > S = "${WORKDIR}/git" > -- > 2.5.0 > > -- > _______________________________________________ > Openembedded-core mailing list > Openembedded-core@lists.openembedded.org > http://lists.openembedded.org/mailman/listinfo/openembedded-core [-- Attachment #2: Message signed with OpenPGP using GPGMail --] [-- Type: application/pgp-signature, Size: 211 bytes --] ^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: [PATCH] Rename 'BRANCH' variable to 'SRC_BRANCH' for clearness 2015-08-21 21:49 ` Khem Raj @ 2015-08-21 21:58 ` Otavio Salvador 2015-08-22 4:20 ` Randy MacLeod 2015-08-22 6:03 ` Khem Raj 0 siblings, 2 replies; 7+ messages in thread From: Otavio Salvador @ 2015-08-21 21:58 UTC (permalink / raw) To: Khem Raj; +Cc: Otavio Salvador, OpenEmbedded Core Mailing List On Fri, Aug 21, 2015 at 6:49 PM, Khem Raj <raj.khem@gmail.com> wrote: > >> On Aug 21, 2015, at 2:38 PM, Otavio Salvador <otavio@ossystems.com.br> wrote: >> >> The 'BRANCH' variable name has no explicit relation with the >> SRC_URI. Using 'SRC_BRANCH' makes it more obvious and easier to >> identify. > > Look good to me, just may be avoid ‘_’ and call it SRCBRANCH I did this initially but looking at how it looks in the source code, it seems SRC_BRANCH makes easier to spot the relation with SRC_URI. So I took the second. -- Otavio Salvador O.S. Systems http://www.ossystems.com.br http://code.ossystems.com.br Mobile: +55 (53) 9981-7854 Mobile: +1 (347) 903-9750 ^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: [PATCH] Rename 'BRANCH' variable to 'SRC_BRANCH' for clearness 2015-08-21 21:58 ` Otavio Salvador @ 2015-08-22 4:20 ` Randy MacLeod 2015-08-22 6:03 ` Khem Raj 1 sibling, 0 replies; 7+ messages in thread From: Randy MacLeod @ 2015-08-22 4:20 UTC (permalink / raw) To: openembedded-core On 2015-08-21 05:58 PM, Otavio Salvador wrote: > On Fri, Aug 21, 2015 at 6:49 PM, Khem Raj <raj.khem@gmail.com> wrote: >> >>> On Aug 21, 2015, at 2:38 PM, Otavio Salvador <otavio@ossystems.com.br> wrote: >>> >>> The 'BRANCH' variable name has no explicit relation with the >>> SRC_URI. Using 'SRC_BRANCH' makes it more obvious and easier to >>> identify. >> >> Look good to me, just may be avoid ‘_’ and call it SRCBRANCH > > I did this initially but looking at how it looks in the source code, > it seems SRC_BRANCH makes easier to spot the relation with SRC_URI. So > I took the second. +1 -- # Randy MacLeod. SMTS, Linux, Wind River Direct: 613.963.1350 | 350 Terry Fox Drive, Suite 200, Ottawa, ON, Canada, K2K 2W5 ^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: [PATCH] Rename 'BRANCH' variable to 'SRC_BRANCH' for clearness 2015-08-21 21:58 ` Otavio Salvador 2015-08-22 4:20 ` Randy MacLeod @ 2015-08-22 6:03 ` Khem Raj 2015-08-22 9:08 ` Richard Purdie 1 sibling, 1 reply; 7+ messages in thread From: Khem Raj @ 2015-08-22 6:03 UTC (permalink / raw) To: Otavio Salvador; +Cc: Otavio Salvador, OpenEmbedded Core Mailing List [-- Attachment #1: Type: text/plain, Size: 1008 bytes --] > On Aug 21, 2015, at 2:58 PM, Otavio Salvador <otavio.salvador@ossystems.com.br> wrote: > > On Fri, Aug 21, 2015 at 6:49 PM, Khem Raj <raj.khem@gmail.com> wrote: >> >>> On Aug 21, 2015, at 2:38 PM, Otavio Salvador <otavio@ossystems.com.br> wrote: >>> >>> The 'BRANCH' variable name has no explicit relation with the >>> SRC_URI. Using 'SRC_BRANCH' makes it more obvious and easier to >>> identify. >> >> Look good to me, just may be avoid ‘_’ and call it SRCBRANCH > > I did this initially but looking at how it looks in the source code, > it seems SRC_BRANCH makes easier to spot the relation with SRC_URI. So > I took the second. since bitbake use ‘_’ as a override separator, its less confusing if variables don’t have underscore in them for future collision. > > -- > Otavio Salvador O.S. Systems > http://www.ossystems.com.br http://code.ossystems.com.br > Mobile: +55 (53) 9981-7854 Mobile: +1 (347) 903-9750 [-- Attachment #2: Message signed with OpenPGP using GPGMail --] [-- Type: application/pgp-signature, Size: 211 bytes --] ^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: [PATCH] Rename 'BRANCH' variable to 'SRC_BRANCH' for clearness 2015-08-22 6:03 ` Khem Raj @ 2015-08-22 9:08 ` Richard Purdie 2015-08-22 10:48 ` Otavio Salvador 0 siblings, 1 reply; 7+ messages in thread From: Richard Purdie @ 2015-08-22 9:08 UTC (permalink / raw) To: Khem Raj; +Cc: Otavio Salvador, Otavio Salvador, OpenEmbedded Core Mailing List On Fri, 2015-08-21 at 23:03 -0700, Khem Raj wrote: > > On Aug 21, 2015, at 2:58 PM, Otavio Salvador <otavio.salvador@ossystems.com.br> wrote: > > > > On Fri, Aug 21, 2015 at 6:49 PM, Khem Raj <raj.khem@gmail.com> wrote: > >> > >>> On Aug 21, 2015, at 2:38 PM, Otavio Salvador <otavio@ossystems.com.br> wrote: > >>> > >>> The 'BRANCH' variable name has no explicit relation with the > >>> SRC_URI. Using 'SRC_BRANCH' makes it more obvious and easier to > >>> identify. > >> > >> Look good to me, just may be avoid ‘_’ and call it SRCBRANCH > > > > I did this initially but looking at how it looks in the source code, > > it seems SRC_BRANCH makes easier to spot the relation with SRC_URI. So > > I took the second. > > since bitbake use ‘_’ as a override separator, its less confusing if variables don’t have underscore in them > for future collision. Names with '_' in them might look better but there is a small price to pay for it in that bitbake then has to track whether "BRANCH" is an override. Obviously it does this in many cases already (e.g. URI from SRC_URI) but when you've looked at what the datastore actually has to do to keep the system working, you start to lean against creating more work for it. I continue to believe we should probably find a better syntax for overrides. If someone had a good alternative, it would probably be worth the pain of switching... I'm not saying we shouldn't take the above patch here, just that this is something which does have a cost and all the uses do mount up significantly. Cheers, Richard ^ permalink raw reply [flat|nested] 7+ messages in thread
* Re: [PATCH] Rename 'BRANCH' variable to 'SRC_BRANCH' for clearness 2015-08-22 9:08 ` Richard Purdie @ 2015-08-22 10:48 ` Otavio Salvador 0 siblings, 0 replies; 7+ messages in thread From: Otavio Salvador @ 2015-08-22 10:48 UTC (permalink / raw) To: Richard Purdie; +Cc: Otavio Salvador, OpenEmbedded Core Mailing List On Sat, Aug 22, 2015 at 6:08 AM, Richard Purdie <richard.purdie@linuxfoundation.org> wrote: > On Fri, 2015-08-21 at 23:03 -0700, Khem Raj wrote: >> > On Aug 21, 2015, at 2:58 PM, Otavio Salvador <otavio.salvador@ossystems.com.br> wrote: >> > >> > On Fri, Aug 21, 2015 at 6:49 PM, Khem Raj <raj.khem@gmail.com> wrote: >> >> >> >>> On Aug 21, 2015, at 2:38 PM, Otavio Salvador <otavio@ossystems.com.br> wrote: >> >>> >> >>> The 'BRANCH' variable name has no explicit relation with the >> >>> SRC_URI. Using 'SRC_BRANCH' makes it more obvious and easier to >> >>> identify. >> >> >> >> Look good to me, just may be avoid ‘_’ and call it SRCBRANCH >> > >> > I did this initially but looking at how it looks in the source code, >> > it seems SRC_BRANCH makes easier to spot the relation with SRC_URI. So >> > I took the second. >> >> since bitbake use ‘_’ as a override separator, its less confusing if variables don’t have underscore in them >> for future collision. > > Names with '_' in them might look better but there is a small price to > pay for it in that bitbake then has to track whether "BRANCH" is an > override. Obviously it does this in many cases already (e.g. URI from > SRC_URI) but when you've looked at what the datastore actually has to do > to keep the system working, you start to lean against creating more work > for it. > > I continue to believe we should probably find a better syntax for > overrides. If someone had a good alternative, it would probably be worth > the pain of switching... > > I'm not saying we shouldn't take the above patch here, just that this is > something which does have a cost and all the uses do mount up > significantly. So we should consider renaming SRC_URI for SRCURI. ;-) I am Ok sending it as SRCBRANCH but it does looks less obvious for news comers. -- Otavio Salvador O.S. Systems http://www.ossystems.com.br http://code.ossystems.com.br Mobile: +55 (53) 9981-7854 Mobile: +1 (347) 903-9750 ^ permalink raw reply [flat|nested] 7+ messages in thread
end of thread, other threads:[~2015-08-22 10:48 UTC | newest] Thread overview: 7+ messages (download: mbox.gz follow: Atom feed -- links below jump to the message on this page -- 2015-08-21 21:38 [PATCH] Rename 'BRANCH' variable to 'SRC_BRANCH' for clearness Otavio Salvador 2015-08-21 21:49 ` Khem Raj 2015-08-21 21:58 ` Otavio Salvador 2015-08-22 4:20 ` Randy MacLeod 2015-08-22 6:03 ` Khem Raj 2015-08-22 9:08 ` Richard Purdie 2015-08-22 10:48 ` Otavio Salvador
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox