From: Catalin Marinas <catalin.marinas@arm.com>
To: openrisc@lists.librecores.org
Subject: [OpenRISC] [PATCH 09/29] arm64: use asm-generic/cacheflush.h
Date: Fri, 22 May 2020 16:54:27 +0100 [thread overview]
Message-ID: <20200522155426.GI26492@gaia> (raw)
In-Reply-To: <20200515143646.3857579-10-hch@lst.de>
On Fri, May 15, 2020 at 04:36:26PM +0200, Christoph Hellwig wrote:
> ARM64 needs almost no cache flushing routines of its own. Rely on
> asm-generic/cacheflush.h for the defaults.
>
> Signed-off-by: Christoph Hellwig <hch@lst.de>
Acked-by: Catalin Marinas <catalin.marinas@arm.com>
next prev parent reply other threads:[~2020-05-22 15:54 UTC|newest]
Thread overview: 38+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-05-15 14:36 [OpenRISC] sort out the flush_icache_range mess v2 Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 01/29] arm: fix the flush_icache_range arguments in set_fiq_handler Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 02/29] nds32: unexport flush_icache_page Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 03/29] powerpc: unexport flush_icache_user_range Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 04/29] unicore32: remove flush_cache_user_range Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 05/29] asm-generic: fix the inclusion guards for cacheflush.h Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 06/29] asm-generic: don't include <linux/mm.h> in cacheflush.h Christoph Hellwig
2020-05-27 4:34 ` [OpenRISC] [PATCH] media: omap3isp: Shuffle cacheflush.h and include mm.h Nathan Chancellor
2020-05-27 5:10 ` Christoph Hellwig
2020-05-27 7:02 ` Geert Uytterhoeven
2020-05-27 8:13 ` Nathan Chancellor
2020-05-27 13:45 ` Laurent Pinchart
2020-05-15 14:36 ` [OpenRISC] [PATCH 07/29] asm-generic: improve the flush_dcache_page stub Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 08/29] alpha: use asm-generic/cacheflush.h Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 09/29] arm64: " Christoph Hellwig
2020-05-22 15:54 ` Catalin Marinas [this message]
2020-05-15 14:36 ` [OpenRISC] [PATCH 10/29] c6x: " Christoph Hellwig
2020-05-18 18:20 ` Mark Salter
2020-05-15 14:36 ` [OpenRISC] [PATCH 11/29] hexagon: " Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 12/29] ia64: " Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 13/29] microblaze: " Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 14/29] m68knommu: " Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 15/29] openrisc: " Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 16/29] powerpc: " Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 17/29] riscv: " Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 18/29] arm, sparc, unicore32: remove flush_icache_user_range Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 19/29] mm: rename flush_icache_user_range to flush_icache_user_page Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 20/29] asm-generic: add a flush_icache_user_range stub Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 21/29] sh: implement flush_icache_user_range Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 22/29] xtensa: " Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 23/29] arm: rename flush_cache_user_range to flush_icache_user_range Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 24/29] m68k: implement flush_icache_user_range Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 25/29] exec: only build read_code when needed Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 26/29] exec: use flush_icache_user_range in read_code Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 27/29] binfmt_flat: use flush_icache_user_range Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 28/29] nommu: use flush_icache_user_range in brk and mmap Christoph Hellwig
2020-05-15 14:36 ` [OpenRISC] [PATCH 29/29] module: move the set_fs hack for flush_icache_range to m68k Christoph Hellwig
2020-05-18 13:04 ` Jessica Yu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20200522155426.GI26492@gaia \
--to=catalin.marinas@arm.com \
--cc=openrisc@lists.librecores.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox