X86 platform drivers
 help / color / mirror / Atom feed
From: Hans de Goede <hdegoede@redhat.com>
To: "Sakari Ailus" <sakari.ailus@linux.intel.com>,
	"Daniel Scally" <djrscally@gmail.com>,
	"Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>
Cc: platform-driver-x86@vger.kernel.org,
	Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
	laurent.pinchart@ideasonboard.com, hverkuil@xs4all.nl,
	linux-media@vger.kernel.org
Subject: Re: [PATCH v4 0/3] int3472: Support GPIO con_id based on _HID
Date: Fri, 31 Jan 2025 10:16:38 +0100	[thread overview]
Message-ID: <0d2c594d-0bc9-4a96-a0f8-390a9efbfb3e@redhat.com> (raw)
In-Reply-To: <20250131073707.1082931-1-sakari.ailus@linux.intel.com>

Hi,

On 31-Jan-25 8:37 AM, Sakari Ailus wrote:
> Hi folks,
> 
> One patch turned into a set, the second patch being the original one.
> 
> since v3:
> 
> - Add a patch (first one) to switch to unsigned long type for polarity
>   field and renames it as gpio_flags.
> 
> - Use a polarity_low boolean field for indicating the GPIO polarity. This
>   is turned to gpio_flags in int3472_get_con_id_and_polarity().
> 
> - Put the new polarity_low bool field next to the u8's for better struct
>   packing.
> 
> - Add a patch (last one) to rename "func" as "con_id" which is used
>   throughout the GPIO framework.

Thanks the whole series looks good to me:

Reviewed-by: Hans de Goede <hdegoede@redhat.com>

for the series.

Regards,

Hans


p.s.

Did you see my remarks about rewriting the INT3472 code to have it
do all the power-sequencing itself in the "RFC: How to deal with the INT3472
handshake GPIO found on Intel IPU6 MTL?" thread ?



  parent reply	other threads:[~2025-01-31  9:16 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-01-31  7:37 [PATCH v4 0/3] int3472: Support GPIO con_id based on _HID Sakari Ailus
2025-01-31  7:37 ` [PATCH v4 1/3] platform/x86: int3472: Use correct type for "polarity", call it gpio_flags Sakari Ailus
2025-01-31  7:37 ` [PATCH v4 2/3] platform/x86: int3472: Call "reset" GPIO "enable" for INT347E Sakari Ailus
2025-01-31 11:22   ` Andy Shevchenko
2025-01-31 11:57     ` Sakari Ailus
2025-01-31 17:20       ` Andy Shevchenko
2025-01-31  7:37 ` [PATCH v4 3/3] platform/x86: int3472: Call "func" "con_id" instead Sakari Ailus
2025-01-31  9:16 ` Hans de Goede [this message]
2025-01-31 11:24 ` [PATCH v4 0/3] int3472: Support GPIO con_id based on _HID Andy Shevchenko

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=0d2c594d-0bc9-4a96-a0f8-390a9efbfb3e@redhat.com \
    --to=hdegoede@redhat.com \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=djrscally@gmail.com \
    --cc=hverkuil@xs4all.nl \
    --cc=ilpo.jarvinen@linux.intel.com \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=linux-media@vger.kernel.org \
    --cc=platform-driver-x86@vger.kernel.org \
    --cc=sakari.ailus@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox