From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Sakari Ailus <sakari.ailus@linux.intel.com>
Cc: "Daniel Scally" <djrscally@gmail.com>,
"Hans de Goede" <hdegoede@redhat.com>,
"Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>,
platform-driver-x86@vger.kernel.org,
laurent.pinchart@ideasonboard.com, hverkuil@xs4all.nl,
linux-media@vger.kernel.org
Subject: Re: [PATCH v4 2/3] platform/x86: int3472: Call "reset" GPIO "enable" for INT347E
Date: Fri, 31 Jan 2025 13:22:19 +0200 [thread overview]
Message-ID: <Z5yya8BIK9GBtVEM@smile.fi.intel.com> (raw)
In-Reply-To: <20250131073707.1082931-3-sakari.ailus@linux.intel.com>
On Fri, Jan 31, 2025 at 09:37:06AM +0200, Sakari Ailus wrote:
> The DT bindings for ov7251 specify "enable" GPIO (xshutdown in
> documentation) but the int3472 indiscriminately provides this as a "reset"
> GPIO to sensor drivers. Take this into account by assigning it as "enable"
> with active high polarity for INT347E devices, i.e. ov7251. "reset" with
> active low polarity remains the default GPIO name for other devices.
...
> +static void int3472_get_func_and_polarity(struct acpi_device *adev, u8 *type,
> + const char **func, unsigned long *gpio_flags)
> {
> - switch (type) {
> + unsigned int i;
> +
> + for (i = 0; i < ARRAY_SIZE(int3472_gpio_map); i++) {
> + if (*type != int3472_gpio_map[i].type_from ||
> + !acpi_dev_hid_uid_match(adev, int3472_gpio_map[i].hid, NULL))
> + continue;
I think in a split form it is easier to read and maintain:
if (!acpi_dev_hid_uid_match(adev, int3472_gpio_map[i].hid, NULL))
continue;
if (*type != int3472_gpio_map[i].type_from)
continue;
> + *type = int3472_gpio_map[i].type_to;
> + *gpio_flags = int3472_gpio_map[i].polarity_low ?
> + GPIO_ACTIVE_LOW : GPIO_ACTIVE_HIGH;
Still can be one line (100 characters). But in this case I have no strong
preference. Up to Hans.
> + *func = int3472_gpio_map[i].func;
> + return;
> + }
--
With Best Regards,
Andy Shevchenko
next prev parent reply other threads:[~2025-01-31 11:22 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-01-31 7:37 [PATCH v4 0/3] int3472: Support GPIO con_id based on _HID Sakari Ailus
2025-01-31 7:37 ` [PATCH v4 1/3] platform/x86: int3472: Use correct type for "polarity", call it gpio_flags Sakari Ailus
2025-01-31 7:37 ` [PATCH v4 2/3] platform/x86: int3472: Call "reset" GPIO "enable" for INT347E Sakari Ailus
2025-01-31 11:22 ` Andy Shevchenko [this message]
2025-01-31 11:57 ` Sakari Ailus
2025-01-31 17:20 ` Andy Shevchenko
2025-01-31 7:37 ` [PATCH v4 3/3] platform/x86: int3472: Call "func" "con_id" instead Sakari Ailus
2025-01-31 9:16 ` [PATCH v4 0/3] int3472: Support GPIO con_id based on _HID Hans de Goede
2025-01-31 11:24 ` Andy Shevchenko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Z5yya8BIK9GBtVEM@smile.fi.intel.com \
--to=andriy.shevchenko@linux.intel.com \
--cc=djrscally@gmail.com \
--cc=hdegoede@redhat.com \
--cc=hverkuil@xs4all.nl \
--cc=ilpo.jarvinen@linux.intel.com \
--cc=laurent.pinchart@ideasonboard.com \
--cc=linux-media@vger.kernel.org \
--cc=platform-driver-x86@vger.kernel.org \
--cc=sakari.ailus@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox