From: Sakari Ailus <sakari.ailus@linux.intel.com>
To: "Daniel Scally" <djrscally@gmail.com>,
"Hans de Goede" <hdegoede@redhat.com>,
"Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>
Cc: platform-driver-x86@vger.kernel.org,
Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
laurent.pinchart@ideasonboard.com, hverkuil@xs4all.nl,
linux-media@vger.kernel.org
Subject: [PATCH v4 0/3] int3472: Support GPIO con_id based on _HID
Date: Fri, 31 Jan 2025 09:37:04 +0200 [thread overview]
Message-ID: <20250131073707.1082931-1-sakari.ailus@linux.intel.com> (raw)
Hi folks,
One patch turned into a set, the second patch being the original one.
since v3:
- Add a patch (first one) to switch to unsigned long type for polarity
field and renames it as gpio_flags.
- Use a polarity_low boolean field for indicating the GPIO polarity. This
is turned to gpio_flags in int3472_get_con_id_and_polarity().
- Put the new polarity_low bool field next to the u8's for better struct
packing.
- Add a patch (last one) to rename "func" as "con_id" which is used
throughout the GPIO framework.
Sakari Ailus (3):
platform/x86: int3472: Use correct type for "polarity", call it
gpio_flags
platform/x86: int3472: Call "reset" GPIO "enable" for INT347E
platform/x86: int3472: Call "func" "con_id" instead
drivers/platform/x86/intel/int3472/discrete.c | 98 +++++++++++++------
1 file changed, 68 insertions(+), 30 deletions(-)
--
2.39.5
next reply other threads:[~2025-01-31 7:37 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-01-31 7:37 Sakari Ailus [this message]
2025-01-31 7:37 ` [PATCH v4 1/3] platform/x86: int3472: Use correct type for "polarity", call it gpio_flags Sakari Ailus
2025-01-31 7:37 ` [PATCH v4 2/3] platform/x86: int3472: Call "reset" GPIO "enable" for INT347E Sakari Ailus
2025-01-31 11:22 ` Andy Shevchenko
2025-01-31 11:57 ` Sakari Ailus
2025-01-31 17:20 ` Andy Shevchenko
2025-01-31 7:37 ` [PATCH v4 3/3] platform/x86: int3472: Call "func" "con_id" instead Sakari Ailus
2025-01-31 9:16 ` [PATCH v4 0/3] int3472: Support GPIO con_id based on _HID Hans de Goede
2025-01-31 11:24 ` Andy Shevchenko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20250131073707.1082931-1-sakari.ailus@linux.intel.com \
--to=sakari.ailus@linux.intel.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=djrscally@gmail.com \
--cc=hdegoede@redhat.com \
--cc=hverkuil@xs4all.nl \
--cc=ilpo.jarvinen@linux.intel.com \
--cc=laurent.pinchart@ideasonboard.com \
--cc=linux-media@vger.kernel.org \
--cc=platform-driver-x86@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox