From: Shyam Sundar S K <Shyam-sundar.S-k@amd.com>
To: Hans de Goede <hdegoede@redhat.com>,
markgross@kernel.org, ilpo.jarvinen@linux.intel.com,
basavaraj.natikar@amd.com, jikos@kernel.org,
benjamin.tissoires@redhat.com
Cc: Patil.Reddy@amd.com, mario.limonciello@amd.com,
platform-driver-x86@vger.kernel.org, linux-input@vger.kernel.org
Subject: Re: [PATCH v6 03/15] platform/x86/amd/pmf: Change return type of amd_pmf_set_dram_addr()
Date: Mon, 11 Dec 2023 20:45:47 +0530 [thread overview]
Message-ID: <4af63850-0cb5-4deb-8dad-39dbb425916b@amd.com> (raw)
In-Reply-To: <bae8cbbb-47d9-4e03-9445-8ca9b50576af@redhat.com>
Hi Hans,
On 12/11/2023 2:10 PM, Hans de Goede wrote:
> Hi,
>
> On 12/4/23 11:15, Shyam Sundar S K wrote:
>> In the current code, the metrics table information was required only
>> for auto-mode or CnQF at a given time. Hence keeping the return type
>> of amd_pmf_set_dram_addr() as static made sense.
>>
>> But with the addition of Smart PC builder feature, the metrics table
>> information has to be shared by the Smart PC also and this feature
>> resides outside of core.c.
>>
>> To make amd_pmf_set_dram_addr() visible outside of core.c make it
>> as a non-static function and move the allocation of memory for
>> metrics table from amd_pmf_init_metrics_table() to amd_pmf_set_dram_addr()
>> as amd_pmf_set_dram_addr() is the common function to set the DRAM
>> address.
>>
>> Add a suspend handler that can free up the allocated memory for getting
>> the metrics table information.
>>
>> Reviewed-by: Mario Limonciello <mario.limonciello@amd.com>
>> Signed-off-by: Shyam Sundar S K <Shyam-sundar.S-k@amd.com>
>> ---
>> drivers/platform/x86/amd/pmf/core.c | 42 ++++++++++++++++++++++-------
>> drivers/platform/x86/amd/pmf/pmf.h | 1 +
>> 2 files changed, 34 insertions(+), 9 deletions(-)
>>
>> diff --git a/drivers/platform/x86/amd/pmf/core.c b/drivers/platform/x86/amd/pmf/core.c
>> index ec92d1cc0dac..f50b7ec9a625 100644
>> --- a/drivers/platform/x86/amd/pmf/core.c
>> +++ b/drivers/platform/x86/amd/pmf/core.c
>> @@ -251,29 +251,35 @@ static const struct pci_device_id pmf_pci_ids[] = {
>> { }
>> };
>>
>> -static void amd_pmf_set_dram_addr(struct amd_pmf_dev *dev)
>> +int amd_pmf_set_dram_addr(struct amd_pmf_dev *dev)
>> {
>> u64 phys_addr;
>> u32 hi, low;
>>
>> + /* Get Metrics Table Address */
>> + dev->buf = kzalloc(sizeof(dev->m_table), GFP_KERNEL);
>> + if (!dev->buf)
>> + return -ENOMEM;
>> +
>> phys_addr = virt_to_phys(dev->buf);
>> hi = phys_addr >> 32;
>> low = phys_addr & GENMASK(31, 0);
>>
>> amd_pmf_send_cmd(dev, SET_DRAM_ADDR_HIGH, 0, hi, NULL);
>> amd_pmf_send_cmd(dev, SET_DRAM_ADDR_LOW, 0, low, NULL);
>> +
>> + return 0;
>> }
>>
>> int amd_pmf_init_metrics_table(struct amd_pmf_dev *dev)
>> {
>> - /* Get Metrics Table Address */
>> - dev->buf = kzalloc(sizeof(dev->m_table), GFP_KERNEL);
>> - if (!dev->buf)
>> - return -ENOMEM;
>> + int ret;
>>
>> INIT_DELAYED_WORK(&dev->work_buffer, amd_pmf_get_metrics);
>>
>> - amd_pmf_set_dram_addr(dev);
>> + ret = amd_pmf_set_dram_addr(dev);
>> + if (ret)
>> + return ret;
>>
>> /*
>> * Start collecting the metrics data after a small delay
>> @@ -284,17 +290,35 @@ int amd_pmf_init_metrics_table(struct amd_pmf_dev *dev)
>> return 0;
>> }
>>
>> +static int amd_pmf_suspend_handler(struct device *dev)
>> +{
>> + struct amd_pmf_dev *pdev = dev_get_drvdata(dev);
>> +
>> + /*
>> + * Free the buffer allocated for storing the metrics table
>> + * information, as will have to allocate it freshly after
>> + * resume.
>> + */
>> + kfree(pdev->buf);
>
> This seems quite risky. You are freeing the memory here,
> but the SET_DRAM_ADDR_HIGH and SET_DRAM_ADDR_LO registers
> still point to it, so the hw may still access it.
>
> IMHO it would be better to add a "bool alloc_buffer"
> parameter to amd_pmf_set_dram_addr() and set that
> to true on init and false on resume.
>
Ok. I have made this change.
> Also I guess that this DRAM buffer is used by the new
> smartpc mode and specifically by the command send by
> amd_pmf_invoke_cmd() work. In that case you really
> need to make sure to cancel the work before
> freeing the buffer and then re-submit the work
> on resume.
With some sanity tests, I don't think so this is required. pdev->buf
is only used to get the metrics table info. So, I am keeping only the
freeing part + alloc_buffer thing and not cancel/resubmit in the
suspend/resume.
If there are issues in the future because of not including
cancel/resubmit thing, can we work that as a bug fix later? Would that
be OK for you?
Thanks,
Shyam
>
> Regards,
>
> Hans
>
>
>
>> +
>> + return 0;
>> +}
>> +
>> static int amd_pmf_resume_handler(struct device *dev)
>> {
>> struct amd_pmf_dev *pdev = dev_get_drvdata(dev);
>> + int ret;
>>
>> - if (pdev->buf)
>> - amd_pmf_set_dram_addr(pdev);
>> + if (pdev->buf) {
>> + ret = amd_pmf_set_dram_addr(pdev);
>> + if (ret)
>> + return ret;
>> + }
>>
>> return 0;
>> }
>>
>> -static DEFINE_SIMPLE_DEV_PM_OPS(amd_pmf_pm, NULL, amd_pmf_resume_handler);
>> +static DEFINE_SIMPLE_DEV_PM_OPS(amd_pmf_pm, amd_pmf_suspend_handler, amd_pmf_resume_handler);
>>
>> static void amd_pmf_init_features(struct amd_pmf_dev *dev)
>> {
>> diff --git a/drivers/platform/x86/amd/pmf/pmf.h b/drivers/platform/x86/amd/pmf/pmf.h
>> index a24e34e42032..6a0e4c446dd3 100644
>> --- a/drivers/platform/x86/amd/pmf/pmf.h
>> +++ b/drivers/platform/x86/amd/pmf/pmf.h
>> @@ -421,6 +421,7 @@ int amd_pmf_init_metrics_table(struct amd_pmf_dev *dev);
>> int amd_pmf_get_power_source(void);
>> int apmf_install_handler(struct amd_pmf_dev *pmf_dev);
>> int apmf_os_power_slider_update(struct amd_pmf_dev *dev, u8 flag);
>> +int amd_pmf_set_dram_addr(struct amd_pmf_dev *dev);
>>
>> /* SPS Layer */
>> int amd_pmf_get_pprof_modes(struct amd_pmf_dev *pmf);
>
next prev parent reply other threads:[~2023-12-11 15:15 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-12-04 10:15 [PATCH v6 00/15] Introduce PMF Smart PC Solution Builder Feature Shyam Sundar S K
2023-12-04 10:15 ` [PATCH v6 01/15] platform/x86/amd/pmf: Add PMF TEE interface Shyam Sundar S K
2023-12-04 10:15 ` [PATCH v6 02/15] platform/x86/amd/pmf: Add support for PMF-TA interaction Shyam Sundar S K
2023-12-04 10:15 ` [PATCH v6 03/15] platform/x86/amd/pmf: Change return type of amd_pmf_set_dram_addr() Shyam Sundar S K
2023-12-11 8:40 ` Hans de Goede
2023-12-11 15:15 ` Shyam Sundar S K [this message]
2023-12-11 15:55 ` Hans de Goede
2023-12-11 16:35 ` Shyam Sundar S K
2023-12-04 10:15 ` [PATCH v6 04/15] platform/x86/amd/pmf: Add support for PMF Policy Binary Shyam Sundar S K
2023-12-04 19:05 ` Mario Limonciello
2023-12-11 8:53 ` Hans de Goede
2023-12-04 10:15 ` [PATCH v6 05/15] platform/x86/amd/pmf: change amd_pmf_init_features() call sequence Shyam Sundar S K
2023-12-04 10:15 ` [PATCH v6 06/15] platform/x86/amd/pmf: Add support to get inputs from other subsystems Shyam Sundar S K
2023-12-04 19:03 ` Mario Limonciello
2023-12-04 10:15 ` [PATCH v6 07/15] platform/x86/amd/pmf: Add support update p3t limit Shyam Sundar S K
2023-12-04 10:15 ` [PATCH v6 08/15] platform/x86/amd/pmf: Add support to update system state Shyam Sundar S K
2023-12-04 10:15 ` [PATCH v6 09/15] platform/x86/amd/pmf: Make source_as_str() as non-static Shyam Sundar S K
2023-12-04 10:15 ` [PATCH v6 10/15] platform/x86/amd/pmf: Add facility to dump TA inputs Shyam Sundar S K
2023-12-04 10:15 ` [PATCH v6 11/15] platform/x86/amd/pmf: Add capability to sideload of policy binary Shyam Sundar S K
2023-12-11 8:59 ` Hans de Goede
2023-12-04 10:15 ` [PATCH v6 12/15] platform/x86/amd/pmf: dump policy binary data Shyam Sundar S K
2023-12-04 10:15 ` [PATCH v6 13/15] HID: amd_sfh: rename float_to_int() to amd_sfh_float_to_int() Shyam Sundar S K
2023-12-04 19:02 ` Mario Limonciello
2023-12-04 10:15 ` [PATCH v6 14/15] platform/x86/amd/pmf: Add PMF-AMDSFH interface for HPD Shyam Sundar S K
2023-12-04 19:02 ` Mario Limonciello
2023-12-11 9:07 ` Hans de Goede
2023-12-04 10:15 ` [PATCH v6 15/15] platform/x86/amd/pmf: Add PMF-AMDSFH interface for ALS Shyam Sundar S K
2023-12-11 9:15 ` Hans de Goede
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4af63850-0cb5-4deb-8dad-39dbb425916b@amd.com \
--to=shyam-sundar.s-k@amd.com \
--cc=Patil.Reddy@amd.com \
--cc=basavaraj.natikar@amd.com \
--cc=benjamin.tissoires@redhat.com \
--cc=hdegoede@redhat.com \
--cc=ilpo.jarvinen@linux.intel.com \
--cc=jikos@kernel.org \
--cc=linux-input@vger.kernel.org \
--cc=mario.limonciello@amd.com \
--cc=markgross@kernel.org \
--cc=platform-driver-x86@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox