From: Tom Rini <trini@konsulko.com>
To: Simon Glass <sjg@chromium.org>
Cc: U-Boot Mailing List <u-boot@lists.denx.de>,
Marek Vasut <marex@denx.de>,
Andre Przywara <andre.przywara@arm.com>,
Heinrich Schuchardt <xypron.glpk@gmx.de>,
Marek Vasut <marek.vasut+renesas@mailbox.org>,
Michal Simek <michal.simek@amd.com>
Subject: Re: [PATCH v3 08/38] spl: Create proper symbols for enabling the malloc() pool
Date: Mon, 25 Sep 2023 15:46:11 -0400 [thread overview]
Message-ID: <20230925194611.GN305624@bill-the-cat> (raw)
In-Reply-To: <20230924192536.1812799-9-sjg@chromium.org>
[-- Attachment #1: Type: text/plain, Size: 1364 bytes --]
On Sun, Sep 24, 2023 at 01:24:53PM -0600, Simon Glass wrote:
> For U-Boot proper we have CONFIG_SYS_MALLOC_F which indicates that a
> malloc() pool is available before relocation.
>
> For SPL we only have CONFIG_SPL_SYS_MALLOC_F_LEN which indicates the
> size of the pool.
>
> In various places we use CONFIG_SPL_SYS_MALLOC_F_LEN == 0 to indicate
> that there is no pool.
>
> This differing approach is confusing. Add a new CONFIG_SPL_SYS_MALLOC_F
> symbol for SPL (and similarly for TPL and VPL). Tidy up the Kconfig
> help for clarity.
>
> For now these symbols are not used. That is cleaned up in the following
> patches.
>
> Signed-off-by: Simon Glass <sjg@chromium.org>
This introduces:
WARNING: unmet direct dependencies detected for SPL_SYS_MALLOC_F
Depends on [n]: ARM [=y] && ARCH_SNAPDRAGON [=n] || ARM [=y] && ARCH_SOCFPGA [=n] || SPL_FRAMEWORK [=n] && SYS_MALLOC_F [=y] && SPL [=y]
Selected by [y]:
- SPL_DM_SERIAL [=y] && SERIAL [=y] && DM_SERIAL [=y] && SPL_DM [=y]
WARNING: unmet direct dependencies detected for SPL_SYS_MALLOC_F
Depends on [n]: ARM [=y] && ARCH_SNAPDRAGON [=n] || ARM [=y] && ARCH_SOCFPGA [=n] || SPL_FRAMEWORK [=n] && SYS_MALLOC_F [=y] && SPL [=y]
Selected by [y]:
- SPL_DM_SERIAL [=y] && SERIAL [=y] && DM_SERIAL [=y] && SPL_DM [=y]
On mx28evk and imx28_xea_sb.
--
Tom
[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 659 bytes --]
next prev parent reply other threads:[~2023-09-25 19:46 UTC|newest]
Thread overview: 50+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-09-24 19:24 [PATCH v3 00/38] spl: Preparation for Universal Payload Simon Glass
2023-09-24 19:24 ` [PATCH v3 01/38] spl: Use CONFIG_SPL... instead of CONFIG_..._SPL_ Simon Glass
2023-09-25 14:55 ` Felix Brack
2023-09-25 16:08 ` Simon Glass
2023-10-09 16:15 ` Felix Brack
2023-09-24 19:24 ` [PATCH v3 02/38] spl: Rename SYS_SPL_ARGS_ADDR to SPL_PAYLOAD_ARGS_ADDR Simon Glass
2023-09-24 19:24 ` [PATCH v3 03/38] spl: Avoid #ifdef with CONFIG_SPL_SYS_MALLOC Simon Glass
2023-09-24 19:24 ` [PATCH v3 04/38] spl: mx6: powerpc: Drop the condition on timer_init() Simon Glass
2023-09-26 6:45 ` Christophe Leroy
2023-09-27 14:19 ` Simon Glass
2023-09-24 19:24 ` [PATCH v3 05/38] spl: Drop #ifdefs for BOARD_INIT and watchdog Simon Glass
2023-09-24 19:24 ` [PATCH v3 06/38] spl: Avoid #ifdef with CONFIG_SPL_PAYLOAD_ARGS_ADDR Simon Glass
2023-09-24 19:24 ` [PATCH v3 07/38] spl: Drop the switch() statement for OS selection Simon Glass
2023-09-24 19:24 ` [PATCH v3 08/38] spl: Create proper symbols for enabling the malloc() pool Simon Glass
2023-09-25 19:46 ` Tom Rini [this message]
2023-09-24 19:24 ` [PATCH v3 09/38] spl: Enable CONFIG_SPL_SYS_MALLOC_F where needed Simon Glass
2023-09-24 19:24 ` [PATCH v3 10/38] tpl: Enable CONFIG_TPL_SYS_MALLOC_F " Simon Glass
2023-09-24 19:24 ` [PATCH v3 11/38] spl: Use SYS_MALLOC_F instead of SYS_MALLOC_F_LEN Simon Glass
2023-09-24 19:24 ` [PATCH v3 12/38] Tidy up uses of CONFIG_SYS_MALLOC_F_LEN Simon Glass
2023-09-24 19:24 ` [PATCH v3 13/38] doc: Clean up SYS_MALLOC_SIMPLE Simon Glass
2023-09-24 19:24 ` [PATCH v3 14/38] dm: core: Correct help in TPL_DM and VPL_DM Simon Glass
2023-09-24 19:25 ` [PATCH v3 15/38] spl: Avoid an #ifdef when printing gd->malloc_ptr Simon Glass
2023-09-24 19:25 ` [PATCH v3 16/38] spl: Remove #ifdefs with BOOTSTAGE Simon Glass
2023-09-25 19:56 ` Tom Rini
2023-09-24 19:25 ` [PATCH v3 17/38] spl: Rename spl_load_fit_image() to load_simple_fit() Simon Glass
2023-09-24 19:25 ` [PATCH v3 18/38] spl: Move the full FIT code to spl_fit.c Simon Glass
2023-09-24 19:25 ` [PATCH v3 19/38] spl: Use the correct FIT_..._PROP constants Simon Glass
2023-09-24 19:25 ` [PATCH v3 20/38] spl: Move bloblist writing until the image is known Simon Glass
2023-09-24 19:25 ` [PATCH v3 21/38] dm: core: Reverse the argument order in ofnode_copy_props() Simon Glass
2023-09-24 19:25 ` [PATCH v3 22/38] dm: core: Ensure we run flattree tests on ofnode Simon Glass
2023-09-24 19:25 ` [PATCH v3 23/38] dm: core: Tidy up comments in the ofnode tests Simon Glass
2023-09-24 19:25 ` [PATCH v3 24/38] dm: core: Add a function to create an empty tree Simon Glass
2023-09-24 19:25 ` [PATCH v3 25/38] dm: core: Add a way to copy a node Simon Glass
2023-09-24 19:25 ` [PATCH v3 26/38] dm: core: Add a way to delete " Simon Glass
2023-09-24 19:25 ` [PATCH v3 27/38] dm: core: Add a way to convert a devicetree to a dtb Simon Glass
2023-09-24 19:25 ` [PATCH v3 28/38] dm: core: Support writing a boolean Simon Glass
2023-09-24 19:25 ` [PATCH v3 29/38] dm: core: Support writing a 64-bit value Simon Glass
2023-09-24 19:25 ` [PATCH v3 30/38] dm: core: Add tests for oftree_path() Simon Glass
2023-09-24 19:25 ` [PATCH v3 31/38] sandbox: Move reading the RAM buffer into a better place Simon Glass
2023-09-24 19:25 ` [PATCH v3 32/38] sandbox: Init the EC properly even if no state file is available Simon Glass
2023-09-24 19:25 ` [PATCH v3 33/38] sandbox: Only read the state if we have a state file Simon Glass
2023-09-24 19:25 ` [PATCH v3 34/38] sandbox: Move the bloblist down a little in memory Simon Glass
2023-09-24 19:25 ` [PATCH v3 35/38] bloblist: Support initing from multiple places Simon Glass
2023-09-24 19:25 ` [PATCH v3 36/38] fdt: Allow the devicetree to come from a bloblist Simon Glass
2023-09-24 19:25 ` [PATCH v3 37/38] command: Include a required header in command.h Simon Glass
2023-09-24 19:25 ` [PATCH v3 38/38] pci: serial: Support reading PCI-register size with base Simon Glass
2023-09-25 20:17 ` Tom Rini
2023-09-26 11:37 ` Simon Glass
2023-09-26 14:05 ` Tom Rini
2023-09-25 20:36 ` [PATCH v3 00/38] spl: Preparation for Universal Payload Tom Rini
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230925194611.GN305624@bill-the-cat \
--to=trini@konsulko.com \
--cc=andre.przywara@arm.com \
--cc=marek.vasut+renesas@mailbox.org \
--cc=marex@denx.de \
--cc=michal.simek@amd.com \
--cc=sjg@chromium.org \
--cc=u-boot@lists.denx.de \
--cc=xypron.glpk@gmx.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox