From: Tom Rini <trini@konsulko.com>
To: Simon Glass <sjg@chromium.org>
Cc: u-boot@lists.denx.de
Subject: Re: [PATCH v3 00/38] spl: Preparation for Universal Payload
Date: Mon, 25 Sep 2023 16:36:07 -0400 [thread overview]
Message-ID: <20230925203607.GQ305624@bill-the-cat> (raw)
In-Reply-To: <20230924192536.1812799-1-sjg@chromium.org>
[-- Attachment #1: Type: text/plain, Size: 3543 bytes --]
On Sun, Sep 24, 2023 at 01:24:45PM -0600, Simon Glass wrote:
> This series tidies up SPL a little and adds some core ofnode functions
> needed to support Universal Payload. It also includes a few minor fix-ups
> for sandbox.
>
> For SPL the changes include CONFIG naming, removing various #ifdefs and
> tidying up the FIT code.
>
> One notable piece of the ofnode improvements is support for flattening
> a livetree. This should be useful in future as we move FDT fixups to use
> the ofnode API.
>
> Changes in v3:
> - Mention testing on qemu-ppce500
> - Add new patch to create a proper symbol for enabling the malloc() pool
> - Add new patch to enable CONFIG_SPL_SYS_MALLOC_F where needed
> - Add new patch to nable CONFIG_TPL_SYS_MALLOC_F where needed
> - Add new patch to use SYS_MALLOC_F instead of SYS_MALLOC_F_LEN
> - Add new patch to tidy up uses of CONFIG_SYS_MALLOC_F_LEN
> - Add new patch to clean up SYS_MALLOC_SIMPLE documentation
> - Add new patch to correct help in TPL_DM and VPL_DM
> - Rebase on the new patch
>
> Changes in v2:
> - Rename based on Tom's feedback
> - Improve readability by moving the size part to the header file
> - Explicitly copy two maintainers as it seems only Mario was auto-cc'd
> - Change the approach to use the header file
> - Use the same condition for both pieces to avoid possible problems
> - No changes as it still seems unclear what should be done
>
> Simon Glass (38):
> spl: Use CONFIG_SPL... instead of CONFIG_..._SPL_...
> spl: Rename SYS_SPL_ARGS_ADDR to SPL_PAYLOAD_ARGS_ADDR
> spl: Avoid #ifdef with CONFIG_SPL_SYS_MALLOC
> spl: mx6: powerpc: Drop the condition on timer_init()
> spl: Drop #ifdefs for BOARD_INIT and watchdog
> spl: Avoid #ifdef with CONFIG_SPL_PAYLOAD_ARGS_ADDR
> spl: Drop the switch() statement for OS selection
> spl: Create proper symbols for enabling the malloc() pool
> spl: Enable CONFIG_SPL_SYS_MALLOC_F where needed
> tpl: Enable CONFIG_TPL_SYS_MALLOC_F where needed
> spl: Use SYS_MALLOC_F instead of SYS_MALLOC_F_LEN
> Tidy up uses of CONFIG_SYS_MALLOC_F_LEN
> doc: Clean up SYS_MALLOC_SIMPLE
> dm: core: Correct help in TPL_DM and VPL_DM
> spl: Avoid an #ifdef when printing gd->malloc_ptr
> spl: Remove #ifdefs with BOOTSTAGE
> spl: Rename spl_load_fit_image() to load_simple_fit()
> spl: Move the full FIT code to spl_fit.c
> spl: Use the correct FIT_..._PROP constants
> spl: Move bloblist writing until the image is known
> dm: core: Reverse the argument order in ofnode_copy_props()
> dm: core: Ensure we run flattree tests on ofnode
> dm: core: Tidy up comments in the ofnode tests
> dm: core: Add a function to create an empty tree
> dm: core: Add a way to copy a node
> dm: core: Add a way to delete a node
> dm: core: Add a way to convert a devicetree to a dtb
> dm: core: Support writing a boolean
> dm: core: Support writing a 64-bit value
> dm: core: Add tests for oftree_path()
> sandbox: Move reading the RAM buffer into a better place
> sandbox: Init the EC properly even if no state file is available
> sandbox: Only read the state if we have a state file
> sandbox: Move the bloblist down a little in memory
> bloblist: Support initing from multiple places
> fdt: Allow the devicetree to come from a bloblist
> command: Include a required header in command.h
> pci: serial: Support reading PCI-register size with base
Specific feedback aside, generally this seems fine.
--
Tom
[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 659 bytes --]
prev parent reply other threads:[~2023-09-25 20:36 UTC|newest]
Thread overview: 50+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-09-24 19:24 [PATCH v3 00/38] spl: Preparation for Universal Payload Simon Glass
2023-09-24 19:24 ` [PATCH v3 01/38] spl: Use CONFIG_SPL... instead of CONFIG_..._SPL_ Simon Glass
2023-09-25 14:55 ` Felix Brack
2023-09-25 16:08 ` Simon Glass
2023-10-09 16:15 ` Felix Brack
2023-09-24 19:24 ` [PATCH v3 02/38] spl: Rename SYS_SPL_ARGS_ADDR to SPL_PAYLOAD_ARGS_ADDR Simon Glass
2023-09-24 19:24 ` [PATCH v3 03/38] spl: Avoid #ifdef with CONFIG_SPL_SYS_MALLOC Simon Glass
2023-09-24 19:24 ` [PATCH v3 04/38] spl: mx6: powerpc: Drop the condition on timer_init() Simon Glass
2023-09-26 6:45 ` Christophe Leroy
2023-09-27 14:19 ` Simon Glass
2023-09-24 19:24 ` [PATCH v3 05/38] spl: Drop #ifdefs for BOARD_INIT and watchdog Simon Glass
2023-09-24 19:24 ` [PATCH v3 06/38] spl: Avoid #ifdef with CONFIG_SPL_PAYLOAD_ARGS_ADDR Simon Glass
2023-09-24 19:24 ` [PATCH v3 07/38] spl: Drop the switch() statement for OS selection Simon Glass
2023-09-24 19:24 ` [PATCH v3 08/38] spl: Create proper symbols for enabling the malloc() pool Simon Glass
2023-09-25 19:46 ` Tom Rini
2023-09-24 19:24 ` [PATCH v3 09/38] spl: Enable CONFIG_SPL_SYS_MALLOC_F where needed Simon Glass
2023-09-24 19:24 ` [PATCH v3 10/38] tpl: Enable CONFIG_TPL_SYS_MALLOC_F " Simon Glass
2023-09-24 19:24 ` [PATCH v3 11/38] spl: Use SYS_MALLOC_F instead of SYS_MALLOC_F_LEN Simon Glass
2023-09-24 19:24 ` [PATCH v3 12/38] Tidy up uses of CONFIG_SYS_MALLOC_F_LEN Simon Glass
2023-09-24 19:24 ` [PATCH v3 13/38] doc: Clean up SYS_MALLOC_SIMPLE Simon Glass
2023-09-24 19:24 ` [PATCH v3 14/38] dm: core: Correct help in TPL_DM and VPL_DM Simon Glass
2023-09-24 19:25 ` [PATCH v3 15/38] spl: Avoid an #ifdef when printing gd->malloc_ptr Simon Glass
2023-09-24 19:25 ` [PATCH v3 16/38] spl: Remove #ifdefs with BOOTSTAGE Simon Glass
2023-09-25 19:56 ` Tom Rini
2023-09-24 19:25 ` [PATCH v3 17/38] spl: Rename spl_load_fit_image() to load_simple_fit() Simon Glass
2023-09-24 19:25 ` [PATCH v3 18/38] spl: Move the full FIT code to spl_fit.c Simon Glass
2023-09-24 19:25 ` [PATCH v3 19/38] spl: Use the correct FIT_..._PROP constants Simon Glass
2023-09-24 19:25 ` [PATCH v3 20/38] spl: Move bloblist writing until the image is known Simon Glass
2023-09-24 19:25 ` [PATCH v3 21/38] dm: core: Reverse the argument order in ofnode_copy_props() Simon Glass
2023-09-24 19:25 ` [PATCH v3 22/38] dm: core: Ensure we run flattree tests on ofnode Simon Glass
2023-09-24 19:25 ` [PATCH v3 23/38] dm: core: Tidy up comments in the ofnode tests Simon Glass
2023-09-24 19:25 ` [PATCH v3 24/38] dm: core: Add a function to create an empty tree Simon Glass
2023-09-24 19:25 ` [PATCH v3 25/38] dm: core: Add a way to copy a node Simon Glass
2023-09-24 19:25 ` [PATCH v3 26/38] dm: core: Add a way to delete " Simon Glass
2023-09-24 19:25 ` [PATCH v3 27/38] dm: core: Add a way to convert a devicetree to a dtb Simon Glass
2023-09-24 19:25 ` [PATCH v3 28/38] dm: core: Support writing a boolean Simon Glass
2023-09-24 19:25 ` [PATCH v3 29/38] dm: core: Support writing a 64-bit value Simon Glass
2023-09-24 19:25 ` [PATCH v3 30/38] dm: core: Add tests for oftree_path() Simon Glass
2023-09-24 19:25 ` [PATCH v3 31/38] sandbox: Move reading the RAM buffer into a better place Simon Glass
2023-09-24 19:25 ` [PATCH v3 32/38] sandbox: Init the EC properly even if no state file is available Simon Glass
2023-09-24 19:25 ` [PATCH v3 33/38] sandbox: Only read the state if we have a state file Simon Glass
2023-09-24 19:25 ` [PATCH v3 34/38] sandbox: Move the bloblist down a little in memory Simon Glass
2023-09-24 19:25 ` [PATCH v3 35/38] bloblist: Support initing from multiple places Simon Glass
2023-09-24 19:25 ` [PATCH v3 36/38] fdt: Allow the devicetree to come from a bloblist Simon Glass
2023-09-24 19:25 ` [PATCH v3 37/38] command: Include a required header in command.h Simon Glass
2023-09-24 19:25 ` [PATCH v3 38/38] pci: serial: Support reading PCI-register size with base Simon Glass
2023-09-25 20:17 ` Tom Rini
2023-09-26 11:37 ` Simon Glass
2023-09-26 14:05 ` Tom Rini
2023-09-25 20:36 ` Tom Rini [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230925203607.GQ305624@bill-the-cat \
--to=trini@konsulko.com \
--cc=sjg@chromium.org \
--cc=u-boot@lists.denx.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox