U-Boot Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Mattijs Korpershoek <mkorpershoek@baylibre.com>
To: Zixun LI <admin@hifiphile.com>, Lukasz Majewski <lukma@denx.de>,
	Marek Vasut <marex@denx.de>, Tom Rini <trini@konsulko.com>
Cc: Zixun LI <zli@ogga.fr>, u-boot@lists.denx.de
Subject: Re: [PATCH v3 5/7] usb: gadget: atmel: Rename atmel_usba_start()/_stop() to usba_udc_enable()/_disable()
Date: Wed, 24 Jul 2024 12:16:46 +0200	[thread overview]
Message-ID: <877cdb5c35.fsf@baylibre.com> (raw)
In-Reply-To: <20240723131817.262596-6-zli@ogga.fr>

Hi Zixun,

Thank you for the patch.

On mar., juil. 23, 2024 at 15:18, Zixun LI <admin@hifiphile.com> wrote:

> Rename atmel_usba_start() / atmel_usba_stop() to usba_udc_enable()
> / usba_udc_disable(), remove atmel_ prefix to be inline with other
> functions. Also avoid confusion with DM start() / stop() functions.
>
> Signed-off-by: Zixun LI <zli@ogga.fr>

Reviewed-by: Mattijs Korpershoek <mkorpershoek@baylibre.com>

> ---
>  drivers/usb/gadget/atmel_usba_udc.c | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/usb/gadget/atmel_usba_udc.c b/drivers/usb/gadget/atmel_usba_udc.c
> index a3d24501ba..ea9ad7585e 100644
> --- a/drivers/usb/gadget/atmel_usba_udc.c
> +++ b/drivers/usb/gadget/atmel_usba_udc.c
> @@ -1153,7 +1153,7 @@ static int usba_udc_irq(struct usba_udc *udc)
>  	return 0;
>  }
>  
> -static int atmel_usba_start(struct usba_udc *udc)
> +static int usba_udc_enable(struct usba_udc *udc)
>  {
>  	udc->devstatus = 1 << USB_DEVICE_SELF_POWERED;
>  
> @@ -1168,7 +1168,7 @@ static int atmel_usba_start(struct usba_udc *udc)
>  	return 0;
>  }
>  
> -static int atmel_usba_stop(struct usba_udc *udc)
> +static int usba_udc_disable(struct usba_udc *udc)
>  {
>  	udc->gadget.speed = USB_SPEED_UNKNOWN;
>  	reset_all_endpoints(udc);
> @@ -1253,7 +1253,7 @@ int usb_gadget_register_driver(struct usb_gadget_driver *driver)
>  		return -EBUSY;
>  	}
>  
> -	atmel_usba_start(udc);
> +	usba_udc_enable(udc);
>  
>  	udc->driver = driver;
>  
> @@ -1279,7 +1279,7 @@ int usb_gadget_unregister_driver(struct usb_gadget_driver *driver)
>  	driver->unbind(&udc->gadget);
>  	udc->driver = NULL;
>  
> -	atmel_usba_stop(udc);
> +	usba_udc_disable(udc);
>  
>  	return 0;
>  }
> -- 
> 2.45.2

  parent reply	other threads:[~2024-07-24 10:16 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-07-23 13:18 [PATCH v3 0/7] usb: gadget: atmel: Code refactor and DM_USB_GADGET support Zixun LI
2024-07-23 13:18 ` [PATCH v3 1/7] usb: gadget: atmel: Sort includes Zixun LI
2024-07-23 13:34   ` Marek Vasut
2024-07-24 10:06   ` Mattijs Korpershoek
2024-07-23 13:18 ` [PATCH v3 2/7] usb: gadget: atmel: Replace printf() and pr_err() by log_err() Zixun LI
2024-07-23 13:34   ` Marek Vasut
2024-07-24 10:12   ` Mattijs Korpershoek
2024-07-23 13:18 ` [PATCH v3 3/7] usb: gadget: atmel: Fix typo in usb_gadget_register_driver() Zixun LI
2024-07-23 13:35   ` Marek Vasut
2024-07-24 10:14   ` Mattijs Korpershoek
2024-07-23 13:18 ` [PATCH v3 4/7] usb: gadget: atmel: Move usba_udc_pdata() with other static functions Zixun LI
2024-07-23 13:35   ` Marek Vasut
2024-07-24 10:15   ` Mattijs Korpershoek
2024-07-23 13:18 ` [PATCH v3 5/7] usb: gadget: atmel: Rename atmel_usba_start()/_stop() to usba_udc_enable()/_disable() Zixun LI
2024-07-23 13:36   ` Marek Vasut
2024-07-24 10:16   ` Mattijs Korpershoek [this message]
2024-07-23 13:18 ` [PATCH v3 6/7] usb: gadget: atmel: Add attach/detach support Zixun LI
2024-07-23 13:36   ` Marek Vasut
2024-07-24 10:19     ` Mattijs Korpershoek
2024-07-24 10:18   ` Mattijs Korpershoek
2024-07-23 13:18 ` [PATCH v3 7/7] usb: gadget: atmel: Add DM_USB_GADGET support Zixun LI
2024-07-24 10:41   ` Mattijs Korpershoek
2024-07-24 13:20     ` admin LI

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=877cdb5c35.fsf@baylibre.com \
    --to=mkorpershoek@baylibre.com \
    --cc=admin@hifiphile.com \
    --cc=lukma@denx.de \
    --cc=marex@denx.de \
    --cc=trini@konsulko.com \
    --cc=u-boot@lists.denx.de \
    --cc=zli@ogga.fr \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox