From: Mattijs Korpershoek <mkorpershoek@baylibre.com>
To: Zixun LI <admin@hifiphile.com>, Lukasz Majewski <lukma@denx.de>,
Marek Vasut <marex@denx.de>, Tom Rini <trini@konsulko.com>
Cc: Zixun LI <zli@ogga.fr>, u-boot@lists.denx.de
Subject: Re: [PATCH v3 2/7] usb: gadget: atmel: Replace printf() and pr_err() by log_err()
Date: Wed, 24 Jul 2024 12:12:48 +0200 [thread overview]
Message-ID: <87frrz5c9r.fsf@baylibre.com> (raw)
In-Reply-To: <20240723131817.262596-3-zli@ogga.fr>
Hi Zixun,
Thank you for the patch.
On mar., juil. 23, 2024 at 15:18, Zixun LI <admin@hifiphile.com> wrote:
> To have a uniform printing function, also drop linux/printk.h as no
> longer used.
>
> Signed-off-by: Zixun LI <zli@ogga.fr>
Checkpatch complains here:
checkpatch.pl: 164: WARNING: From:/Signed-off-by: email address mismatch: 'From: Zixun LI <admin@hifiphile.com>' != 'Signed-off-by: Zixun LI <zli@ogga.fr>'
Please make sure that the commiter matches the Signed-off-by.
This can be done with git commit --reset-author or --author="name <email>"
> ---
> drivers/usb/gadget/atmel_usba_udc.c | 12 ++++++------
> 1 file changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/usb/gadget/atmel_usba_udc.c b/drivers/usb/gadget/atmel_usba_udc.c
> index 5f78251fdb..83fdc36870 100644
> --- a/drivers/usb/gadget/atmel_usba_udc.c
> +++ b/drivers/usb/gadget/atmel_usba_udc.c
> @@ -7,13 +7,13 @@
> * Bo Shen <voice.shen@atmel.com>
> */
>
> +#include <log.h>
> #include <malloc.h>
> #include <asm/gpio.h>
> #include <asm/hardware.h>
> #include <linux/bitops.h>
> #include <linux/errno.h>
> #include <linux/list.h>
> -#include <linux/printk.h>
> #include <linux/usb/ch9.h>
> #include <linux/usb/gadget.h>
> #include <linux/usb/atmel_usba_udc.h>
> @@ -1204,12 +1204,12 @@ int usb_gadget_register_driver(struct usb_gadget_driver *driver)
> int ret;
>
> if (!driver || !driver->bind || !driver->setup) {
> - printf("bad paramter\n");
> + log_err("bad paramter\n");
> return -EINVAL;
> }
>
> if (udc->driver) {
> - printf("UDC already has a gadget driver\n");
> + log_err("UDC already has a gadget driver\n");
> return -EBUSY;
> }
>
> @@ -1219,7 +1219,7 @@ int usb_gadget_register_driver(struct usb_gadget_driver *driver)
>
> ret = driver->bind(&udc->gadget);
> if (ret) {
> - pr_err("driver->bind() returned %d\n", ret);
> + log_err("driver->bind() returned %d\n", ret);
> udc->driver = NULL;
> }
>
> @@ -1231,7 +1231,7 @@ int usb_gadget_unregister_driver(struct usb_gadget_driver *driver)
> struct usba_udc *udc = &controller;
>
> if (!driver || !driver->unbind || !driver->disconnect) {
> - pr_err("bad paramter\n");
> + log_err("bad parameter\n");
Here we change both:
1. pr_err() to log_err()
2. fix paramter -> parameter
2. should be done in patch 3/7 instead of here.
With the above fixed:
Reviewed-by: Mattijs Korpershoek <mkorpershoek@baylibre.com>
> return -EINVAL;
> }
>
> @@ -1252,7 +1252,7 @@ static struct usba_ep *usba_udc_pdata(struct usba_platform_data *pdata,
>
> eps = malloc(sizeof(struct usba_ep) * pdata->num_ep);
> if (!eps) {
> - pr_err("failed to alloc eps\n");
> + log_err("failed to alloc eps\n");
> return NULL;
> }
>
> --
> 2.45.2
next prev parent reply other threads:[~2024-07-24 10:12 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-07-23 13:18 [PATCH v3 0/7] usb: gadget: atmel: Code refactor and DM_USB_GADGET support Zixun LI
2024-07-23 13:18 ` [PATCH v3 1/7] usb: gadget: atmel: Sort includes Zixun LI
2024-07-23 13:34 ` Marek Vasut
2024-07-24 10:06 ` Mattijs Korpershoek
2024-07-23 13:18 ` [PATCH v3 2/7] usb: gadget: atmel: Replace printf() and pr_err() by log_err() Zixun LI
2024-07-23 13:34 ` Marek Vasut
2024-07-24 10:12 ` Mattijs Korpershoek [this message]
2024-07-23 13:18 ` [PATCH v3 3/7] usb: gadget: atmel: Fix typo in usb_gadget_register_driver() Zixun LI
2024-07-23 13:35 ` Marek Vasut
2024-07-24 10:14 ` Mattijs Korpershoek
2024-07-23 13:18 ` [PATCH v3 4/7] usb: gadget: atmel: Move usba_udc_pdata() with other static functions Zixun LI
2024-07-23 13:35 ` Marek Vasut
2024-07-24 10:15 ` Mattijs Korpershoek
2024-07-23 13:18 ` [PATCH v3 5/7] usb: gadget: atmel: Rename atmel_usba_start()/_stop() to usba_udc_enable()/_disable() Zixun LI
2024-07-23 13:36 ` Marek Vasut
2024-07-24 10:16 ` Mattijs Korpershoek
2024-07-23 13:18 ` [PATCH v3 6/7] usb: gadget: atmel: Add attach/detach support Zixun LI
2024-07-23 13:36 ` Marek Vasut
2024-07-24 10:19 ` Mattijs Korpershoek
2024-07-24 10:18 ` Mattijs Korpershoek
2024-07-23 13:18 ` [PATCH v3 7/7] usb: gadget: atmel: Add DM_USB_GADGET support Zixun LI
2024-07-24 10:41 ` Mattijs Korpershoek
2024-07-24 13:20 ` admin LI
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87frrz5c9r.fsf@baylibre.com \
--to=mkorpershoek@baylibre.com \
--cc=admin@hifiphile.com \
--cc=lukma@denx.de \
--cc=marex@denx.de \
--cc=trini@konsulko.com \
--cc=u-boot@lists.denx.de \
--cc=zli@ogga.fr \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox