From: f.fainelli@gmail.com (Florian Fainelli)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH net-next v2 05/10] drivers: base: Add device_find_class()
Date: Wed, 11 Jan 2017 19:41:16 -0800 [thread overview]
Message-ID: <20170112034121.27697-6-f.fainelli@gmail.com> (raw)
In-Reply-To: <20170112034121.27697-1-f.fainelli@gmail.com>
Add a helper function to lookup a device reference given a class name.
This is a preliminary patch to remove adhoc code from net/dsa/dsa.c and
make it more generic.
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
---
drivers/base/core.c | 19 +++++++++++++++++++
include/linux/device.h | 1 +
2 files changed, 20 insertions(+)
diff --git a/drivers/base/core.c b/drivers/base/core.c
index 020ea7f05520..3dd6047c10d8 100644
--- a/drivers/base/core.c
+++ b/drivers/base/core.c
@@ -2065,6 +2065,25 @@ struct device *device_find_child(struct device *parent, void *data,
}
EXPORT_SYMBOL_GPL(device_find_child);
+static int dev_is_class(struct device *dev, void *class)
+{
+ if (dev->class != NULL && !strcmp(dev->class->name, class))
+ return 1;
+
+ return 0;
+}
+
+struct device *device_find_class(struct device *parent, char *class)
+{
+ if (dev_is_class(parent, class)) {
+ get_device(parent);
+ return parent;
+ }
+
+ return device_find_child(parent, class, dev_is_class);
+}
+EXPORT_SYMBOL_GPL(device_find_class);
+
int __init devices_init(void)
{
devices_kset = kset_create_and_add("devices", &device_uevent_ops, NULL);
diff --git a/include/linux/device.h b/include/linux/device.h
index 491b4c0ca633..8d37f5ecb972 100644
--- a/include/linux/device.h
+++ b/include/linux/device.h
@@ -1120,6 +1120,7 @@ extern int device_for_each_child_reverse(struct device *dev, void *data,
int (*fn)(struct device *dev, void *data));
extern struct device *device_find_child(struct device *dev, void *data,
int (*match)(struct device *dev, void *data));
+extern struct device *device_find_class(struct device *parent, char *class);
extern int device_rename(struct device *dev, const char *new_name);
extern int device_move(struct device *dev, struct device *new_parent,
enum dpm_order dpm_order);
--
2.9.3
WARNING: multiple messages have this Message-ID (diff)
From: Florian Fainelli <f.fainelli@gmail.com>
To: netdev@vger.kernel.org
Cc: Florian Fainelli <f.fainelli@gmail.com>,
Jason Cooper <jason@lakedaemon.net>, Andrew Lunn <andrew@lunn.ch>,
Sebastian Hesselbarth <sebastian.hesselbarth@gmail.com>,
Gregory Clement <gregory.clement@free-electrons.com>,
Russell King <linux@armlinux.org.uk>,
Vivien Didelot <vivien.didelot@savoirfairelinux.com>,
"David S. Miller" <davem@davemloft.net>,
linux-arm-kernel@lists.infradead.org (moderated list:ARM
SUB-ARCHITECTURES), linux-kernel@vger.kernel.org (open list),
gregkh@linuxfoundation.org
Subject: [PATCH net-next v2 05/10] drivers: base: Add device_find_class()
Date: Wed, 11 Jan 2017 19:41:16 -0800 [thread overview]
Message-ID: <20170112034121.27697-6-f.fainelli@gmail.com> (raw)
In-Reply-To: <20170112034121.27697-1-f.fainelli@gmail.com>
Add a helper function to lookup a device reference given a class name.
This is a preliminary patch to remove adhoc code from net/dsa/dsa.c and
make it more generic.
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
---
drivers/base/core.c | 19 +++++++++++++++++++
include/linux/device.h | 1 +
2 files changed, 20 insertions(+)
diff --git a/drivers/base/core.c b/drivers/base/core.c
index 020ea7f05520..3dd6047c10d8 100644
--- a/drivers/base/core.c
+++ b/drivers/base/core.c
@@ -2065,6 +2065,25 @@ struct device *device_find_child(struct device *parent, void *data,
}
EXPORT_SYMBOL_GPL(device_find_child);
+static int dev_is_class(struct device *dev, void *class)
+{
+ if (dev->class != NULL && !strcmp(dev->class->name, class))
+ return 1;
+
+ return 0;
+}
+
+struct device *device_find_class(struct device *parent, char *class)
+{
+ if (dev_is_class(parent, class)) {
+ get_device(parent);
+ return parent;
+ }
+
+ return device_find_child(parent, class, dev_is_class);
+}
+EXPORT_SYMBOL_GPL(device_find_class);
+
int __init devices_init(void)
{
devices_kset = kset_create_and_add("devices", &device_uevent_ops, NULL);
diff --git a/include/linux/device.h b/include/linux/device.h
index 491b4c0ca633..8d37f5ecb972 100644
--- a/include/linux/device.h
+++ b/include/linux/device.h
@@ -1120,6 +1120,7 @@ extern int device_for_each_child_reverse(struct device *dev, void *data,
int (*fn)(struct device *dev, void *data));
extern struct device *device_find_child(struct device *dev, void *data,
int (*match)(struct device *dev, void *data));
+extern struct device *device_find_class(struct device *parent, char *class);
extern int device_rename(struct device *dev, const char *new_name);
extern int device_move(struct device *dev, struct device *new_parent,
enum dpm_order dpm_order);
--
2.9.3
WARNING: multiple messages have this Message-ID (diff)
From: Florian Fainelli <f.fainelli@gmail.com>
To: netdev@vger.kernel.org
Cc: Andrew Lunn <andrew@lunn.ch>,
Florian Fainelli <f.fainelli@gmail.com>,
Jason Cooper <jason@lakedaemon.net>,
Vivien Didelot <vivien.didelot@savoirfairelinux.com>,
gregkh@linuxfoundation.org, Russell King <linux@armlinux.org.uk>,
open list <linux-kernel@vger.kernel.org>,
Gregory Clement <gregory.clement@free-electrons.com>,
"David S. Miller" <davem@davemloft.net>,
"moderated list:ARM SUB-ARCHITECTURES"
<linux-arm-kernel@lists.infradead.org>,
Sebastian Hesselbarth <sebastian.hesselbarth@gmail.com>
Subject: [PATCH net-next v2 05/10] drivers: base: Add device_find_class()
Date: Wed, 11 Jan 2017 19:41:16 -0800 [thread overview]
Message-ID: <20170112034121.27697-6-f.fainelli@gmail.com> (raw)
In-Reply-To: <20170112034121.27697-1-f.fainelli@gmail.com>
Add a helper function to lookup a device reference given a class name.
This is a preliminary patch to remove adhoc code from net/dsa/dsa.c and
make it more generic.
Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
---
drivers/base/core.c | 19 +++++++++++++++++++
include/linux/device.h | 1 +
2 files changed, 20 insertions(+)
diff --git a/drivers/base/core.c b/drivers/base/core.c
index 020ea7f05520..3dd6047c10d8 100644
--- a/drivers/base/core.c
+++ b/drivers/base/core.c
@@ -2065,6 +2065,25 @@ struct device *device_find_child(struct device *parent, void *data,
}
EXPORT_SYMBOL_GPL(device_find_child);
+static int dev_is_class(struct device *dev, void *class)
+{
+ if (dev->class != NULL && !strcmp(dev->class->name, class))
+ return 1;
+
+ return 0;
+}
+
+struct device *device_find_class(struct device *parent, char *class)
+{
+ if (dev_is_class(parent, class)) {
+ get_device(parent);
+ return parent;
+ }
+
+ return device_find_child(parent, class, dev_is_class);
+}
+EXPORT_SYMBOL_GPL(device_find_class);
+
int __init devices_init(void)
{
devices_kset = kset_create_and_add("devices", &device_uevent_ops, NULL);
diff --git a/include/linux/device.h b/include/linux/device.h
index 491b4c0ca633..8d37f5ecb972 100644
--- a/include/linux/device.h
+++ b/include/linux/device.h
@@ -1120,6 +1120,7 @@ extern int device_for_each_child_reverse(struct device *dev, void *data,
int (*fn)(struct device *dev, void *data));
extern struct device *device_find_child(struct device *dev, void *data,
int (*match)(struct device *dev, void *data));
+extern struct device *device_find_class(struct device *parent, char *class);
extern int device_rename(struct device *dev, const char *new_name);
extern int device_move(struct device *dev, struct device *new_parent,
enum dpm_order dpm_order);
--
2.9.3
next prev parent reply other threads:[~2017-01-12 3:41 UTC|newest]
Thread overview: 48+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-01-12 3:41 [PATCH net-next v2 00/10] net: dsa: Support for pdata in dsa2 Florian Fainelli
2017-01-12 3:41 ` Florian Fainelli
2017-01-12 3:41 ` [PATCH net-next v2 01/10] net: dsa: Pass device pointer to dsa_register_switch Florian Fainelli
2017-01-12 3:41 ` Florian Fainelli
2017-01-12 3:41 ` [PATCH net-next v2 02/10] net: dsa: Make most functions take a dsa_port argument Florian Fainelli
2017-01-12 3:41 ` Florian Fainelli
2017-01-12 3:41 ` [PATCH net-next v2 03/10] net: dsa: Suffix function manipulating device_node with _dn Florian Fainelli
2017-01-12 3:41 ` Florian Fainelli
2017-01-12 3:41 ` Florian Fainelli
2017-01-12 3:41 ` [PATCH net-next v2 04/10] net: dsa: Move ports assignment closer to error checking Florian Fainelli
2017-01-12 3:41 ` Florian Fainelli
2017-01-12 3:41 ` Florian Fainelli
2017-01-12 3:41 ` Florian Fainelli [this message]
2017-01-12 3:41 ` [PATCH net-next v2 05/10] drivers: base: Add device_find_class() Florian Fainelli
2017-01-12 3:41 ` Florian Fainelli
2017-01-12 21:21 ` David Miller
2017-01-12 21:21 ` David Miller
2017-01-12 22:50 ` Florian Fainelli
2017-01-12 22:50 ` Florian Fainelli
2017-01-13 4:16 ` David Miller
2017-01-13 4:16 ` David Miller
2017-01-13 10:55 ` David Laight
2017-01-13 10:55 ` David Laight
2017-01-14 19:01 ` Florian Fainelli
2017-01-14 19:01 ` Florian Fainelli
2017-01-12 3:41 ` [PATCH net-next v2 06/10] net: dsa: Migrate to device_find_class() Florian Fainelli
2017-01-12 3:41 ` Florian Fainelli
2017-01-12 3:41 ` [PATCH net-next v2 07/10] net: Relocate dev_to_net_device() into core Florian Fainelli
2017-01-12 3:41 ` Florian Fainelli
2017-01-12 3:41 ` Florian Fainelli
2017-01-12 3:41 ` [PATCH net-next v2 08/10] net: dsa: Add support for platform data Florian Fainelli
2017-01-12 3:41 ` Florian Fainelli
2017-01-13 14:04 ` Andrew Lunn
2017-01-13 14:04 ` Andrew Lunn
2017-01-13 22:37 ` Florian Fainelli
2017-01-13 22:37 ` Florian Fainelli
2017-01-14 19:12 ` Florian Fainelli
2017-01-14 19:12 ` Florian Fainelli
2017-01-13 14:11 ` Andrew Lunn
2017-01-13 14:11 ` Andrew Lunn
2017-01-13 22:39 ` Florian Fainelli
2017-01-13 22:39 ` Florian Fainelli
2017-01-12 3:41 ` [PATCH net-next v2 09/10] net: phy: Allow pre-declaration of MDIO devices Florian Fainelli
2017-01-12 3:41 ` Florian Fainelli
2017-01-12 3:41 ` [PATCH net-next v2 10/10] ARM: orion: Register DSA switch as a MDIO device Florian Fainelli
2017-01-12 3:41 ` Florian Fainelli
2017-01-13 2:34 ` [PATCH net-next v2 00/10] net: dsa: Support for pdata in dsa2 Vivien Didelot
2017-01-13 2:34 ` Vivien Didelot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20170112034121.27697-6-f.fainelli@gmail.com \
--to=f.fainelli@gmail.com \
--cc=linux-arm-kernel@lists.infradead.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.