All of lore.kernel.org
 help / color / mirror / Atom feed
From: Frank Li <Frank.Li@nxp.com>
To: Shawn Guo <shawnguo@kernel.org>, Rob Herring <robh@kernel.org>,
	Krzysztof Kozlowski <krzk+dt@kernel.org>,
	Conor Dooley <conor+dt@kernel.org>,
	linux-arm-kernel@lists.infradead.org (moderated
	list:ARM/FREESCALE LAYERSCAPE ARM ARCHITECTURE),
	devicetree@vger.kernel.org (open list:OPEN FIRMWARE AND
	FLATTENED DEVICE TREE BINDINGS),
	linux-kernel@vger.kernel.org (open list)
Cc: imx@lists.linux.dev
Subject: [PATCH v2 10/13] arm64: dts: layerscape: rename aux_bus to aux-bus
Date: Wed, 26 Jun 2024 16:25:30 -0400	[thread overview]
Message-ID: <20240626202533.2182846-11-Frank.Li@nxp.com> (raw)
In-Reply-To: <20240626202533.2182846-1-Frank.Li@nxp.com>

Rename aux_bus to aux-bus to fix below CHECK_DTBS warning.
arch/arm64/boot/dts/freescale/fsl-ls1043a-rdb.dtb:
    aux_bus: $nodename:0: 'aux_bus' does not match '^([a-z][a-z0-9\\-]+-bus|bus|localbus|soc|axi|ahb|apb)(@.+)?$'
        from schema $id: http://devicetree.org/schemas/simple-bus.yam

Signed-off-by: Frank Li <Frank.Li@nxp.com>
---
 arch/arm64/boot/dts/freescale/fsl-ls1043a.dtsi | 2 +-
 arch/arm64/boot/dts/freescale/fsl-ls1046a.dtsi | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/arm64/boot/dts/freescale/fsl-ls1043a.dtsi b/arch/arm64/boot/dts/freescale/fsl-ls1043a.dtsi
index acf3eab61b626..364eeeab089bb 100644
--- a/arch/arm64/boot/dts/freescale/fsl-ls1043a.dtsi
+++ b/arch/arm64/boot/dts/freescale/fsl-ls1043a.dtsi
@@ -805,7 +805,7 @@ QORIQ_CLK_PLL_DIV(1)>,
 					    QORIQ_CLK_PLL_DIV(1)>;
 		};
 
-		aux_bus: aux_bus {
+		aux_bus: aux-bus {
 			#address-cells = <2>;
 			#size-cells = <2>;
 			compatible = "simple-bus";
diff --git a/arch/arm64/boot/dts/freescale/fsl-ls1046a.dtsi b/arch/arm64/boot/dts/freescale/fsl-ls1046a.dtsi
index 8ce73a076e77a..f2fd8f984dc38 100644
--- a/arch/arm64/boot/dts/freescale/fsl-ls1046a.dtsi
+++ b/arch/arm64/boot/dts/freescale/fsl-ls1046a.dtsi
@@ -715,7 +715,7 @@ QORIQ_CLK_PLL_DIV(2)>,
 					    QORIQ_CLK_PLL_DIV(2)>;
 		};
 
-		aux_bus: aux_bus {
+		aux_bus: aux-bus {
 			#address-cells = <2>;
 			#size-cells = <2>;
 			compatible = "simple-bus";
-- 
2.34.1


  parent reply	other threads:[~2024-06-26 20:26 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-06-26 20:25 [PATCH v2 00/13] arm64: dts: layerscaple: clean up some simple CHECK_WARNING Frank Li
2024-06-26 20:25 ` [PATCH v2 01/13] arm64: dts: layerscape: rename node 'timer' as 'rtc' Frank Li
2024-06-26 20:28   ` [PATCH v2 00/13] arm64: dts: layerscaple: clean up some simple CHECK_WARNING Frank Li
2024-06-27 10:37     ` Shawn Guo
2024-06-26 20:25 ` [PATCH v2 02/13] arm64: dts: layerscape: add platform special compatible string for gpio Frank Li
2024-07-01 16:43   ` Rob Herring
2024-07-01 18:51     ` Frank Li
2024-06-26 20:25 ` [PATCH v2 03/13] arm64: dts: fsl-lx2160a: fix #address-cells for pinctrl-single Frank Li
2024-06-26 20:25 ` [PATCH v2 04/13] arm64: dts: fsl-ls1012a: remove property 'snps,host-vbus-glitches' Frank Li
2024-06-26 20:25 ` [PATCH v2 05/13] arm64: dts: layerscape: replace node name 'nor' with 'flash' Frank Li
2024-06-26 20:25 ` [PATCH v2 06/13] arm64: dts: layerscape: remove compatible string 'fsl,fman-xmdio' for fman3 Frank Li
2024-06-26 20:25 ` [PATCH v2 07/13] arm64: dts: layerscaple: add #dma-cells for qdma Frank Li
2024-06-27 17:17   ` Rob Herring
2024-06-27 17:22     ` Rob Herring
2024-06-27 18:27       ` Frank Li
2024-06-28  2:34         ` Shawn Guo
2024-06-26 20:25 ` [PATCH v2 08/13] arm64: dts: layerscape: rename node name "wdt" to "watchdog" Frank Li
2024-06-26 20:25 ` [PATCH v2 09/13] arm64: dts: layerscape: change pcie interrupt order Frank Li
2024-06-26 20:25 ` Frank Li [this message]
2024-06-26 20:25 ` [PATCH v2 11/13] arm64: dts: fsl-ls1043a: remove unused clk-name at watchdog node Frank Li
2024-06-26 20:25 ` [PATCH v2 12/13] arm64: dts: fsl-ls1046a: rename thermal node name Frank Li
2024-06-26 20:25 ` [PATCH v2 13/13] arm64: dts: layerscape: rename b(q)man-portals to b(q)man-portals-bus Frank Li

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20240626202533.2182846-11-Frank.Li@nxp.com \
    --to=frank.li@nxp.com \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=imx@lists.linux.dev \
    --cc=krzk+dt@kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=robh@kernel.org \
    --cc=shawnguo@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.