From: Frank Li <Frank.Li@nxp.com>
To: frank.li@nxp.com
Cc: conor+dt@kernel.org, devicetree@vger.kernel.org,
imx@lists.linux.dev, krzk+dt@kernel.org,
linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org, robh@kernel.org,
shawnguo@kernel.org
Subject: [PATCH v2 00/13] arm64: dts: layerscaple: clean up some simple CHECK_WARNING
Date: Wed, 26 Jun 2024 16:28:09 -0400 [thread overview]
Message-ID: <20240626202809.2187404-1-Frank.Li@nxp.com> (raw)
In-Reply-To: <20240626202533.2182846-2-Frank.Li@nxp.com>
Change from v1 to v2
- Combine some similar warning to one patch for difference ls chipes.
- Remove arm64: dts: layerscape: add '#power-control-cells' for rcpm
rcpm actually not power-controller, it is wakeup controller, need
better method to fix warning
- Add aux-bus fix
- Add pcie irq order fix
- Add rename to rtc fix
- Add thermal-node name fix
- Add q(b)man-portals node name fix
Frank Li (13):
arm64: dts: layerscape: rename node 'timer' as 'rtc'
arm64: dts: layerscape: add platform special compatible string for
gpio
arm64: dts: fsl-lx2160a: fix #address-cells for pinctrl-single
arm64: dts: fsl-ls1012a: remove property 'snps,host-vbus-glitches'
arm64: dts: layerscape: replace node name 'nor' with 'flash'
arm64: dts: layerscape: remove compatible string 'fsl,fman-xmdio' for
fman3
arm64: dts: layerscaple: add #dma-cells for qdma
arm64: dts: layerscape: rename node name "wdt" to "watchdog"
arm64: dts: layerscape: change pcie interrupt order
arm64: dts: layerscape: rename aux_bus to aux-bus
arm64: dts: fsl-ls1043a: remove unused clk-name at watchdog node
arm64: dts: fsl-ls1046a: rename thermal node name
arm64: dts: layerscape: rename b(q)man-portals to b(q)man-portals-bus
.../arm64/boot/dts/freescale/fsl-ls1012a.dtsi | 13 +++---
.../arm64/boot/dts/freescale/fsl-ls1028a.dtsi | 5 ++-
.../boot/dts/freescale/fsl-ls1043a-qds.dts | 2 +-
.../boot/dts/freescale/fsl-ls1043a-rdb.dts | 2 +-
.../arm64/boot/dts/freescale/fsl-ls1043a.dtsi | 10 ++---
.../boot/dts/freescale/fsl-ls1046a-qds.dts | 2 +-
.../arm64/boot/dts/freescale/fsl-ls1046a.dtsi | 45 ++++++++++---------
.../boot/dts/freescale/fsl-ls1088a-qds.dts | 2 +-
.../arm64/boot/dts/freescale/fsl-ls1088a.dtsi | 18 ++++----
.../boot/dts/freescale/fsl-ls208xa-qds.dtsi | 2 +-
.../boot/dts/freescale/fsl-ls208xa-rdb.dtsi | 2 +-
.../arm64/boot/dts/freescale/fsl-ls208xa.dtsi | 18 ++++----
.../arm64/boot/dts/freescale/fsl-lx2160a.dtsi | 14 +++---
.../dts/freescale/qoriq-fman3-0-10g-0.dtsi | 2 +-
.../dts/freescale/qoriq-fman3-0-10g-1.dtsi | 2 +-
.../dts/freescale/qoriq-fman3-0-1g-0.dtsi | 2 +-
.../dts/freescale/qoriq-fman3-0-1g-1.dtsi | 2 +-
.../dts/freescale/qoriq-fman3-0-1g-2.dtsi | 2 +-
.../dts/freescale/qoriq-fman3-0-1g-3.dtsi | 2 +-
.../dts/freescale/qoriq-fman3-0-1g-4.dtsi | 2 +-
.../dts/freescale/qoriq-fman3-0-1g-5.dtsi | 2 +-
.../boot/dts/freescale/qoriq-fman3-0.dtsi | 4 +-
22 files changed, 78 insertions(+), 77 deletions(-)
--
2.34.1
next prev parent reply other threads:[~2024-06-26 20:28 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-06-26 20:25 [PATCH v2 00/13] arm64: dts: layerscaple: clean up some simple CHECK_WARNING Frank Li
2024-06-26 20:25 ` [PATCH v2 01/13] arm64: dts: layerscape: rename node 'timer' as 'rtc' Frank Li
2024-06-26 20:28 ` Frank Li [this message]
2024-06-27 10:37 ` [PATCH v2 00/13] arm64: dts: layerscaple: clean up some simple CHECK_WARNING Shawn Guo
2024-06-26 20:25 ` [PATCH v2 02/13] arm64: dts: layerscape: add platform special compatible string for gpio Frank Li
2024-07-01 16:43 ` Rob Herring
2024-07-01 18:51 ` Frank Li
2024-06-26 20:25 ` [PATCH v2 03/13] arm64: dts: fsl-lx2160a: fix #address-cells for pinctrl-single Frank Li
2024-06-26 20:25 ` [PATCH v2 04/13] arm64: dts: fsl-ls1012a: remove property 'snps,host-vbus-glitches' Frank Li
2024-06-26 20:25 ` [PATCH v2 05/13] arm64: dts: layerscape: replace node name 'nor' with 'flash' Frank Li
2024-06-26 20:25 ` [PATCH v2 06/13] arm64: dts: layerscape: remove compatible string 'fsl,fman-xmdio' for fman3 Frank Li
2024-06-26 20:25 ` [PATCH v2 07/13] arm64: dts: layerscaple: add #dma-cells for qdma Frank Li
2024-06-27 17:17 ` Rob Herring
2024-06-27 17:22 ` Rob Herring
2024-06-27 18:27 ` Frank Li
2024-06-28 2:34 ` Shawn Guo
2024-06-26 20:25 ` [PATCH v2 08/13] arm64: dts: layerscape: rename node name "wdt" to "watchdog" Frank Li
2024-06-26 20:25 ` [PATCH v2 09/13] arm64: dts: layerscape: change pcie interrupt order Frank Li
2024-06-26 20:25 ` [PATCH v2 10/13] arm64: dts: layerscape: rename aux_bus to aux-bus Frank Li
2024-06-26 20:25 ` [PATCH v2 11/13] arm64: dts: fsl-ls1043a: remove unused clk-name at watchdog node Frank Li
2024-06-26 20:25 ` [PATCH v2 12/13] arm64: dts: fsl-ls1046a: rename thermal node name Frank Li
2024-06-26 20:25 ` [PATCH v2 13/13] arm64: dts: layerscape: rename b(q)man-portals to b(q)man-portals-bus Frank Li
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20240626202809.2187404-1-Frank.Li@nxp.com \
--to=frank.li@nxp.com \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=imx@lists.linux.dev \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=robh@kernel.org \
--cc=shawnguo@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.