All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 1/4] xfs: rename xfs_linux.h to xfs_platform.h
  2025-12-19  5:41 [PATCH v2] rename xfs.h Christoph Hellwig
@ 2025-12-19  5:41 ` Christoph Hellwig
  0 siblings, 0 replies; 2+ messages in thread
From: Christoph Hellwig @ 2025-12-19  5:41 UTC (permalink / raw)
  To: Carlos Maiolino
  Cc: Andrey Albershteyn, Darrick J . Wong, Dave Chinner, Eric Sandeen,
	linux-xfs

Rename xfs_linux.h to prepare for including including it directly
from source files including those shared with xfsprogs.

Signed-off-by: Christoph Hellwig <hch@lst.de>
---
 fs/xfs/xfs.h                           | 2 +-
 fs/xfs/{xfs_linux.h => xfs_platform.h} | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)
 rename fs/xfs/{xfs_linux.h => xfs_platform.h} (98%)

diff --git a/fs/xfs/xfs.h b/fs/xfs/xfs.h
index 9355ccad9503..b335a471c088 100644
--- a/fs/xfs/xfs.h
+++ b/fs/xfs/xfs.h
@@ -23,6 +23,6 @@
 #endif
 
 
-#include "xfs_linux.h"
+#include "xfs_platform.h"
 
 #endif	/* __XFS_H__ */
diff --git a/fs/xfs/xfs_linux.h b/fs/xfs/xfs_platform.h
similarity index 98%
rename from fs/xfs/xfs_linux.h
rename to fs/xfs/xfs_platform.h
index 4dd747bdbcca..ec8cd71fc868 100644
--- a/fs/xfs/xfs_linux.h
+++ b/fs/xfs/xfs_platform.h
@@ -3,8 +3,8 @@
  * Copyright (c) 2000-2005 Silicon Graphics, Inc.
  * All Rights Reserved.
  */
-#ifndef __XFS_LINUX__
-#define __XFS_LINUX__
+#ifndef _XFS_PLATFORM_H
+#define _XFS_PLATFORM_H
 
 #include <linux/types.h>
 #include <linux/uuid.h>
@@ -281,4 +281,4 @@ kmem_to_page(void *addr)
 	return virt_to_page(addr);
 }
 
-#endif /* __XFS_LINUX__ */
+#endif /* _XFS_PLATFORM_H */
-- 
2.47.3


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH 1/4] xfs: rename xfs_linux.h to xfs_platform.h
@ 2025-12-19 17:18 kernel test robot
  0 siblings, 0 replies; 2+ messages in thread
From: kernel test robot @ 2025-12-19 17:18 UTC (permalink / raw)
  To: oe-kbuild

:::::: 
:::::: Manual check reason: "high confidence checkpatch report"
:::::: 

BCC: lkp@intel.com
CC: oe-kbuild-all@lists.linux.dev
In-Reply-To: <20251219054202.1773441-2-hch@lst.de>
References: <20251219054202.1773441-2-hch@lst.de>
TO: Christoph Hellwig <hch@lst.de>
TO: Carlos Maiolino <cem@kernel.org>

Hi Christoph,

kernel test robot noticed the following build warnings:

[auto build test WARNING on xfs-linux/for-next]
[If your patch is applied to the wrong git tree, kindly drop us a note.
And when submitting patch, we suggest to use '--base' as documented in
https://git-scm.com/docs/git-format-patch#_base_tree_information]

url:    https://github.com/intel-lab-lkp/linux/commits/Christoph-Hellwig/xfs-include-global-headers-first-in-xfs_platform-h/20251219-144249
base:   https://git.kernel.org/pub/scm/fs/xfs/xfs-linux.git for-next
patch link:    https://lore.kernel.org/r/20251219054202.1773441-2-hch%40lst.de
patch subject: [PATCH 1/4] xfs: rename xfs_linux.h to xfs_platform.h
:::::: branch date: 11 hours ago
:::::: commit date: 11 hours ago
reproduce: (https://download.01.org/0day-ci/archive/20251219/202512191801.CYuDRRG2-lkp@intel.com/reproduce)

# many are suggestions rather than must-fix

WARNING:REPEATED_WORD: Possible repeated word: 'including'
#6: 
Rename xfs_linux.h to prepare for including including it directly

-- 
0-DAY CI Kernel Test Service
https://github.com/intel/lkp-tests/wiki

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2025-12-19 17:19 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-12-19 17:18 [PATCH 1/4] xfs: rename xfs_linux.h to xfs_platform.h kernel test robot
  -- strict thread matches above, loose matches on Subject: below --
2025-12-19  5:41 [PATCH v2] rename xfs.h Christoph Hellwig
2025-12-19  5:41 ` [PATCH 1/4] xfs: rename xfs_linux.h to xfs_platform.h Christoph Hellwig

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.