From: "Daniel P. Smith" <dpsmith@apertussolutions.com>
To: Jan Beulich <jbeulich@suse.com>
Cc: "Andrew Cooper" <andrew.cooper3@citrix.com>,
"Teddy Astie" <teddy.astie@vates.tech>,
"Roger Pau Monné" <roger@xenproject.org>,
"xen-devel@lists.xenproject.org" <xen-devel@lists.xenproject.org>
Subject: Re: [PATCH 20/24] XSM: fold xsm_{,un}map_domain_pirq() hooks
Date: Thu, 13 Aug 2026 08:42:30 -0400 [thread overview]
Message-ID: <7828588f-38d7-4039-95c3-8ffd386a8509@apertussolutions.com> (raw)
In-Reply-To: <274a27cb-13f0-47c3-aa73-1534925dc350@suse.com>
On 8/6/26 3:36 AM, Jan Beulich wrote:
> On 06.08.2026 03:10, Daniel P. Smith wrote:
>> On 7/28/26 9:23 AM, Jan Beulich wrote:
>>> --- a/xen/xsm/flask/hooks.c
>>> +++ b/xen/xsm/flask/hooks.c
>>> @@ -1022,14 +1022,9 @@ static char *cf_check flask_show_irq_sid
>>>
>>> #ifdef CONFIG_HAS_PIRQ
>>>
>>> -static int cf_check flask_map_domain_pirq(struct domain *d)
>>> +static int cf_check flask_map_domain_pirq(struct domain *d, bool access)
>>> {
>>> - return current_has_perm(d, SECCLASS_RESOURCE, RESOURCE__ADD);
>>> -}
>>> -
>>> -static int cf_check flask_unmap_domain_pirq(struct domain *d)
>>> -{
>>> - return current_has_perm(d, SECCLASS_RESOURCE, RESOURCE__REMOVE);
>>> + return current_has_perm(d, SECCLASS_RESOURCE, resource_to_perm(access));
>>> }
>>>
>>> #endif /* CONFIG_HAS_PIRQ */
>>>
>>
>> I am not opposed to collapsing the calls as long as the semantic is not
>> lost, which I feel the reuse of the xsm_map_domain_pirq does looses it
>> much less provides an opportunity for confusion. Something like
>> xsm_domain_pirq(..., access) makes more semantic sense to me, as it
>> would read, grant domain pirq access T/F.
>
> In fact I was as well wondering about naming (and a possible name change)
> here. I decided against it because of the other hooks (touched by patch
> 19), which all follow a similar model of their names really more expressing
> the "positive" form than the "negative" one. Further, entirely losing "map"
> from the name also doesn't look quite right, as physdev_{,un}map_pirq() is
> where they're called from. To follow the naming of some of the other hook,
> maybe xsm_domain_pirq_mapping(..., bool map)? Possibly even with "domain"
> dropped from the name, fully fitting xsm_io{mem,port}_mapping()? Which
> would then further raise the question whether patch 19 should maybe rename
> the parameters of those two hooks to "map" at the same time.
>
Sound like you and I were running through the same argument with
ourselves, except you went right and I went left.
For me, I find the false case of xsm_map_domain_pirq(..., access) reads
a bit weird, "Can the target map domain pirq access=false?" I do like
your mapping suggestion along with the parameter rename to map. It
changes the reading to "Is target allowed map(true)/unmap(false) for the
domain pirq mapping?" This could be carried through to the other cases.
v/r,
dps
next prev parent reply other threads:[~2026-08-13 12:42 UTC|newest]
Thread overview: 73+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-28 13:10 [PATCH 00/24] XSM: follow-on to XSAs 492 and 499 Jan Beulich
2026-07-28 13:13 ` [PATCH 01/24] XSM: reduce redundancy in hook machinery Jan Beulich
2026-07-30 15:05 ` Daniel P. Smith
2026-07-30 15:18 ` Jan Beulich
2026-07-30 18:21 ` Daniel P. Smith
2026-07-31 8:03 ` Jan Beulich
2026-08-02 14:46 ` Daniel P. Smith
2026-07-28 13:14 ` [PATCH 02/24] XSM: make .grant_*() hooks dependent upon GRANT_TABLE=y Jan Beulich
2026-07-30 18:23 ` Daniel P. Smith
2026-07-28 13:14 ` [PATCH 03/24] XSM: make .{,un}map_domain_pirq() hooks dependent upon HAS_PIRQ=y Jan Beulich
2026-08-02 14:50 ` Daniel P. Smith
2026-07-28 13:14 ` [PATCH 04/24] XSM: make PCI hooks dependent upon HAS_PCI=y Jan Beulich
2026-08-02 14:53 ` Daniel P. Smith
2026-07-28 13:15 ` [PATCH 05/24] XSM: make .iomem_mapping_vcpi() hook dependent upon HAS_VPCI=y Jan Beulich
2026-08-02 14:56 ` Daniel P. Smith
2026-07-28 13:15 ` [PATCH 06/24] XSM: make .kexec() hook dependent upon KEXEC=y Jan Beulich
2026-08-02 14:57 ` Daniel P. Smith
2026-07-28 13:15 ` [PATCH 07/24] XSM: make .hypfs() hook dependent upon HYPFS=y Jan Beulich
2026-08-02 14:58 ` Daniel P. Smith
2026-07-28 13:16 ` [PATCH 08/24] XSM: make .hvm_altp2mhvm_op() hook dependent upon ALTP2M=y Jan Beulich
2026-08-02 14:58 ` Daniel P. Smith
2026-07-28 13:17 ` [PATCH 09/24] XSM: make .hvm_param*() hooks dependent upon HVM=y Jan Beulich
2026-08-02 15:05 ` Daniel P. Smith
2026-08-03 9:55 ` Jan Beulich
2026-08-02 15:05 ` Daniel P. Smith
2026-07-28 13:17 ` [PATCH 10/24] XSM: make .dm_op() hook dependent upon IOREQ_SERVER=y Jan Beulich
2026-08-02 15:07 ` Daniel P. Smith
2026-07-28 13:18 ` [PATCH 11/24] XSM: make certain x86-specific hooks dependent upon PV=y Jan Beulich
2026-08-02 15:08 ` Daniel P. Smith
2026-07-28 13:18 ` [PATCH 12/24] x86/mm: get_page_from_l1e() is PV-or-shadow-only Jan Beulich
2026-08-02 15:55 ` Daniel P. Smith
2026-08-03 10:11 ` Jan Beulich
2026-08-13 11:51 ` Daniel P. Smith
2026-08-13 12:14 ` Jan Beulich
2026-08-13 13:02 ` Daniel P. Smith
2026-07-28 13:19 ` [PATCH 13/24] x86: restrict PHYSDEVOP_* when PV=n Jan Beulich
2026-08-05 22:38 ` Daniel P. Smith
2026-07-28 13:19 ` [PATCH 14/24] XSM/dummy: fold cf_check into XSM_INLINE Jan Beulich
2026-08-05 22:39 ` Daniel P. Smith
2026-07-28 13:20 ` [PATCH 15/24] XSM/dummy: drop redundant return statements Jan Beulich
2026-08-05 22:40 ` Daniel P. Smith
2026-07-28 13:20 ` [PATCH 16/24] XSM: suppress hypercall when XSM=n Jan Beulich
2026-08-05 22:42 ` Daniel P. Smith
2026-07-28 13:22 ` [PATCH 17/24] XSM: make Argo hooks well-formed ones Jan Beulich
2026-08-03 21:01 ` Jason Andryuk
2026-08-04 7:53 ` Jan Beulich
2026-08-04 14:27 ` Jason Andryuk
2026-08-05 9:11 ` Jan Beulich
2026-08-06 0:37 ` Daniel P. Smith
2026-08-05 23:02 ` Daniel P. Smith
2026-08-06 7:16 ` Jan Beulich
2026-08-06 14:09 ` Jason Andryuk
2026-08-13 12:09 ` Daniel P. Smith
2026-08-15 1:12 ` Jason Andryuk
2026-07-28 13:22 ` [PATCH 18/24] XSM: make XSM " Jan Beulich
2026-08-06 0:53 ` Daniel P. Smith
2026-08-06 7:22 ` Jan Beulich
2026-07-28 13:23 ` [PATCH 19/24] XSM: convert "allow" (Flask: "access") parameters to bool Jan Beulich
2026-08-06 0:56 ` Daniel P. Smith
2026-07-28 13:23 ` [PATCH 20/24] XSM: fold xsm_{,un}map_domain_pirq() hooks Jan Beulich
2026-08-06 1:10 ` Daniel P. Smith
2026-08-06 7:36 ` Jan Beulich
2026-08-06 8:02 ` Jan Beulich
2026-08-13 12:42 ` Daniel P. Smith [this message]
2026-08-13 13:02 ` Jan Beulich
2026-08-13 13:05 ` Daniel P. Smith
2026-07-28 13:24 ` [PATCH 21/24] x86: type-correct last parameter of map_domain_pirq() Jan Beulich
2026-07-28 13:25 ` [PATCH 22/24] XSM: pass just SBDF to xsm_{,un}map_domain_irq() Jan Beulich
2026-08-06 1:16 ` Daniel P. Smith
2026-07-28 13:26 ` [PATCH 23/24] XSM: fold xsm_{,un}map_domain_irq() hooks Jan Beulich
2026-08-13 11:27 ` Daniel P. Smith
2026-07-28 13:26 ` [PATCH 24/24] XSM: fold xsm_{,un}bind_pt_irq() hooks Jan Beulich
2026-08-13 11:32 ` Daniel P. Smith
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=7828588f-38d7-4039-95c3-8ffd386a8509@apertussolutions.com \
--to=dpsmith@apertussolutions.com \
--cc=andrew.cooper3@citrix.com \
--cc=jbeulich@suse.com \
--cc=roger@xenproject.org \
--cc=teddy.astie@vates.tech \
--cc=xen-devel@lists.xenproject.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.