From: "Daniel P. Smith" <dpsmith@apertussolutions.com>
To: Jan Beulich <jbeulich@suse.com>
Cc: "Andrew Cooper" <andrew.cooper3@citrix.com>,
"Teddy Astie" <teddy.astie@vates.tech>,
"Roger Pau Monné" <roger@xenproject.org>,
"xen-devel@lists.xenproject.org" <xen-devel@lists.xenproject.org>
Subject: Re: [PATCH 12/24] x86/mm: get_page_from_l1e() is PV-or-shadow-only
Date: Thu, 13 Aug 2026 09:02:35 -0400 [thread overview]
Message-ID: <f7ff827b-fb15-432c-8a5b-d5e73531a526@apertussolutions.com> (raw)
In-Reply-To: <a83cf90c-142a-41ee-a80b-4e849cc804f3@suse.com>
On 8/13/26 8:14 AM, Jan Beulich wrote:
> On 13.08.2026 13:51, Daniel P. Smith wrote:
>> On 8/3/26 6:11 AM, Jan Beulich wrote:
>>> On 02.08.2026 17:55, Daniel P. Smith wrote:
>>>> On 7/28/26 9:18 AM, Jan Beulich wrote:
>>>>> Otherwise the function is unreachable, violating MISRA C:2012 rule 2.1.
>>>>> With the function compiled out, its dedicated XSM hook also becomes
>>>>> unreachable, so it is similarly guarded.
>>>>>
>>>>> Signed-off-by: Jan Beulich <jbeulich@suse.com>
>>>>> ---
>>>>> It feels suspicious that the .priv_mapping() check is used for HVM guests
>>>>> in shadow mode, but not for ones in HAP mode.
>>>>
>>>> I believe a hint to it is laying in the comment,
>>>>
>>>> /*
>>>> * Let privileged domains transfer the right to map their target
>>>> * domain's pages. This is used to allow stub-domain pvfb export to
>>>> * dom0, until pvfb supports granted mappings. At that time this
>>>> * minor hack can go away.
>>>> */
>>>>
>>>> Correct me if I am wrong, but get_page_from_l1e() is only used by PV and
>>>> HVM + Shadow. When in HVM + HAP is mapping a guest page, it is done
>>>> through p2m_get_foreign() which will then be covered by
>>>> xsm_map_gmfn_foreign(). So only HVM + Shadow can hit TARGET_HACK check.
>>>
>>> Yes, sure; that wasn't the point of my comment. The point was that I'd
>>> expect _the same_ hook to be used by the other path. Aiui if you make a
>>> policy, you want same situations dealt with the same. Hence there shouldn't
>>> be a need to express the same thing two ways.
>>
>> But it's not the same, the enforcement mechanism is different. FLASK is
>> an evaluation of Subject/Object/Predicate. In this case the mechanism
>> (software enforced access) that provides the Predicate has enough risk
>> that it warranted itself a separate check to allow fine grained
>> assignment of the operation to a specific domain which was driven by a
>> specific use case.
>
> I don't understand this. What mode a guest is run in (HAP vs shadow)
> shouldn't affect what permissions it has. Two distinct hooks means the
> guest might change behavior when flipped between hap=0 and hap=1. Which
> absolutely shouldn't happen, imo.
>
Oh, it most certainly does affect how a security policy wants to be
written. Certain mechanisms have properties that provide certain
assurances and the security architect/policy writer may not want to
allow the access via mechanisms deemed to have an unacceptable risk.
>>>> I think the question is how to address the TARGET_HACK situation.
>>>
>>> I fear I don't really know what exactly you mean here.
>>
>> Is this path still needed for the pvfb or is it now in use by other use
>> cases. If the former, then close the ability otherwise TARGET_HACK
>> should be renamed to something sensible for general case. Some code
>> documentation might be necessary to help understand why/
>
> Only after grep-ing it has become apparent that TARGET_HACK is something
> in Flask. It's entirely invisible outside of Flask, e.g. at the call site
> of the hook.
>
Correct.
> I think the comment is stale in referencing only pvfb, but I'm not really
> sure. It is too long ago that I last saw the log message issued there,
> and hence I don't recall under what (buggy guest?) conditions it could
> surface.
>
Agreed, that's why I was trying to say that it appears to have been
created based on that specific situation. My question is, did this
situation evolve to no longer be a one-off or can we close the ability
to map memory this way. The comment alludes that it was a temporary
method of access, but I haven't studied the path to this check or what
situations could follow that path today. I have a suspicion that it's no
longer a one-off situation.
v/r,
dps
next prev parent reply other threads:[~2026-08-13 13:03 UTC|newest]
Thread overview: 73+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-28 13:10 [PATCH 00/24] XSM: follow-on to XSAs 492 and 499 Jan Beulich
2026-07-28 13:13 ` [PATCH 01/24] XSM: reduce redundancy in hook machinery Jan Beulich
2026-07-30 15:05 ` Daniel P. Smith
2026-07-30 15:18 ` Jan Beulich
2026-07-30 18:21 ` Daniel P. Smith
2026-07-31 8:03 ` Jan Beulich
2026-08-02 14:46 ` Daniel P. Smith
2026-07-28 13:14 ` [PATCH 02/24] XSM: make .grant_*() hooks dependent upon GRANT_TABLE=y Jan Beulich
2026-07-30 18:23 ` Daniel P. Smith
2026-07-28 13:14 ` [PATCH 03/24] XSM: make .{,un}map_domain_pirq() hooks dependent upon HAS_PIRQ=y Jan Beulich
2026-08-02 14:50 ` Daniel P. Smith
2026-07-28 13:14 ` [PATCH 04/24] XSM: make PCI hooks dependent upon HAS_PCI=y Jan Beulich
2026-08-02 14:53 ` Daniel P. Smith
2026-07-28 13:15 ` [PATCH 05/24] XSM: make .iomem_mapping_vcpi() hook dependent upon HAS_VPCI=y Jan Beulich
2026-08-02 14:56 ` Daniel P. Smith
2026-07-28 13:15 ` [PATCH 06/24] XSM: make .kexec() hook dependent upon KEXEC=y Jan Beulich
2026-08-02 14:57 ` Daniel P. Smith
2026-07-28 13:15 ` [PATCH 07/24] XSM: make .hypfs() hook dependent upon HYPFS=y Jan Beulich
2026-08-02 14:58 ` Daniel P. Smith
2026-07-28 13:16 ` [PATCH 08/24] XSM: make .hvm_altp2mhvm_op() hook dependent upon ALTP2M=y Jan Beulich
2026-08-02 14:58 ` Daniel P. Smith
2026-07-28 13:17 ` [PATCH 09/24] XSM: make .hvm_param*() hooks dependent upon HVM=y Jan Beulich
2026-08-02 15:05 ` Daniel P. Smith
2026-08-03 9:55 ` Jan Beulich
2026-08-02 15:05 ` Daniel P. Smith
2026-07-28 13:17 ` [PATCH 10/24] XSM: make .dm_op() hook dependent upon IOREQ_SERVER=y Jan Beulich
2026-08-02 15:07 ` Daniel P. Smith
2026-07-28 13:18 ` [PATCH 11/24] XSM: make certain x86-specific hooks dependent upon PV=y Jan Beulich
2026-08-02 15:08 ` Daniel P. Smith
2026-07-28 13:18 ` [PATCH 12/24] x86/mm: get_page_from_l1e() is PV-or-shadow-only Jan Beulich
2026-08-02 15:55 ` Daniel P. Smith
2026-08-03 10:11 ` Jan Beulich
2026-08-13 11:51 ` Daniel P. Smith
2026-08-13 12:14 ` Jan Beulich
2026-08-13 13:02 ` Daniel P. Smith [this message]
2026-07-28 13:19 ` [PATCH 13/24] x86: restrict PHYSDEVOP_* when PV=n Jan Beulich
2026-08-05 22:38 ` Daniel P. Smith
2026-07-28 13:19 ` [PATCH 14/24] XSM/dummy: fold cf_check into XSM_INLINE Jan Beulich
2026-08-05 22:39 ` Daniel P. Smith
2026-07-28 13:20 ` [PATCH 15/24] XSM/dummy: drop redundant return statements Jan Beulich
2026-08-05 22:40 ` Daniel P. Smith
2026-07-28 13:20 ` [PATCH 16/24] XSM: suppress hypercall when XSM=n Jan Beulich
2026-08-05 22:42 ` Daniel P. Smith
2026-07-28 13:22 ` [PATCH 17/24] XSM: make Argo hooks well-formed ones Jan Beulich
2026-08-03 21:01 ` Jason Andryuk
2026-08-04 7:53 ` Jan Beulich
2026-08-04 14:27 ` Jason Andryuk
2026-08-05 9:11 ` Jan Beulich
2026-08-06 0:37 ` Daniel P. Smith
2026-08-05 23:02 ` Daniel P. Smith
2026-08-06 7:16 ` Jan Beulich
2026-08-06 14:09 ` Jason Andryuk
2026-08-13 12:09 ` Daniel P. Smith
2026-08-15 1:12 ` Jason Andryuk
2026-07-28 13:22 ` [PATCH 18/24] XSM: make XSM " Jan Beulich
2026-08-06 0:53 ` Daniel P. Smith
2026-08-06 7:22 ` Jan Beulich
2026-07-28 13:23 ` [PATCH 19/24] XSM: convert "allow" (Flask: "access") parameters to bool Jan Beulich
2026-08-06 0:56 ` Daniel P. Smith
2026-07-28 13:23 ` [PATCH 20/24] XSM: fold xsm_{,un}map_domain_pirq() hooks Jan Beulich
2026-08-06 1:10 ` Daniel P. Smith
2026-08-06 7:36 ` Jan Beulich
2026-08-06 8:02 ` Jan Beulich
2026-08-13 12:42 ` Daniel P. Smith
2026-08-13 13:02 ` Jan Beulich
2026-08-13 13:05 ` Daniel P. Smith
2026-07-28 13:24 ` [PATCH 21/24] x86: type-correct last parameter of map_domain_pirq() Jan Beulich
2026-07-28 13:25 ` [PATCH 22/24] XSM: pass just SBDF to xsm_{,un}map_domain_irq() Jan Beulich
2026-08-06 1:16 ` Daniel P. Smith
2026-07-28 13:26 ` [PATCH 23/24] XSM: fold xsm_{,un}map_domain_irq() hooks Jan Beulich
2026-08-13 11:27 ` Daniel P. Smith
2026-07-28 13:26 ` [PATCH 24/24] XSM: fold xsm_{,un}bind_pt_irq() hooks Jan Beulich
2026-08-13 11:32 ` Daniel P. Smith
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=f7ff827b-fb15-432c-8a5b-d5e73531a526@apertussolutions.com \
--to=dpsmith@apertussolutions.com \
--cc=andrew.cooper3@citrix.com \
--cc=jbeulich@suse.com \
--cc=roger@xenproject.org \
--cc=teddy.astie@vates.tech \
--cc=xen-devel@lists.xenproject.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.