All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/4] drm/ast: Use struct ast_device
@ 2023-02-21 15:57 Thomas Zimmermann
  2023-02-21 15:57 ` [PATCH 1/4] drm/ast: Remove little-endianism from I/O helpers Thomas Zimmermann
                   ` (3 more replies)
  0 siblings, 4 replies; 9+ messages in thread
From: Thomas Zimmermann @ 2023-02-21 15:57 UTC (permalink / raw)
  To: jfalempe, airlied, airlied, daniel; +Cc: Thomas Zimmermann, dri-devel

Rename struct ast_private to struct ast_device. The old name comes
from the time when struct drm_device.dev_private was still in use.
Also update the upcast helper.

The renaming touches ast's I/O-helper macros, which generate warnings
with checkpatch. So fix the I/O helpers in the first two patches of
this patchset.

Tested on AST2100 hardware.

Thomas Zimmermann (4):
  drm/ast: Remove little-endianism from I/O helpers
  drm/ast: Rework definition of I/O read and write helpers
  drm/ast: Rename struct ast_private to struct ast_device
  drm/ast: Rename to_ast_private() to to_ast_device()

 drivers/gpu/drm/ast/ast_dp.c    | 10 ++--
 drivers/gpu/drm/ast/ast_dp501.c | 40 +++++++-------
 drivers/gpu/drm/ast/ast_drv.c   |  2 +-
 drivers/gpu/drm/ast/ast_drv.h   | 84 ++++++++++++-----------------
 drivers/gpu/drm/ast/ast_i2c.c   |  8 +--
 drivers/gpu/drm/ast/ast_main.c  | 24 ++++-----
 drivers/gpu/drm/ast/ast_mm.c    |  4 +-
 drivers/gpu/drm/ast/ast_mode.c  | 78 +++++++++++++--------------
 drivers/gpu/drm/ast/ast_post.c  | 94 ++++++++++++++++-----------------
 9 files changed, 163 insertions(+), 181 deletions(-)

-- 
2.39.2


^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2023-02-28 10:35 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2023-02-21 15:57 [PATCH 0/4] drm/ast: Use struct ast_device Thomas Zimmermann
2023-02-21 15:57 ` [PATCH 1/4] drm/ast: Remove little-endianism from I/O helpers Thomas Zimmermann
2023-02-28 10:15   ` Javier Martinez Canillas
2023-02-21 15:57 ` [PATCH 2/4] drm/ast: Rework definition of I/O read and write helpers Thomas Zimmermann
2023-02-28 10:25   ` Javier Martinez Canillas
2023-02-21 15:57 ` [PATCH 3/4] drm/ast: Rename struct ast_private to struct ast_device Thomas Zimmermann
2023-02-28 10:32   ` Javier Martinez Canillas
2023-02-21 15:57 ` [PATCH 4/4] drm/ast: Rename to_ast_private() to to_ast_device() Thomas Zimmermann
2023-02-28 10:33   ` Javier Martinez Canillas

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.