All of lore.kernel.org
 help / color / mirror / Atom feed
From: Oleksii <oleksii.kurochko@gmail.com>
To: Julien Grall <julien@xen.org>, xen-devel@lists.xenproject.org
Cc: Andrew Cooper <andrew.cooper3@citrix.com>,
	Jan Beulich <jbeulich@suse.com>,
	 Stefano Stabellini <sstabellini@kernel.org>,
	Bertrand Marquis <bertrand.marquis@arm.com>,
	Michal Orzel <michal.orzel@amd.com>,
	Volodymyr Babchuk <Volodymyr_Babchuk@epam.com>
Subject: Re: [PATCH v2 6/8] xen/riscv: introduce generic Xen page table handling
Date: Mon, 22 Jul 2024 16:51:46 +0200	[thread overview]
Message-ID: <a0e77fa86e25a3947348e5778b4a23236b28c8f3.camel@gmail.com> (raw)
In-Reply-To: <5187f606-0a1c-4812-8f8c-13301f0aba8c@xen.org>

Hi Julien,

On Sun, 2024-07-21 at 10:02 +0100, Julien Grall wrote:
> Hi,
> 
> On 12/07/2024 17:22, Oleksii Kurochko wrote:
> > At least, between Arm and RISC-V most of the code related to Xen
> > page
> > table handling are common.
> > 
> > This GENERIC_PT code is based on Arm's arm/mmu/pt.c except some
> > minor
> > changes such as introduction of the following functions:
> >    * get_root_page()
> >    * xen_pt_check_contig()
> >    * set_pte_table_bit()
> >    * sanity_arch_specific_pte_checks()
> >    * get_contig_bit()
> >    * set_pte_permissions()
> >    * flush_xen_tlb_range_va()
> > It was done because not every functions has the generic pte_flags
> > and
> > it could be a different positions of the PTE bits in a PTE.
> While I am always in favor of trying to avoid code duplication, I am
> not 
> sure the page-tables are one that should be.
Probably it wasn't the best one abstraction provided. But I think that
there are still some function which could be generic:
- xen_{un}map_table()
- map_pages_to_xen
- probably some page table walking?

But I am okay, if not to abstract that, I just wanted to here an
opinion if it is a sense to work in this direction or not.

I will then move everything to RISC-V specific folder and clean up some
places related to Arm.

~ Oleksii

> 
> For instance, you don't have the concept of contiguous page in RISC-V
> (I 
> see you introduce dummy flags, but IMHO this is a bit of a hack). All
> the code was also written in a way to avoid temporary conflict
> mappings. 
> This is to avoid using Break-Before-Make. But on newer hardware this 
> could be relaxed.
> 
> I am interested to know what the others thinks.
> 
> Cheers,
> 



  parent reply	other threads:[~2024-07-22 14:51 UTC|newest]

Thread overview: 51+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-07-12 16:22 [PATCH v2 0/8] RISCV device tree mapping Oleksii Kurochko
2024-07-12 16:22 ` [PATCH v6 1/8] xen/device-tree: Move Arm's setup.c bootinfo functions to common Oleksii Kurochko
2024-07-15  8:36   ` Jan Beulich
2024-07-15 10:15   ` Michal Orzel
2024-07-15 13:42     ` Oleksii
2024-07-12 16:22 ` [PATCH v6 2/8] xen/common: Move Arm's bootfdt.c " Oleksii Kurochko
2024-07-12 16:22 ` [PATCH v2 3/8] xen/riscv: enable CONFIG_HAS_DEVICE_TREE Oleksii Kurochko
2024-07-15  8:40   ` Jan Beulich
2024-07-12 16:22 ` [PATCH v2 4/8] xen/riscv: setup fixmap mapping Oleksii Kurochko
2024-07-21  8:46   ` Julien Grall
2024-07-22 14:31     ` Oleksii
2024-07-22 14:44       ` Julien Grall
2024-07-23 12:58     ` oleksii.kurochko
2024-07-23 13:32       ` Julien Grall
2024-07-23 13:27     ` oleksii.kurochko
2024-07-23 13:33       ` Julien Grall
2024-07-23 13:38         ` oleksii.kurochko
2024-07-22 12:42   ` Jan Beulich
2024-07-22 14:36     ` Oleksii
2024-07-22 15:25       ` Jan Beulich
2024-07-22 17:04         ` oleksii.kurochko
2024-07-23 13:34           ` oleksii.kurochko
2024-07-12 16:22 ` [PATCH v2 5/8] xen/riscv: introduce asm/pmap.h header Oleksii Kurochko
2024-07-21  8:51   ` Julien Grall
2024-07-22 12:58     ` Jan Beulich
2024-07-22 14:57       ` Julien Grall
2024-07-22 14:40     ` Oleksii
2024-07-22 12:54   ` Jan Beulich
2024-07-22 14:44     ` Oleksii Kurochko
2024-07-22 14:48       ` Julien Grall
2024-07-22 17:09         ` Oleksii Kurochko
2024-07-22 17:21           ` Julien Grall
2024-07-23  8:02             ` Oleksii Kurochko
2024-07-23  8:36               ` Jan Beulich
2024-07-23  8:55                 ` oleksii.kurochko
2024-07-23 10:02                   ` Jan Beulich
2024-07-23 15:36                     ` oleksii.kurochko
2024-07-23 15:49                       ` Julien Grall
2024-07-23 17:25                         ` oleksii.kurochko
2024-07-23 17:28                           ` oleksii.kurochko
2024-07-23 18:44                             ` Julien Grall
2024-07-12 16:22 ` [PATCH v2 6/8] xen/riscv: introduce generic Xen page table handling Oleksii Kurochko
2024-07-21  9:02   ` Julien Grall
2024-07-22  6:59     ` Jan Beulich
2024-07-22 14:51     ` Oleksii [this message]
2024-07-12 16:22 ` [PATCH v2 7/8] xen/riscv: select CONFIG_GENREIC_PT Oleksii Kurochko
2024-07-12 16:22 ` [PATCH v2 8/8] xen/riscv: introduce early_fdt_map() Oleksii Kurochko
2024-07-15  8:52   ` Jan Beulich
2024-07-15 13:58     ` Oleksii
2024-07-15 14:58       ` Jan Beulich
2024-07-15 15:00         ` Jan Beulich

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=a0e77fa86e25a3947348e5778b4a23236b28c8f3.camel@gmail.com \
    --to=oleksii.kurochko@gmail.com \
    --cc=Volodymyr_Babchuk@epam.com \
    --cc=andrew.cooper3@citrix.com \
    --cc=bertrand.marquis@arm.com \
    --cc=jbeulich@suse.com \
    --cc=julien@xen.org \
    --cc=michal.orzel@amd.com \
    --cc=sstabellini@kernel.org \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.