From: Sean Christopherson <seanjc@google.com>
To: Yosry Ahmed <yosry@kernel.org>
Cc: Paolo Bonzini <pbonzini@redhat.com>,
Jim Mattson <jmattson@google.com>,
Maxim Levitsky <mlevitsk@redhat.com>,
Vitaly Kuznetsov <vkuznets@redhat.com>,
Tom Lendacky <thomas.lendacky@amd.com>,
kvm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [RFC PATCH v2 22/25] KVM: x86/mmu: Refactor kvm_mmu_invlpg() to allow skipping the gva flush
Date: Mon, 27 Jul 2026 09:41:12 -0700 [thread overview]
Message-ID: <ameKKF_XBAXFCTkR@google.com> (raw)
In-Reply-To: <CAO9r8zNE6E7GYg=jrtRVnyG-2xtkFCrNP6FRiH5ZVgmCRKMLtQ@mail.gmail.com>
On Mon, Jul 27, 2026, Yosry Ahmed wrote:
> On Mon, Jul 27, 2026 at 8:38 AM Sean Christopherson <seanjc@google.com> wrote:
> > On Fri, Jul 24, 2026, Yosry Ahmed wrote:
> > > > > What's the main objection to kvm_mmu_invalidate_addr_in_root()?
> > > >
> > > > I don't love the __kvm_mmu_invalidate_addr() => kvm_mmu_invalidate_addr_in_root()
> > > > callchain. It's not at all obvious that the in_root() helper shouldn't be called
> > > > directly. I don't hate it, but I do think we need better clarity on what all this
> > > > is doing.
> > > >
> > > > E.g. when looking at __kvm_inject_emulated_page_fault(), since it hardcodes a
> > > > single root, it's a bit headscratching to use kvm_mmu_invalidate_addr() instead
> > > > of kvm_mmu_invalidate_addr_in_root.
> > >
> > > Coming back to this, I agree it's confusing. I think this can be fixed
> > > with a better name though. Looking at
> > > kvm_mmu_invalidate_addr_in_root() (or __kvm_mmu_invalidate_addr() in
> > > current code), seems like what it does is find SPTEs for that address,
> > > sync them, and flush the TLB if needed.
> > >
> > > So maybe mmu_sync_addr_sptes() or mmu_sync_and_flush_addr_sptes()?
> >
> > kvm_mmu_sync_addr()? The "sptes" part is implied in things like kvm_sync_page()
> > and mmu_sync_children().
>
> Sounds good. I assume you're okay with keeping everything else the
> same way? I assume you didn't like any of the alternatives?
Ya, I don't want risk delaying this series chasing down flaws that no one cares
about in practice.
next prev parent reply other threads:[~2026-07-27 16:41 UTC|newest]
Thread overview: 96+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-16 0:41 [RFC PATCH v2 00/25] Optimize nSVM TLB flushes Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 01/25] KVM: nSVM: Flush the TLB after forcefully leaving nested Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 02/25] KVM: SVM: Passthrough the number of supported ASIDs Yosry Ahmed
2026-07-14 13:20 ` Yosry Ahmed
2026-07-14 21:28 ` Jim Mattson
2026-07-14 21:43 ` Yosry Ahmed
2026-07-14 23:41 ` Sean Christopherson
2026-07-15 6:32 ` Jim Mattson
2026-07-15 17:45 ` Yosry Ahmed
2026-07-15 18:20 ` Jim Mattson
2026-07-15 19:12 ` Yosry Ahmed
2026-07-16 23:09 ` Jim Mattson
2026-07-22 22:09 ` Sean Christopherson
2026-07-22 22:39 ` Jim Mattson
2026-07-23 0:27 ` Sean Christopherson
2026-07-23 2:46 ` Jim Mattson
2026-07-23 12:24 ` Jim Mattson
2026-07-23 14:07 ` Sean Christopherson
2026-07-23 15:57 ` Jim Mattson
2026-07-23 16:32 ` Yosry Ahmed
2026-07-23 16:54 ` Jim Mattson
2026-07-23 16:57 ` Yosry Ahmed
2026-07-23 17:07 ` Jim Mattson
2026-07-23 17:26 ` Sean Christopherson
2026-07-23 17:34 ` Yosry Ahmed
2026-07-15 17:41 ` Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 03/25] KVM: VMX: Generalize VPID allocation to be vendor-neutral Yosry Ahmed
2026-07-22 22:26 ` Sean Christopherson
2026-07-22 22:36 ` Yosry Ahmed
2026-07-23 13:26 ` Sean Christopherson
2026-06-16 0:41 ` [RFC PATCH v2 04/25] KVM: x86/mmu: Support specifying a minimum TLB tag Yosry Ahmed
2026-07-23 0:28 ` Sean Christopherson
2026-07-23 5:00 ` Yosry Ahmed
2026-07-23 14:15 ` Sean Christopherson
2026-06-16 0:41 ` [RFC PATCH v2 05/25] KVM: SVM: Add helpers to set/clear ASID flush in VMCB Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 06/25] KVM: SVM: Fallback to flush everything if FLUSHBYASID is not available Yosry Ahmed
2026-07-23 0:29 ` Sean Christopherson
2026-06-16 0:41 ` [RFC PATCH v2 07/25] KVM: SVM: Duplicate pre-run ASID check for SEV and non-SEV guests Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 08/25] KVM: SEV: Stop using per-vCPU ASID for SEV VMs Yosry Ahmed
2026-06-16 1:06 ` sashiko-bot
2026-06-16 17:50 ` Yosry Ahmed
2026-07-07 21:30 ` Yosry Ahmed
2026-07-23 0:33 ` Sean Christopherson
2026-07-23 5:02 ` Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 09/25] KVM: SVM: Use a static ASID per vCPU Yosry Ahmed
2026-06-16 1:08 ` sashiko-bot
2026-06-16 17:58 ` Yosry Ahmed
2026-07-07 21:28 ` Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 10/25] KVM: nSVM: Add a placeholder ASID for L2 Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 11/25] KVM: x86: hyper-v: Rename kvm_hv_vcpu_purge_flush_tlb() Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 12/25] KVM: x86: hyper-v: Allow puring all TLB flush FIFOs Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 13/25] KVM: nSVM: Flush both L1 and L2 ASIDs on KVM_REQ_TLB_FLUSH Yosry Ahmed
2026-06-16 1:05 ` sashiko-bot
2026-06-16 18:00 ` Yosry Ahmed
2026-07-23 0:37 ` Sean Christopherson
2026-06-16 0:41 ` [RFC PATCH v2 14/25] KVM: nSVM: Move svm_switch_vmcb() to nested.c Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 15/25] KVM: nSVM: Call nested_svm_transition_tlb_flush() on every VMCB switch Yosry Ahmed
2026-07-23 0:42 ` Sean Christopherson
2026-07-23 5:07 ` Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 16/25] KVM: nSVM: Split nested_svm_transition_tlb_flush() into entry/exit fns Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 17/25] KVM: nSVM: Service local TLB flushes before nested transitions Yosry Ahmed
2026-06-16 1:20 ` sashiko-bot
2026-06-16 18:06 ` Yosry Ahmed
2026-06-17 0:21 ` Yosry Ahmed
2026-07-23 0:46 ` Sean Christopherson
2026-07-23 5:06 ` Yosry Ahmed
2026-07-23 13:34 ` Sean Christopherson
2026-07-24 22:27 ` Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 18/25] KVM: nSVM: Handle nested TLB flush requests through TLB_CONTROL Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 19/25] KVM: nSVM: Flush the TLB if L1 changes L2's ASID in vmcb12 Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 20/25] KVM: nSVM: Do not reset TLB_CONTROL in vmcb02 on nested VM-Enter Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 21/25] KVM: x86/mmu: rename __kvm_mmu_invalidate_addr() Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 22/25] KVM: x86/mmu: Refactor kvm_mmu_invlpg() to allow skipping the gva flush Yosry Ahmed
2026-07-23 0:53 ` Sean Christopherson
2026-07-23 0:56 ` Sean Christopherson
2026-07-23 5:11 ` Yosry Ahmed
2026-07-23 15:23 ` Sean Christopherson
2026-07-23 21:48 ` Yosry Ahmed
2026-07-23 22:03 ` Sean Christopherson
2026-07-23 22:10 ` Yosry Ahmed
2026-07-24 1:12 ` Sean Christopherson
2026-07-24 16:45 ` Yosry Ahmed
2026-07-27 15:38 ` Sean Christopherson
2026-07-27 15:46 ` Yosry Ahmed
2026-07-27 16:41 ` Sean Christopherson [this message]
2026-06-16 0:41 ` [RFC PATCH v2 23/25] KVM: nSVM: Flush L2's ASID when emulating INVLPGA Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 24/25] KVM: nSVM: Use different ASIDs for L1 and L2 Yosry Ahmed
2026-06-16 1:30 ` sashiko-bot
2026-06-16 18:14 ` Yosry Ahmed
2026-06-16 18:16 ` Yosry Ahmed
2026-06-16 18:28 ` Yosry Ahmed
2026-06-16 19:54 ` Jim Mattson
2026-06-16 19:56 ` Yosry Ahmed
2026-06-16 21:49 ` Yosry Ahmed
2026-06-16 0:41 ` [RFC PATCH v2 25/25] DO NOT MERGE: Add nested_tlb_force_flush Yosry Ahmed
2026-06-16 1:21 ` sashiko-bot
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ameKKF_XBAXFCTkR@google.com \
--to=seanjc@google.com \
--cc=jmattson@google.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mlevitsk@redhat.com \
--cc=pbonzini@redhat.com \
--cc=thomas.lendacky@amd.com \
--cc=vkuznets@redhat.com \
--cc=yosry@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.