All of lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH mptcp-next 0/3] mptcp: improve ADD_ADDR timeout handling
@ 2025-07-29  8:22 Geliang Tang
  2025-07-29  8:22 ` [PATCH mptcp-next 1/3] mptcp: rename add_addr_timeout to add_addr_timeout_max Geliang Tang
                   ` (4 more replies)
  0 siblings, 5 replies; 9+ messages in thread
From: Geliang Tang @ 2025-07-29  8:22 UTC (permalink / raw)
  To: mptcp; +Cc: Geliang Tang

From: Geliang Tang <tanggeliang@kylinos.cn>

This series optimizes MPTCP's ADD_ADDR retransmission timeout:

1. Renames sysctl to add_addr_timeout_max for clearer semantics
2. Makes timeout adaptive to subflow RTT
3. Updates selftests for the rename

The adaptive timeout improves subflow establishment responsiveness
while maintaining reliability through the max timeout cap. The rename
provides better configuration clarity.

Closes: https://github.com/multipath-tcp/mptcp_net-next/issues/576

Geliang Tang (3):
  mptcp: rename add_addr_timeout to add_addr_timeout_max
  mptcp: make ADD_ADDR timeout adaptive to subflow RTT
  selftests: mptcp: update for add_addr_timeout_max rename

 Documentation/networking/mptcp-sysctl.rst     |  6 ++---
 net/mptcp/ctrl.c                              | 12 ++++-----
 net/mptcp/pm.c                                | 27 ++++++++++++++++---
 net/mptcp/protocol.h                          |  2 +-
 .../testing/selftests/net/mptcp/mptcp_join.sh |  8 +++---
 5 files changed, 38 insertions(+), 17 deletions(-)

-- 
2.48.1


^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2025-07-30  9:26 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2025-07-29  8:22 [PATCH mptcp-next 0/3] mptcp: improve ADD_ADDR timeout handling Geliang Tang
2025-07-29  8:22 ` [PATCH mptcp-next 1/3] mptcp: rename add_addr_timeout to add_addr_timeout_max Geliang Tang
2025-07-30  9:22   ` Matthieu Baerts
2025-07-29  8:22 ` [PATCH mptcp-next 2/3] mptcp: make ADD_ADDR timeout adaptive to subflow RTT Geliang Tang
2025-07-30  9:26   ` Matthieu Baerts
2025-07-29  8:22 ` [PATCH mptcp-next 3/3] selftests: mptcp: update for add_addr_timeout_max rename Geliang Tang
2025-07-30  9:26   ` Matthieu Baerts
2025-07-29 10:24 ` [PATCH mptcp-next 0/3] mptcp: improve ADD_ADDR timeout handling MPTCP CI
2025-07-30  9:20 ` Matthieu Baerts

This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.