Alsa-Devel Archive on lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/6] ASoC: topology: Cleanup patches
@ 2022-04-01 12:01 Amadeusz Sławiński
  2022-04-01 12:01 ` [PATCH 1/6] ASoC: topology: Use for loop instead of while Amadeusz Sławiński
                   ` (8 more replies)
  0 siblings, 9 replies; 10+ messages in thread
From: Amadeusz Sławiński @ 2022-04-01 12:01 UTC (permalink / raw)
  To: Liam Girdwood, Mark Brown
  Cc: Pierre-Louis Bossart, Cezary Rojewski, alsa-devel, Takashi Iwai,
	Amadeusz Sławiński

Following patches contain minor changes, cleaning up code to be easier
to read.
Clean up few loops, to be simpler or altogether remove them.
Rename some things to make code easier to understand.

Amadeusz Sławiński (6):
  ASoC: topology: Use for loop instead of while
  ASoC: topology: Remove unnecessary looping
  ASoC: topology: Return bool instead of int
  ASoC: topology: Rename SOC_TPLG_PASS_MIXER to _CONTROL
  ASoC: topology: Correct error message
  ASoC: topology: Rename soc_tplg_init_kcontrol() function

 sound/soc/soc-topology.c | 455 ++++++++++++++++++---------------------
 1 file changed, 208 insertions(+), 247 deletions(-)

-- 
2.25.1


^ permalink raw reply	[flat|nested] 10+ messages in thread

end of thread, other threads:[~2022-04-05  9:35 UTC | newest]

Thread overview: 10+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2022-04-01 12:01 [PATCH 0/6] ASoC: topology: Cleanup patches Amadeusz Sławiński
2022-04-01 12:01 ` [PATCH 1/6] ASoC: topology: Use for loop instead of while Amadeusz Sławiński
2022-04-01 12:01 ` [PATCH 2/6] ASoC: topology: Remove unnecessary looping Amadeusz Sławiński
2022-04-01 12:01 ` [PATCH 3/6] ASoC: topology: Return bool instead of int Amadeusz Sławiński
2022-04-01 12:01 ` [PATCH 4/6] ASoC: topology: Rename SOC_TPLG_PASS_MIXER to _CONTROL Amadeusz Sławiński
2022-04-01 12:01 ` [PATCH 5/6] ASoC: topology: Correct error message Amadeusz Sławiński
2022-04-01 12:02 ` [PATCH 6/6] ASoC: topology: Rename soc_tplg_init_kcontrol() function Amadeusz Sławiński
2022-04-01 12:51 ` [PATCH 0/6] ASoC: topology: Cleanup patches Cezary Rojewski
2022-04-01 20:22 ` Ranjani Sridharan
2022-04-05  9:31 ` Mark Brown

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox