From: sashiko-bot@kernel.org
To: "SJ Park" <sj@kernel.org>
Cc: damon@lists.linux.dev
Subject: Re: [RFC PATCH 14/16] Docs/mm/damon/design: document attrs-only monitoring
Date: Sun, 05 Jul 2026 21:05:19 +0000 [thread overview]
Message-ID: <20260705210519.D99B51F000E9@smtp.kernel.org> (raw)
In-Reply-To: <20260705205743.98656-15-sj@kernel.org>
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Low] Spelling mistakes in the newly added documentation: 'deeecided' and 'mechaanism'.
--
commit 802f6df741c5d3bfcb1ed21eadbf33ebee4db496
Author: SJ Park <sj@kernel.org>
Docs/mm/damon/design: document attrs-only monitoring
This commit updates the DAMON design document to include a section
describing the data attributes-only monitoring mode.
> diff --git a/Documentation/mm/damon/design.rst b/Documentation/mm/damon/design.rst
> index 457d6e8bc7878..67398e2133036 100644
> --- a/Documentation/mm/damon/design.rst
> +++ b/Documentation/mm/damon/design.rst
[ ... ]
> @@ -316,6 +316,26 @@ Another way to do this for higher accuracy is using :ref:`DAMOS filter
> information in page level. But, because it is operated in page level, the
> overhead is proportional to the size of the memory.
>
> +Data Attributes-only Monitoring
> +~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> +
> +Data access is the primary monitoring information for DAMON. Hence it
> +:ref:`adjusts <damon_design_data_attrs_monitoring>` regions using the access
> +:ref:`counter <damon_design_region_based_sampling>` (``nr_accesses``). In some
> +use cases, however, users may want some of :ref:`attributes
> +<damon_design_data_attrs_monitoring>` to be the primary information.
> +
> +Data attributes-only monitoring mode supports this use case. For the mode,
> +each attribute probe has their priority weight value. Users can describe by
> +what combination of the attributes the primary information is deeecided, by
[Severity: Low]
This isn't a bug, but there is a typo here: "deeecided" should be "decided".
> +setting the priority weight value. If the total sum of the weights is not
> +zero, the mode is enabled. The regions adjustment mechaanism uses the weighted
[Severity: Low]
This isn't a bug, but there is another typo here: "mechaanism" should be
"mechanism".
> +sum of the :ref:`probe hit counts <damon_design_data_attrs_monitoring>` instead
> +of ``nr_accesses`` in the case. When the mode is enabled, access monitoring is
> +automatically turned off. The access counter (``nr_accesses``) will always be
> +zero and not updated. Hence the mode is called Data Attributes "only"
> +monitoring.
> +
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260705205743.98656-1-sj@kernel.org?part=14
next prev parent reply other threads:[~2026-07-05 21:05 UTC|newest]
Thread overview: 36+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-05 20:57 [RFC PATCH 00/16] mm/damon: introduce data attributes only monitoring SJ Park
2026-07-05 20:57 ` [RFC PATCH 01/16] mm/damon/core: introduce damon_probe->weight SJ Park
2026-07-05 21:04 ` sashiko-bot
2026-07-05 21:21 ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 02/16] mm/damon/core: ask apply_probes() ops callback to set sampling address SJ Park
2026-07-05 21:07 ` sashiko-bot
2026-07-05 21:25 ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 03/16] mm/damon/paddr: set samples in apply_probes() if requested SJ Park
2026-07-05 21:11 ` sashiko-bot
2026-07-05 21:28 ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 04/16] mm/damon/core: ask apply_probe() to return max probe hits weighted sum SJ Park
2026-07-05 20:57 ` [RFC PATCH 05/16] mm/damon/core: implement damon_probe_hits_wsum() SJ Park
2026-07-05 21:13 ` sashiko-bot
2026-07-05 21:30 ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 06/16] mm/damon/paddr: respect return_max_wsum SJ Park
2026-07-05 20:57 ` [RFC PATCH 07/16] mm/damon/core: extend merge function to work with probe hits SJ Park
2026-07-05 21:11 ` sashiko-bot
2026-07-05 21:38 ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 08/16] mm/damon/core: disable access monitoring when probe weights are set SJ Park
2026-07-05 21:19 ` sashiko-bot
2026-07-05 20:57 ` [RFC PATCH 09/16] mm/damon/core: set samples in apply_probes() if " SJ Park
2026-07-05 20:57 ` [RFC PATCH 10/16] mm/damon/core: s/max_nr_accesses/max_merge_score/ in kdamond_fn() SJ Park
2026-07-05 20:57 ` [RFC PATCH 11/16] mm/damon/core: get merge threshold from probe hits when weights are set SJ Park
2026-07-05 21:12 ` sashiko-bot
2026-07-05 21:41 ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 12/16] mm/damon/core: implement damon_has_probe_weight() SJ Park
2026-07-05 21:15 ` sashiko-bot
2026-07-05 21:45 ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 13/16] mm/damon/sysfs: implement probe/weight file SJ Park
2026-07-05 20:57 ` [RFC PATCH 14/16] Docs/mm/damon/design: document attrs-only monitoring SJ Park
2026-07-05 21:05 ` sashiko-bot [this message]
2026-07-05 21:46 ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 15/16] Docs/admin-guide/mm/damon/usage: document weight sysfs file SJ Park
2026-07-05 21:07 ` sashiko-bot
2026-07-05 21:48 ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 16/16] Docs/ABI/damon: document probe weight file SJ Park
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260705210519.D99B51F000E9@smtp.kernel.org \
--to=sashiko-bot@kernel.org \
--cc=damon@lists.linux.dev \
--cc=sashiko-reviews@lists.linux.dev \
--cc=sj@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox