DAMON development mailing list
 help / color / mirror / Atom feed
From: SJ Park <sj@kernel.org>
To: sashiko-bot@kernel.org
Cc: SJ Park <sj@kernel.org>, damon@lists.linux.dev
Subject: Re: [RFC PATCH 01/16] mm/damon/core: introduce damon_probe->weight
Date: Sun,  5 Jul 2026 14:21:33 -0700	[thread overview]
Message-ID: <20260705212135.100131-1-sj@kernel.org> (raw)
In-Reply-To: <20260705210454.34FC51F000E9@smtp.kernel.org>

On Sun, 05 Jul 2026 21:04:53 +0000 sashiko-bot@kernel.org wrote:

> Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
> - [Low] Missing kernel-doc description for the new `weight` field in `struct damon_probe`.
> --
> 
> commit 4be82423c8a2e9beb3264e298ab3af6bd580eea9
> Author: SJ Park <sj@kernel.org>
> 
> mm/damon/core: introduce damon_probe->weight
> 
> This commit adds a new weight field to the damon_probe structure. The field
> is used to specify the degree of the API caller's interest in the data
> attribute of the probe.
> 
> > diff --git a/include/linux/damon.h b/include/linux/damon.h
> > index 616bdf0954b52..257a4769296ab 100644
> > --- a/include/linux/damon.h
> > +++ b/include/linux/damon.h
> > @@ -763,6 +763,7 @@ struct damon_filter {
> >   * @list:	Siblings list.
> >   */
> >  struct damon_probe {
> > +	unsigned int weight;
> 
> [Severity: Low]
> Should the kernel-doc comment block above struct damon_probe be updated to
> include a description for the new weight field? Without it, running
> scripts/kernel-doc might emit a warning about the undocumented field.

Good catch.  I will add the comment on the next revision.

> 
> >  	struct list_head filters;
> >  	struct list_head list;
> >  };
> 
> -- 
> Sashiko AI review · https://sashiko.dev/#/patchset/20260705205743.98656-1-sj@kernel.org?part=1


Thanks,
SJ

  reply	other threads:[~2026-07-05 21:21 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-05 20:57 [RFC PATCH 00/16] mm/damon: introduce data attributes only monitoring SJ Park
2026-07-05 20:57 ` [RFC PATCH 01/16] mm/damon/core: introduce damon_probe->weight SJ Park
2026-07-05 21:04   ` sashiko-bot
2026-07-05 21:21     ` SJ Park [this message]
2026-07-05 20:57 ` [RFC PATCH 02/16] mm/damon/core: ask apply_probes() ops callback to set sampling address SJ Park
2026-07-05 21:07   ` sashiko-bot
2026-07-05 21:25     ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 03/16] mm/damon/paddr: set samples in apply_probes() if requested SJ Park
2026-07-05 21:11   ` sashiko-bot
2026-07-05 21:28     ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 04/16] mm/damon/core: ask apply_probe() to return max probe hits weighted sum SJ Park
2026-07-05 20:57 ` [RFC PATCH 05/16] mm/damon/core: implement damon_probe_hits_wsum() SJ Park
2026-07-05 21:13   ` sashiko-bot
2026-07-05 21:30     ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 06/16] mm/damon/paddr: respect return_max_wsum SJ Park
2026-07-05 20:57 ` [RFC PATCH 07/16] mm/damon/core: extend merge function to work with probe hits SJ Park
2026-07-05 21:11   ` sashiko-bot
2026-07-05 21:38     ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 08/16] mm/damon/core: disable access monitoring when probe weights are set SJ Park
2026-07-05 21:19   ` sashiko-bot
2026-07-05 20:57 ` [RFC PATCH 09/16] mm/damon/core: set samples in apply_probes() if " SJ Park
2026-07-05 20:57 ` [RFC PATCH 10/16] mm/damon/core: s/max_nr_accesses/max_merge_score/ in kdamond_fn() SJ Park
2026-07-05 20:57 ` [RFC PATCH 11/16] mm/damon/core: get merge threshold from probe hits when weights are set SJ Park
2026-07-05 21:12   ` sashiko-bot
2026-07-05 21:41     ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 12/16] mm/damon/core: implement damon_has_probe_weight() SJ Park
2026-07-05 21:15   ` sashiko-bot
2026-07-05 21:45     ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 13/16] mm/damon/sysfs: implement probe/weight file SJ Park
2026-07-05 20:57 ` [RFC PATCH 14/16] Docs/mm/damon/design: document attrs-only monitoring SJ Park
2026-07-05 21:05   ` sashiko-bot
2026-07-05 21:46     ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 15/16] Docs/admin-guide/mm/damon/usage: document weight sysfs file SJ Park
2026-07-05 21:07   ` sashiko-bot
2026-07-05 21:48     ` SJ Park
2026-07-05 20:57 ` [RFC PATCH 16/16] Docs/ABI/damon: document probe weight file SJ Park

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20260705212135.100131-1-sj@kernel.org \
    --to=sj@kernel.org \
    --cc=damon@lists.linux.dev \
    --cc=sashiko-bot@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox