From: Hyungwon Hwang <human.hwang@samsung.com>
To: dri-devel@lists.freedesktop.org, devicetree@vger.kernel.org,
inki.dae@samsung.com, daniel@fooishbar.org
Cc: dh09.lee@samsung.com, sw0312.kim@samsung.com,
Hyungwon Hwang <human.hwang@samsung.com>,
cw00.choi@samsung.com
Subject: [PATCH v5 00/12] Add drivers for Exynos5433 display
Date: Fri, 10 Apr 2015 14:55:18 +0900 [thread overview]
Message-ID: <1428645330-1043-1-git-send-email-human.hwang@samsung.com> (raw)
This patchset is based on the git(branch name: exynos-drm-next) which is
maintained by Inki Dae.
https://kernel.googlesource.com/pub/scm/linux/kernel/git/...
This patchset adds 2 new device drivers, decon and mic, and adds support for
Exynos5433 mipi dsi. To enable display in a Exynos5433 board, decon(display
controller), MIC(Mobile image compressor), mipi dsi, and panel have to be turned
on. This patchset contains support for 3 drivers for SoC level devices.
Changes for v2:
- change config, file, and variable names of decon to represnt exynos5433
instead of exynos to distinguish them from exynos7 decon
- change the initialization order of decon to make it initialized in order like
FIMD or exynos7 decon
- make mic driver to be registered by exynos drm driver instead as a module
driver
- change the description of mic driver in documentation
- add module author at the top of the source file removing MODULE_OWNER,
MODULE_DESCRIPTION, MODULE_LICENSE
- change the author of "drm/exynos: dsi: add support for Exynos5433 SoC" to
Hyungwon Hwang by the previous author's will
Changes for v3:
< Decon >
- fail fast when the proper image format is not set
- remove unnecessary checking code
- add and modify the function to make DPMS work well
< MIC >
- move if statement out of function, so that the function is not called
unnecessarily
- Make it use syscon framework for controlling system register
< DSI >
- separate the previous one patch to three
- renaming patch: rename pll clock to sclk clock
- generalizing patch: generalize the way to getting address and values
- Exynos5433 patch: adds support for Exynos5433 dsi
- use defines for more readable code
- fix typos
Changes for v4:
- rebased to exynos-drm-next with the clean-up patchset by Gustavo Padovan.
Changes for v5:
- separated the refactoring patch of MIPI DSI driver into 3 patches
- added the patch to make DSI driver compatiable with the old clock name
- added the patch to rename the DSI driver's clock
- rename the newly added dsi variables for clarity
Hyungwon Hwang (11):
of: add helper for getting endpoint node of specific identifiers
drm/exynos: mic: add MIC driver
drm/exynos: dsi: rename pll_clk to sclk_clk
drm/exynos: dsi: add macros for register access
drm/exynos: dsi: make use of driver data for static values
drm/exynos: dsi: make use of array for clock access
drm/exynos: dsi: add support for Exynos5433
drm/exynos: dsi: add the backward compatibility for the renamed clock
drm/exynos: dsi: add support for MIC driver as a bridge
drm/exynos: dsi: do not set TE GPIO direction by input
ARM: dts: rename the clock of MIPI DSI 'pll_clk' to 'sclk_mipi'
Joonyoung Shim (1):
drm/exynos: add Exynos5433 decon driver
.../devicetree/bindings/video/exynos-mic.txt | 51 ++
.../devicetree/bindings/video/exynos5433-decon.txt | 65 +++
.../devicetree/bindings/video/exynos_dsim.txt | 31 +-
arch/arm/boot/dts/exynos4.dtsi | 2 +-
drivers/gpu/drm/exynos/Kconfig | 14 +-
drivers/gpu/drm/exynos/Makefile | 2 +
drivers/gpu/drm/exynos/exynos5433_drm_decon.c | 617 +++++++++++++++++++++
drivers/gpu/drm/exynos/exynos_drm_drv.c | 6 +
drivers/gpu/drm/exynos/exynos_drm_drv.h | 2 +
drivers/gpu/drm/exynos/exynos_drm_dsi.c | 464 +++++++++++-----
drivers/gpu/drm/exynos/exynos_drm_mic.c | 490 ++++++++++++++++
drivers/of/base.c | 33 ++
include/linux/of_graph.h | 8 +
include/video/exynos5433_decon.h | 163 ++++++
14 files changed, 1797 insertions(+), 151 deletions(-)
create mode 100644 Documentation/devicetree/bindings/video/exynos-mic.txt
create mode 100644 Documentation/devicetree/bindings/video/exynos5433-decon.txt
create mode 100644 drivers/gpu/drm/exynos/exynos5433_drm_decon.c
create mode 100644 drivers/gpu/drm/exynos/exynos_drm_mic.c
create mode 100644 include/video/exynos5433_decon.h
--
1.9.1
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel
next reply other threads:[~2015-04-10 5:55 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-04-10 5:55 Hyungwon Hwang [this message]
[not found] ` <1428645330-1043-1-git-send-email-human.hwang-Sze3O3UU22JBDgjK7y7TUQ@public.gmane.org>
2015-04-10 5:55 ` [PATCH v5 01/12] drm/exynos: add Exynos5433 decon driver Hyungwon Hwang
[not found] ` <1428645330-1043-2-git-send-email-human.hwang-Sze3O3UU22JBDgjK7y7TUQ@public.gmane.org>
2015-04-10 6:05 ` Varka Bhadram
2015-04-10 6:38 ` Hyungwon Hwang
2015-04-10 5:55 ` [PATCH v5 02/12] of: add helper for getting endpoint node of specific identifiers Hyungwon Hwang
2015-04-10 5:55 ` [PATCH v5 10/12] drm/exynos: dsi: add support for MIC driver as a bridge Hyungwon Hwang
2015-04-10 5:55 ` [PATCH v5 03/12] drm/exynos: mic: add MIC driver Hyungwon Hwang
2015-04-10 5:55 ` [PATCH v5 04/12] drm/exynos: dsi: rename pll_clk to sclk_clk Hyungwon Hwang
2015-04-15 1:24 ` Inki Dae
2015-04-10 5:55 ` [PATCH v5 05/12] drm/exynos: dsi: add macros for register access Hyungwon Hwang
2015-04-10 5:55 ` [PATCH v5 06/12] drm/exynos: dsi: make use of driver data for static values Hyungwon Hwang
2015-04-10 5:55 ` [PATCH v5 07/12] drm/exynos: dsi: make use of array for clock access Hyungwon Hwang
2015-04-10 5:55 ` [PATCH v5 08/12] drm/exynos: dsi: add support for Exynos5433 Hyungwon Hwang
2015-04-10 5:55 ` [PATCH v5 09/12] drm/exynos: dsi: add the backward compatibility for the renamed clock Hyungwon Hwang
2015-04-10 5:55 ` [PATCH v5 11/12] drm/exynos: dsi: do not set TE GPIO direction by input Hyungwon Hwang
2015-04-10 5:55 ` [PATCH v5 12/12] ARM: dts: rename the clock of MIPI DSI 'pll_clk' to 'sclk_mipi' Hyungwon Hwang
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1428645330-1043-1-git-send-email-human.hwang@samsung.com \
--to=human.hwang@samsung.com \
--cc=cw00.choi@samsung.com \
--cc=daniel@fooishbar.org \
--cc=devicetree@vger.kernel.org \
--cc=dh09.lee@samsung.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=inki.dae@samsung.com \
--cc=sw0312.kim@samsung.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox