From: "Souza, Jose" <jose.souza@intel.com>
To: "intel-gfx@lists.freedesktop.org" <intel-gfx@lists.freedesktop.org>
Cc: "Nikula, Jani" <jani.nikula@intel.com>
Subject: Re: [PATCH 1/4] drm/i915: Move drm_vblank_init() to i915_load_modeset_init()
Date: Fri, 9 Nov 2018 01:53:41 +0000 [thread overview]
Message-ID: <080ae0de6345c36223ceb5d85c788e58e4c85f9a.camel@intel.com> (raw)
In-Reply-To: <20181108153305.GY9144@intel.com>
[-- Attachment #1.1: Type: text/plain, Size: 2115 bytes --]
On Thu, 2018-11-08 at 17:33 +0200, Ville Syrjälä wrote:
> On Wed, Nov 07, 2018 at 04:16:44PM -0800, José Roberto de Souza
> wrote:
> > i915_load_modeset_init() is a more suitable place than
> > i915_driver_load() as vblank is part of modeset.
> >
> > Cc: Jani Nikula <jani.nikula@intel.com>
> > Cc: Ville Syrjälä <ville.syrjala@linux.intel.com>
> > Signed-off-by: José Roberto de Souza <jose.souza@intel.com>
>
> Reviewed-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
Thanks for the reviews, patches pushed to drm-intel-next-queued
>
> > ---
> > drivers/gpu/drm/i915/i915_drv.c | 19 +++++++------------
> > 1 file changed, 7 insertions(+), 12 deletions(-)
> >
> > diff --git a/drivers/gpu/drm/i915/i915_drv.c
> > b/drivers/gpu/drm/i915/i915_drv.c
> > index acb516308262..b9108a5821a5 100644
> > --- a/drivers/gpu/drm/i915/i915_drv.c
> > +++ b/drivers/gpu/drm/i915/i915_drv.c
> > @@ -645,6 +645,13 @@ static int i915_load_modeset_init(struct
> > drm_device *dev)
> > if (i915_inject_load_failure())
> > return -ENODEV;
> >
> > + if (INTEL_INFO(dev_priv)->num_pipes) {
> > + ret = drm_vblank_init(&dev_priv->drm,
> > + INTEL_INFO(dev_priv)->num_pipes);
> > + if (ret)
> > + goto out;
> > + }
> > +
> > intel_bios_init(dev_priv);
> >
> > /* If we have > 1 VGA cards, then we need to arbitrate access
> > @@ -1712,18 +1719,6 @@ int i915_driver_load(struct pci_dev *pdev,
> > const struct pci_device_id *ent)
> > if (ret < 0)
> > goto out_cleanup_mmio;
> >
> > - /*
> > - * TODO: move the vblank init and parts of modeset init steps
> > into one
> > - * of the i915_driver_init_/i915_driver_register functions
> > according
> > - * to the role/effect of the given init step.
> > - */
> > - if (INTEL_INFO(dev_priv)->num_pipes) {
> > - ret = drm_vblank_init(&dev_priv->drm,
> > - INTEL_INFO(dev_priv)->num_pipes);
> > - if (ret)
> > - goto out_cleanup_hw;
> > - }
> > -
> > ret = i915_load_modeset_init(&dev_priv->drm);
> > if (ret < 0)
> > goto out_cleanup_hw;
> > --
> > 2.19.1
[-- Attachment #1.2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 488 bytes --]
[-- Attachment #2: Type: text/plain, Size: 160 bytes --]
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
prev parent reply other threads:[~2018-11-09 1:53 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-11-08 0:16 [PATCH 1/4] drm/i915: Move drm_vblank_init() to i915_load_modeset_init() José Roberto de Souza
2018-11-08 0:16 ` [PATCH 2/4] drm/i915: Move FBC init and cleanup calls to modeset functions José Roberto de Souza
2018-11-08 15:29 ` Ville Syrjälä
2018-11-08 0:16 ` [PATCH 3/4] drm/i915: Move intel_init_ipc() call to i915_load_modeset_init() José Roberto de Souza
2018-11-08 15:31 ` Ville Syrjälä
2018-11-08 0:16 ` [PATCH 4/4] drm/i915: Keep overlay functions naming consistent José Roberto de Souza
2018-11-08 15:31 ` Ville Syrjälä
2018-11-08 1:33 ` ✓ Fi.CI.BAT: success for series starting with [1/4] drm/i915: Move drm_vblank_init() to i915_load_modeset_init() Patchwork
2018-11-08 14:54 ` ✓ Fi.CI.IGT: " Patchwork
2018-11-08 15:33 ` [PATCH 1/4] " Ville Syrjälä
2018-11-09 1:53 ` Souza, Jose [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=080ae0de6345c36223ceb5d85c788e58e4c85f9a.camel@intel.com \
--to=jose.souza@intel.com \
--cc=intel-gfx@lists.freedesktop.org \
--cc=jani.nikula@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox