From: "Ville Syrjälä" <ville.syrjala@linux.intel.com>
To: "José Roberto de Souza" <jose.souza@intel.com>
Cc: Jani Nikula <jani.nikula@intel.com>, intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 4/4] drm/i915: Keep overlay functions naming consistent
Date: Thu, 8 Nov 2018 17:31:56 +0200 [thread overview]
Message-ID: <20181108153156.GX9144@intel.com> (raw)
In-Reply-To: <20181108001647.11276-4-jose.souza@intel.com>
On Wed, Nov 07, 2018 at 04:16:47PM -0800, José Roberto de Souza wrote:
> All other overlay functions(almost all other functions in i915)
> follow intel_overlay_verb, so renaming overlay ones that do not match
> that.
>
> Cc: Jani Nikula <jani.nikula@intel.com>
> Cc: Ville Syrjälä <ville.syrjala@linux.intel.com>
> Signed-off-by: José Roberto de Souza <jose.souza@intel.com>
Reviewed-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
> ---
> drivers/gpu/drm/i915/i915_drv.c | 2 +-
> drivers/gpu/drm/i915/intel_display.c | 2 +-
> drivers/gpu/drm/i915/intel_drv.h | 4 ++--
> drivers/gpu/drm/i915/intel_overlay.c | 4 ++--
> 4 files changed, 6 insertions(+), 6 deletions(-)
>
> diff --git a/drivers/gpu/drm/i915/i915_drv.c b/drivers/gpu/drm/i915/i915_drv.c
> index 44903ce1b82d..b1d23c73c147 100644
> --- a/drivers/gpu/drm/i915/i915_drv.c
> +++ b/drivers/gpu/drm/i915/i915_drv.c
> @@ -694,7 +694,7 @@ static int i915_load_modeset_init(struct drm_device *dev)
> if (ret)
> goto cleanup_modeset;
>
> - intel_setup_overlay(dev_priv);
> + intel_overlay_setup(dev_priv);
>
> if (INTEL_INFO(dev_priv)->num_pipes == 0)
> return 0;
> diff --git a/drivers/gpu/drm/i915/intel_display.c b/drivers/gpu/drm/i915/intel_display.c
> index 4c176e13e9bb..05125c7c2aa1 100644
> --- a/drivers/gpu/drm/i915/intel_display.c
> +++ b/drivers/gpu/drm/i915/intel_display.c
> @@ -15826,7 +15826,7 @@ void intel_modeset_cleanup(struct drm_device *dev)
>
> drm_mode_config_cleanup(dev);
>
> - intel_cleanup_overlay(dev_priv);
> + intel_overlay_cleanup(dev_priv);
>
> intel_teardown_gmbus(dev_priv);
>
> diff --git a/drivers/gpu/drm/i915/intel_drv.h b/drivers/gpu/drm/i915/intel_drv.h
> index 6772e9974751..21819a9bdcae 100644
> --- a/drivers/gpu/drm/i915/intel_drv.h
> +++ b/drivers/gpu/drm/i915/intel_drv.h
> @@ -1962,8 +1962,8 @@ struct intel_encoder *intel_get_lvds_encoder(struct drm_device *dev);
> bool intel_is_dual_link_lvds(struct drm_device *dev);
>
> /* intel_overlay.c */
> -void intel_setup_overlay(struct drm_i915_private *dev_priv);
> -void intel_cleanup_overlay(struct drm_i915_private *dev_priv);
> +void intel_overlay_setup(struct drm_i915_private *dev_priv);
> +void intel_overlay_cleanup(struct drm_i915_private *dev_priv);
> int intel_overlay_switch_off(struct intel_overlay *overlay);
> int intel_overlay_put_image_ioctl(struct drm_device *dev, void *data,
> struct drm_file *file_priv);
> diff --git a/drivers/gpu/drm/i915/intel_overlay.c b/drivers/gpu/drm/i915/intel_overlay.c
> index 72eb7e48e8bc..20ea7c99d13a 100644
> --- a/drivers/gpu/drm/i915/intel_overlay.c
> +++ b/drivers/gpu/drm/i915/intel_overlay.c
> @@ -1338,7 +1338,7 @@ static int get_registers(struct intel_overlay *overlay, bool use_phys)
> return err;
> }
>
> -void intel_setup_overlay(struct drm_i915_private *dev_priv)
> +void intel_overlay_setup(struct drm_i915_private *dev_priv)
> {
> struct intel_overlay *overlay;
> int ret;
> @@ -1387,7 +1387,7 @@ void intel_setup_overlay(struct drm_i915_private *dev_priv)
> kfree(overlay);
> }
>
> -void intel_cleanup_overlay(struct drm_i915_private *dev_priv)
> +void intel_overlay_cleanup(struct drm_i915_private *dev_priv)
> {
> struct intel_overlay *overlay;
>
> --
> 2.19.1
--
Ville Syrjälä
Intel
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
next prev parent reply other threads:[~2018-11-08 15:32 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2018-11-08 0:16 [PATCH 1/4] drm/i915: Move drm_vblank_init() to i915_load_modeset_init() José Roberto de Souza
2018-11-08 0:16 ` [PATCH 2/4] drm/i915: Move FBC init and cleanup calls to modeset functions José Roberto de Souza
2018-11-08 15:29 ` Ville Syrjälä
2018-11-08 0:16 ` [PATCH 3/4] drm/i915: Move intel_init_ipc() call to i915_load_modeset_init() José Roberto de Souza
2018-11-08 15:31 ` Ville Syrjälä
2018-11-08 0:16 ` [PATCH 4/4] drm/i915: Keep overlay functions naming consistent José Roberto de Souza
2018-11-08 15:31 ` Ville Syrjälä [this message]
2018-11-08 1:33 ` ✓ Fi.CI.BAT: success for series starting with [1/4] drm/i915: Move drm_vblank_init() to i915_load_modeset_init() Patchwork
2018-11-08 14:54 ` ✓ Fi.CI.IGT: " Patchwork
2018-11-08 15:33 ` [PATCH 1/4] " Ville Syrjälä
2018-11-09 1:53 ` Souza, Jose
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20181108153156.GX9144@intel.com \
--to=ville.syrjala@linux.intel.com \
--cc=intel-gfx@lists.freedesktop.org \
--cc=jani.nikula@intel.com \
--cc=jose.souza@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox