Intel-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
From: Daniel Vetter <daniel@ffwll.ch>
To: Paulo Zanoni <przanoni@gmail.com>
Cc: Daniel Vetter <daniel.vetter@ffwll.ch>,
	Intel Graphics Development <intel-gfx@lists.freedesktop.org>
Subject: Re: [PATCH 4/5] drm/i915: Apply OCD to data/link m/n register #defines
Date: Fri, 3 May 2013 11:15:08 +0200	[thread overview]
Message-ID: <20130503091508.GJ5763@phenom.ffwll.local> (raw)
In-Reply-To: <CA+gsUGThJDeza+oCZY5qoU32m2nuCF5+DtxrqaoXCgNAB1xM+g@mail.gmail.com>

On Thu, May 02, 2013 at 05:36:33PM -0300, Paulo Zanoni wrote:
> Hi
> 
> 2013/5/1 Daniel Vetter <daniel.vetter@ffwll.ch>:
> > - PCH_ prefix for pch registers on ibx/cpt/ppt.
> > - Drop the DP_ from the link defines, redundant.
> > - Drop the GMCH from the data defines and instead give the special g4x
> >   registers a consistent _G4X postfix.
> >
> > Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
> 
> Yay, the new naming is way better. Thanks!
> 
> So since this is about OCD, I'll give my optional OCD bikesheds:
> - Now the register addresses are not aligned on i915_reg.h anymore. I
> suggest we align them again. We should also consider replacing all
> those white spaces with tabs.

Done.

> - We should have renamed the suspend/resume regfile registers too.
> They're getting confusing now.

Imo i915_ums.c is a dungeon and I don't want to change anything in there
if at all possible. Hence why I've kept the old names.

> - We go over 80 columns in some new cases now. Do we have a policy on
> when it's accepted on our driver?

I don't mind too much if something in the dungeons (i915_ums.c and
i915_dma.c overflows). Same for reg defines, since usually you don't
really read them that often. Real code in source files shouldn't overflow
for easier reading (with some exceptions for strings).

> - Reviewed-by: Paulo Zanoni <paulo.r.zanoni@intel.com> but I'd love to
> see my bikesheds on v2 :)

On it's way ;-)
-Daniel
-- 
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch

  reply	other threads:[~2013-05-03  9:12 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2013-05-01 16:03 [PATCH 1/5] drm/i915: s/TRANSCONF/PCH_TRANSCONF/ Daniel Vetter
2013-05-01 16:03 ` [PATCH 2/5] drm/i915: PCH_ prefix for transcoder timings Daniel Vetter
2013-05-02 18:39   ` Paulo Zanoni
2013-05-01 16:03 ` [PATCH 3/5] drm/i915: make set_m_n functions static Daniel Vetter
2013-05-02 18:45   ` Paulo Zanoni
2013-05-01 16:03 ` [PATCH 4/5] drm/i915: Apply OCD to data/link m/n register #defines Daniel Vetter
2013-05-02 20:36   ` Paulo Zanoni
2013-05-03  9:15     ` Daniel Vetter [this message]
2013-05-01 16:03 ` [PATCH 5/5] drm/i915: make intel_cpt_verify_modeset static Daniel Vetter
2013-05-02 20:40   ` Paulo Zanoni
2013-05-02 18:12 ` [PATCH 1/5] drm/i915: s/TRANSCONF/PCH_TRANSCONF/ Paulo Zanoni
2013-05-03  9:19   ` Daniel Vetter
2013-05-03  9:49     ` [PATCH 1/6] " Daniel Vetter
2013-05-03  9:49       ` [PATCH 2/6] drm/i915: PCH_ prefix for transcoder timings Daniel Vetter
2013-05-03 14:16         ` Paulo Zanoni
2013-05-06  9:29           ` Daniel Vetter
2013-05-03  9:49       ` [PATCH 3/6] drm/i915: make set_m_n functions static Daniel Vetter
2013-05-03  9:49       ` [PATCH 4/6] drm/i915: Apply OCD to data/link m/n register #defines Daniel Vetter
2013-05-03  9:49       ` [PATCH 5/6] drm/i915: make intel_cpt_verify_modeset static Daniel Vetter
2013-05-03  9:49       ` [PATCH 6/6] drm/i915: fix up adjusted_mode tracking for interlaced modes Daniel Vetter
2013-05-03 11:24         ` Daniel Vetter
2013-05-03 14:31           ` Paulo Zanoni
2013-05-06  9:24             ` Daniel Vetter

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20130503091508.GJ5763@phenom.ffwll.local \
    --to=daniel@ffwll.ch \
    --cc=daniel.vetter@ffwll.ch \
    --cc=intel-gfx@lists.freedesktop.org \
    --cc=przanoni@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox