Intel-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH 0/3] drm: kernel-doc fixes
@ 2013-05-08 13:38 ville.syrjala
  2013-05-08 13:38 ` [PATCH 1/3] drm: Add kernel-doc for drm_fb_helper_funcs->initial_config ville.syrjala
                   ` (2 more replies)
  0 siblings, 3 replies; 8+ messages in thread
From: ville.syrjala @ 2013-05-08 13:38 UTC (permalink / raw)
  To: dri-devel; +Cc: intel-gfx, Laurent Pinchart

Just a few misc. kernel-doc fixes I spotted while looking into the
subject matter.

^ permalink raw reply	[flat|nested] 8+ messages in thread

* [PATCH 1/3] drm: Add kernel-doc for drm_fb_helper_funcs->initial_config
  2013-05-08 13:38 [PATCH 0/3] drm: kernel-doc fixes ville.syrjala
@ 2013-05-08 13:38 ` ville.syrjala
  2013-05-08 13:38 ` [PATCH 2/3] drm: Remove pointless '-' characters from drm_fb_helper documentation ville.syrjala
  2013-05-08 13:38 ` [PATCH 3/3] drm: Fix drm_rect documentation ville.syrjala
  2 siblings, 0 replies; 8+ messages in thread
From: ville.syrjala @ 2013-05-08 13:38 UTC (permalink / raw)
  To: dri-devel; +Cc: intel-gfx, Laurent Pinchart

From: Ville Syrjälä <ville.syrjala@linux.intel.com>

Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
---
 include/drm/drm_fb_helper.h | 1 +
 1 file changed, 1 insertion(+)

diff --git a/include/drm/drm_fb_helper.h b/include/drm/drm_fb_helper.h
index 8230b46..61ebd51 100644
--- a/include/drm/drm_fb_helper.h
+++ b/include/drm/drm_fb_helper.h
@@ -57,6 +57,7 @@ struct drm_fb_helper_surface_size {
  * @fb_probe: - Driver callback to allocate and initialize the fbdev info
  * 		structure. Futhermore it also needs to allocate the drm
  * 		framebuffer used to back the fbdev.
+ * @initial_config: - Setup an initial fbdev display configuration
  *
  * Driver callbacks used by the fbdev emulation helper library.
  */
-- 
1.8.1.5

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel

^ permalink raw reply related	[flat|nested] 8+ messages in thread

* [PATCH 2/3] drm: Remove pointless '-' characters from drm_fb_helper documentation
  2013-05-08 13:38 [PATCH 0/3] drm: kernel-doc fixes ville.syrjala
  2013-05-08 13:38 ` [PATCH 1/3] drm: Add kernel-doc for drm_fb_helper_funcs->initial_config ville.syrjala
@ 2013-05-08 13:38 ` ville.syrjala
  2013-05-08 13:38 ` [PATCH 3/3] drm: Fix drm_rect documentation ville.syrjala
  2 siblings, 0 replies; 8+ messages in thread
From: ville.syrjala @ 2013-05-08 13:38 UTC (permalink / raw)
  To: dri-devel; +Cc: intel-gfx, Laurent Pinchart

From: Ville Syrjälä <ville.syrjala@linux.intel.com>

Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
---
 include/drm/drm_fb_helper.h | 16 ++++++++--------
 1 file changed, 8 insertions(+), 8 deletions(-)

diff --git a/include/drm/drm_fb_helper.h b/include/drm/drm_fb_helper.h
index 61ebd51..471f276 100644
--- a/include/drm/drm_fb_helper.h
+++ b/include/drm/drm_fb_helper.h
@@ -50,14 +50,14 @@ struct drm_fb_helper_surface_size {
 
 /**
  * struct drm_fb_helper_funcs - driver callbacks for the fbdev emulation library
- * @gamma_set: - Set the given gamma lut register on the given crtc.
- * @gamma_get: - Read the given gamma lut register on the given crtc, used to
- * 		 save the current lut when force-restoring the fbdev for e.g.
- * 		 kdbg.
- * @fb_probe: - Driver callback to allocate and initialize the fbdev info
- * 		structure. Futhermore it also needs to allocate the drm
- * 		framebuffer used to back the fbdev.
- * @initial_config: - Setup an initial fbdev display configuration
+ * @gamma_set: Set the given gamma lut register on the given crtc.
+ * @gamma_get: Read the given gamma lut register on the given crtc, used to
+ *             save the current lut when force-restoring the fbdev for e.g.
+ *             kdbg.
+ * @fb_probe: Driver callback to allocate and initialize the fbdev info
+ *            structure. Futhermore it also needs to allocate the drm
+ *            framebuffer used to back the fbdev.
+ * @initial_config: Setup an initial fbdev display configuration
  *
  * Driver callbacks used by the fbdev emulation helper library.
  */
-- 
1.8.1.5

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply related	[flat|nested] 8+ messages in thread

* [PATCH 3/3] drm: Fix drm_rect documentation
  2013-05-08 13:38 [PATCH 0/3] drm: kernel-doc fixes ville.syrjala
  2013-05-08 13:38 ` [PATCH 1/3] drm: Add kernel-doc for drm_fb_helper_funcs->initial_config ville.syrjala
  2013-05-08 13:38 ` [PATCH 2/3] drm: Remove pointless '-' characters from drm_fb_helper documentation ville.syrjala
@ 2013-05-08 13:38 ` ville.syrjala
  2013-05-08 13:55   ` [Intel-gfx] " Daniel Vetter
  2 siblings, 1 reply; 8+ messages in thread
From: ville.syrjala @ 2013-05-08 13:38 UTC (permalink / raw)
  To: dri-devel; +Cc: intel-gfx, Laurent Pinchart

From: Ville Syrjälä <ville.syrjala@linux.intel.com>

The 'struct' keyword was missing so struct drm_rect documentation never
ended up in the generated docs.

Also reorder drm_rect.h to become before drm_rect.c so that the struct
documentation appears first in the docs. And change it to use the 'I'
directive instead of 'F' while we're at it.

Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
---
 Documentation/DocBook/drm.tmpl | 2 +-
 include/drm/drm_rect.h         | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/Documentation/DocBook/drm.tmpl b/Documentation/DocBook/drm.tmpl
index 7c7af25..89b6faa 100644
--- a/Documentation/DocBook/drm.tmpl
+++ b/Documentation/DocBook/drm.tmpl
@@ -1653,8 +1653,8 @@ void intel_crt_init(struct drm_device *dev)
     <sect2>
       <title>KMS API Functions</title>
 !Edrivers/gpu/drm/drm_crtc.c
+!Iinclude/drm/drm_rect.h
 !Edrivers/gpu/drm/drm_rect.c
-!Finclude/drm/drm_rect.h
     </sect2>
   </sect1>
 
diff --git a/include/drm/drm_rect.h b/include/drm/drm_rect.h
index 64fa265..9a98321 100644
--- a/include/drm/drm_rect.h
+++ b/include/drm/drm_rect.h
@@ -25,7 +25,7 @@
 #define DRM_RECT_H
 
 /**
- * drm_rect - two dimensional rectangle
+ * struct drm_rect - two dimensional rectangle
  * @x1: horizontal starting coordinate (inclusive)
  * @x2: horizontal ending coordinate (exclusive)
  * @y1: vertical starting coordinate (inclusive)
-- 
1.8.1.5

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply related	[flat|nested] 8+ messages in thread

* Re: [Intel-gfx] [PATCH 3/3] drm: Fix drm_rect documentation
  2013-05-08 13:38 ` [PATCH 3/3] drm: Fix drm_rect documentation ville.syrjala
@ 2013-05-08 13:55   ` Daniel Vetter
  2013-05-08 14:16     ` [PATCH v2] " ville.syrjala
  0 siblings, 1 reply; 8+ messages in thread
From: Daniel Vetter @ 2013-05-08 13:55 UTC (permalink / raw)
  To: ville.syrjala; +Cc: intel-gfx, Laurent Pinchart, dri-devel

On Wed, May 08, 2013 at 04:38:35PM +0300, ville.syrjala@linux.intel.com wrote:
> From: Ville Syrjälä <ville.syrjala@linux.intel.com>
> 
> The 'struct' keyword was missing so struct drm_rect documentation never
> ended up in the generated docs.
> 
> Also reorder drm_rect.h to become before drm_rect.c so that the struct
> documentation appears first in the docs. And change it to use the 'I'
> directive instead of 'F' while we're at it.
> 
> Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
> ---
>  Documentation/DocBook/drm.tmpl | 2 +-
>  include/drm/drm_rect.h         | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/Documentation/DocBook/drm.tmpl b/Documentation/DocBook/drm.tmpl
> index 7c7af25..89b6faa 100644
> --- a/Documentation/DocBook/drm.tmpl
> +++ b/Documentation/DocBook/drm.tmpl
> @@ -1653,8 +1653,8 @@ void intel_crt_init(struct drm_device *dev)
>      <sect2>
>        <title>KMS API Functions</title>
>  !Edrivers/gpu/drm/drm_crtc.c
> +!Iinclude/drm/drm_rect.h
>  !Edrivers/gpu/drm/drm_rect.c
> -!Finclude/drm/drm_rect.h

Shameless bikeshed while at it: Can you move the drm_rect stuff to it's
own sections, like all the other kms helper stuff? Only the things in
drm_crtc.c are really core kms apis.
-Daniel

>      </sect2>
>    </sect1>
>  
> diff --git a/include/drm/drm_rect.h b/include/drm/drm_rect.h
> index 64fa265..9a98321 100644
> --- a/include/drm/drm_rect.h
> +++ b/include/drm/drm_rect.h
> @@ -25,7 +25,7 @@
>  #define DRM_RECT_H
>  
>  /**
> - * drm_rect - two dimensional rectangle
> + * struct drm_rect - two dimensional rectangle
>   * @x1: horizontal starting coordinate (inclusive)
>   * @x2: horizontal ending coordinate (exclusive)
>   * @y1: vertical starting coordinate (inclusive)
> -- 
> 1.8.1.5
> 
> _______________________________________________
> Intel-gfx mailing list
> Intel-gfx@lists.freedesktop.org
> http://lists.freedesktop.org/mailman/listinfo/intel-gfx

-- 
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch

^ permalink raw reply	[flat|nested] 8+ messages in thread

* [PATCH v2] drm: Fix drm_rect documentation
  2013-05-08 13:55   ` [Intel-gfx] " Daniel Vetter
@ 2013-05-08 14:16     ` ville.syrjala
  2013-05-08 14:42       ` Daniel Vetter
  2013-05-23 10:02       ` Daniel Vetter
  0 siblings, 2 replies; 8+ messages in thread
From: ville.syrjala @ 2013-05-08 14:16 UTC (permalink / raw)
  To: dri-devel; +Cc: intel-gfx, Laurent Pinchart

From: Ville Syrjälä <ville.syrjala@linux.intel.com>

The 'struct' keyword was missing so struct drm_rect documentation never
ended up in the generated docs.

Also move the drm_rect documentations to a new section alognside the
various helper functions and add a short description about the intended
purpose of drm_rect.

v2: Move to new section and add general description

Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
---
 Documentation/DocBook/drm.tmpl | 8 ++++++--
 include/drm/drm_rect.h         | 9 ++++++++-
 2 files changed, 14 insertions(+), 3 deletions(-)

diff --git a/Documentation/DocBook/drm.tmpl b/Documentation/DocBook/drm.tmpl
index 7c7af25..91ee107 100644
--- a/Documentation/DocBook/drm.tmpl
+++ b/Documentation/DocBook/drm.tmpl
@@ -1653,8 +1653,6 @@ void intel_crt_init(struct drm_device *dev)
     <sect2>
       <title>KMS API Functions</title>
 !Edrivers/gpu/drm/drm_crtc.c
-!Edrivers/gpu/drm/drm_rect.c
-!Finclude/drm/drm_rect.h
     </sect2>
   </sect1>
 
@@ -2163,6 +2161,12 @@ void intel_crt_init(struct drm_device *dev)
       <title>EDID Helper Functions Reference</title>
 !Edrivers/gpu/drm/drm_edid.c
     </sect2>
+    <sect2>
+      <title>Rectangle Utilities Reference</title>
+!Pinclude/drm/drm_rect.h rect utils
+!Iinclude/drm/drm_rect.h
+!Edrivers/gpu/drm/drm_rect.c
+    </sect2>
   </sect1>
 
   <!-- Internals: vertical blanking -->
diff --git a/include/drm/drm_rect.h b/include/drm/drm_rect.h
index 64fa265..d128629 100644
--- a/include/drm/drm_rect.h
+++ b/include/drm/drm_rect.h
@@ -25,7 +25,14 @@
 #define DRM_RECT_H
 
 /**
- * drm_rect - two dimensional rectangle
+ * DOC: rect utils
+ *
+ * Utility functions to help manage rectangular areas for
+ * clipping, scaling, etc. calculations.
+ */
+
+/**
+ * struct drm_rect - two dimensional rectangle
  * @x1: horizontal starting coordinate (inclusive)
  * @x2: horizontal ending coordinate (exclusive)
  * @y1: vertical starting coordinate (inclusive)
-- 
1.8.1.5

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply related	[flat|nested] 8+ messages in thread

* Re: [PATCH v2] drm: Fix drm_rect documentation
  2013-05-08 14:16     ` [PATCH v2] " ville.syrjala
@ 2013-05-08 14:42       ` Daniel Vetter
  2013-05-23 10:02       ` Daniel Vetter
  1 sibling, 0 replies; 8+ messages in thread
From: Daniel Vetter @ 2013-05-08 14:42 UTC (permalink / raw)
  To: ville.syrjala; +Cc: intel-gfx, Laurent Pinchart, dri-devel

On Wed, May 08, 2013 at 05:16:45PM +0300, ville.syrjala@linux.intel.com wrote:
> From: Ville Syrjälä <ville.syrjala@linux.intel.com>
> 
> The 'struct' keyword was missing so struct drm_rect documentation never
> ended up in the generated docs.
> 
> Also move the drm_rect documentations to a new section alognside the
> various helper functions and add a short description about the intended
> purpose of drm_rect.
> 
> v2: Move to new section and add general description
> 
> Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>

Looks neat! Reviewed-by: Daniel Vetter <daniel.vetter@ffwll.ch>

> ---
>  Documentation/DocBook/drm.tmpl | 8 ++++++--
>  include/drm/drm_rect.h         | 9 ++++++++-
>  2 files changed, 14 insertions(+), 3 deletions(-)
> 
> diff --git a/Documentation/DocBook/drm.tmpl b/Documentation/DocBook/drm.tmpl
> index 7c7af25..91ee107 100644
> --- a/Documentation/DocBook/drm.tmpl
> +++ b/Documentation/DocBook/drm.tmpl
> @@ -1653,8 +1653,6 @@ void intel_crt_init(struct drm_device *dev)
>      <sect2>
>        <title>KMS API Functions</title>
>  !Edrivers/gpu/drm/drm_crtc.c
> -!Edrivers/gpu/drm/drm_rect.c
> -!Finclude/drm/drm_rect.h
>      </sect2>
>    </sect1>
>  
> @@ -2163,6 +2161,12 @@ void intel_crt_init(struct drm_device *dev)
>        <title>EDID Helper Functions Reference</title>
>  !Edrivers/gpu/drm/drm_edid.c
>      </sect2>
> +    <sect2>
> +      <title>Rectangle Utilities Reference</title>
> +!Pinclude/drm/drm_rect.h rect utils
> +!Iinclude/drm/drm_rect.h
> +!Edrivers/gpu/drm/drm_rect.c
> +    </sect2>
>    </sect1>
>  
>    <!-- Internals: vertical blanking -->
> diff --git a/include/drm/drm_rect.h b/include/drm/drm_rect.h
> index 64fa265..d128629 100644
> --- a/include/drm/drm_rect.h
> +++ b/include/drm/drm_rect.h
> @@ -25,7 +25,14 @@
>  #define DRM_RECT_H
>  
>  /**
> - * drm_rect - two dimensional rectangle
> + * DOC: rect utils
> + *
> + * Utility functions to help manage rectangular areas for
> + * clipping, scaling, etc. calculations.
> + */
> +
> +/**
> + * struct drm_rect - two dimensional rectangle
>   * @x1: horizontal starting coordinate (inclusive)
>   * @x2: horizontal ending coordinate (exclusive)
>   * @y1: vertical starting coordinate (inclusive)
> -- 
> 1.8.1.5
> 

-- 
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch

^ permalink raw reply	[flat|nested] 8+ messages in thread

* Re: [PATCH v2] drm: Fix drm_rect documentation
  2013-05-08 14:16     ` [PATCH v2] " ville.syrjala
  2013-05-08 14:42       ` Daniel Vetter
@ 2013-05-23 10:02       ` Daniel Vetter
  1 sibling, 0 replies; 8+ messages in thread
From: Daniel Vetter @ 2013-05-23 10:02 UTC (permalink / raw)
  To: ville.syrjala; +Cc: intel-gfx, Laurent Pinchart, dri-devel

On Wed, May 08, 2013 at 05:16:45PM +0300, ville.syrjala@linux.intel.com wrote:
> From: Ville Syrjälä <ville.syrjala@linux.intel.com>
> 
> The 'struct' keyword was missing so struct drm_rect documentation never
> ended up in the generated docs.
> 
> Also move the drm_rect documentations to a new section alognside the
> various helper functions and add a short description about the intended
> purpose of drm_rect.
> 
> v2: Move to new section and add general description
> 
> Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>

Now merged into dinq since the original stuff is in there, too.

Thanks, Daniel
> ---
>  Documentation/DocBook/drm.tmpl | 8 ++++++--
>  include/drm/drm_rect.h         | 9 ++++++++-
>  2 files changed, 14 insertions(+), 3 deletions(-)
> 
> diff --git a/Documentation/DocBook/drm.tmpl b/Documentation/DocBook/drm.tmpl
> index 7c7af25..91ee107 100644
> --- a/Documentation/DocBook/drm.tmpl
> +++ b/Documentation/DocBook/drm.tmpl
> @@ -1653,8 +1653,6 @@ void intel_crt_init(struct drm_device *dev)
>      <sect2>
>        <title>KMS API Functions</title>
>  !Edrivers/gpu/drm/drm_crtc.c
> -!Edrivers/gpu/drm/drm_rect.c
> -!Finclude/drm/drm_rect.h
>      </sect2>
>    </sect1>
>  
> @@ -2163,6 +2161,12 @@ void intel_crt_init(struct drm_device *dev)
>        <title>EDID Helper Functions Reference</title>
>  !Edrivers/gpu/drm/drm_edid.c
>      </sect2>
> +    <sect2>
> +      <title>Rectangle Utilities Reference</title>
> +!Pinclude/drm/drm_rect.h rect utils
> +!Iinclude/drm/drm_rect.h
> +!Edrivers/gpu/drm/drm_rect.c
> +    </sect2>
>    </sect1>
>  
>    <!-- Internals: vertical blanking -->
> diff --git a/include/drm/drm_rect.h b/include/drm/drm_rect.h
> index 64fa265..d128629 100644
> --- a/include/drm/drm_rect.h
> +++ b/include/drm/drm_rect.h
> @@ -25,7 +25,14 @@
>  #define DRM_RECT_H
>  
>  /**
> - * drm_rect - two dimensional rectangle
> + * DOC: rect utils
> + *
> + * Utility functions to help manage rectangular areas for
> + * clipping, scaling, etc. calculations.
> + */
> +
> +/**
> + * struct drm_rect - two dimensional rectangle
>   * @x1: horizontal starting coordinate (inclusive)
>   * @x2: horizontal ending coordinate (exclusive)
>   * @y1: vertical starting coordinate (inclusive)
> -- 
> 1.8.1.5
> 

-- 
Daniel Vetter
Software Engineer, Intel Corporation
+41 (0) 79 365 57 48 - http://blog.ffwll.ch

^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2013-05-23 10:03 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2013-05-08 13:38 [PATCH 0/3] drm: kernel-doc fixes ville.syrjala
2013-05-08 13:38 ` [PATCH 1/3] drm: Add kernel-doc for drm_fb_helper_funcs->initial_config ville.syrjala
2013-05-08 13:38 ` [PATCH 2/3] drm: Remove pointless '-' characters from drm_fb_helper documentation ville.syrjala
2013-05-08 13:38 ` [PATCH 3/3] drm: Fix drm_rect documentation ville.syrjala
2013-05-08 13:55   ` [Intel-gfx] " Daniel Vetter
2013-05-08 14:16     ` [PATCH v2] " ville.syrjala
2013-05-08 14:42       ` Daniel Vetter
2013-05-23 10:02       ` Daniel Vetter

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox