From: Ramalingam C <ramalingam.c@intel.com>
To: Bhawanpreet Lakha <Bhawanpreet.Lakha@amd.com>
Cc: igt-dev@lists.freedesktop.org, intel-gfx@lists.freedesktop.org,
harry.wentland@amd.com
Subject: Re: [PATCH i-g-t v2] tests/kms_content_protection: check i915 and generic debugfs name for HDCP caps
Date: Wed, 23 Oct 2019 20:57:56 +0530 [thread overview]
Message-ID: <20191023152756.GE22201@intel.com> (raw)
In-Reply-To: <20191021194259.17052-1-Bhawanpreet.Lakha@amd.com>
On 2019-10-21 at 15:42:59 -0400, Bhawanpreet Lakha wrote:
> The content protection tests only start if this debugfs entry exists.
> Since the name is specific to intel driver these tests cannot be used with
> other drivers. So we should check generic debugfs name also
>
> v2: Check i915_* if device is i915, otherwise check the generic name.
>
> Signed-off-by: Bhawanpreet Lakha <Bhawanpreet.Lakha@amd.com>
Looks good to me.
Reviewed-by: Ramalingam C <ramalingam.c@intel.com>
> ---
> tests/kms_content_protection.c | 12 ++++++++++--
> 1 file changed, 10 insertions(+), 2 deletions(-)
>
> diff --git a/tests/kms_content_protection.c b/tests/kms_content_protection.c
> index e676b60b..42fdc459 100644
> --- a/tests/kms_content_protection.c
> +++ b/tests/kms_content_protection.c
> @@ -554,7 +554,11 @@ static bool sink_hdcp_capable(igt_output_t *output)
> if (fd < 0)
> return false;
>
> - debugfs_read(fd, "i915_hdcp_sink_capability", buf);
> + if (is_i915_device(data.drm_fd))
> + debugfs_read(fd, "i915_hdcp_sink_capability", buf);
> + else
> + debugfs_read(fd, "hdcp_sink_capability", buf);
> +
> close(fd);
>
> igt_debug("Sink capability: %s\n", buf);
> @@ -571,7 +575,11 @@ static bool sink_hdcp2_capable(igt_output_t *output)
> if (fd < 0)
> return false;
>
> - debugfs_read(fd, "i915_hdcp_sink_capability", buf);
> + if (is_i915_device(data.drm_fd))
> + debugfs_read(fd, "i915_hdcp_sink_capability", buf);
> + else
> + debugfs_read(fd, "hdcp_sink_capability", buf);
> +
> close(fd);
>
> igt_debug("Sink capability: %s\n", buf);
> --
> 2.17.1
>
> _______________________________________________
> Intel-gfx mailing list
> Intel-gfx@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/intel-gfx
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
WARNING: multiple messages have this Message-ID (diff)
From: Ramalingam C <ramalingam.c@intel.com>
To: Bhawanpreet Lakha <Bhawanpreet.Lakha@amd.com>
Cc: igt-dev@lists.freedesktop.org, intel-gfx@lists.freedesktop.org,
harry.wentland@amd.com
Subject: Re: [Intel-gfx] [PATCH i-g-t v2] tests/kms_content_protection: check i915 and generic debugfs name for HDCP caps
Date: Wed, 23 Oct 2019 20:57:56 +0530 [thread overview]
Message-ID: <20191023152756.GE22201@intel.com> (raw)
Message-ID: <20191023152756.4vBWKGLsPFakeIhNYwhdZIEk7h9ML-9_nCeXJUiJaxQ@z> (raw)
In-Reply-To: <20191021194259.17052-1-Bhawanpreet.Lakha@amd.com>
On 2019-10-21 at 15:42:59 -0400, Bhawanpreet Lakha wrote:
> The content protection tests only start if this debugfs entry exists.
> Since the name is specific to intel driver these tests cannot be used with
> other drivers. So we should check generic debugfs name also
>
> v2: Check i915_* if device is i915, otherwise check the generic name.
>
> Signed-off-by: Bhawanpreet Lakha <Bhawanpreet.Lakha@amd.com>
Looks good to me.
Reviewed-by: Ramalingam C <ramalingam.c@intel.com>
> ---
> tests/kms_content_protection.c | 12 ++++++++++--
> 1 file changed, 10 insertions(+), 2 deletions(-)
>
> diff --git a/tests/kms_content_protection.c b/tests/kms_content_protection.c
> index e676b60b..42fdc459 100644
> --- a/tests/kms_content_protection.c
> +++ b/tests/kms_content_protection.c
> @@ -554,7 +554,11 @@ static bool sink_hdcp_capable(igt_output_t *output)
> if (fd < 0)
> return false;
>
> - debugfs_read(fd, "i915_hdcp_sink_capability", buf);
> + if (is_i915_device(data.drm_fd))
> + debugfs_read(fd, "i915_hdcp_sink_capability", buf);
> + else
> + debugfs_read(fd, "hdcp_sink_capability", buf);
> +
> close(fd);
>
> igt_debug("Sink capability: %s\n", buf);
> @@ -571,7 +575,11 @@ static bool sink_hdcp2_capable(igt_output_t *output)
> if (fd < 0)
> return false;
>
> - debugfs_read(fd, "i915_hdcp_sink_capability", buf);
> + if (is_i915_device(data.drm_fd))
> + debugfs_read(fd, "i915_hdcp_sink_capability", buf);
> + else
> + debugfs_read(fd, "hdcp_sink_capability", buf);
> +
> close(fd);
>
> igt_debug("Sink capability: %s\n", buf);
> --
> 2.17.1
>
> _______________________________________________
> Intel-gfx mailing list
> Intel-gfx@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/intel-gfx
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
next prev parent reply other threads:[~2019-10-23 15:27 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-09-23 18:23 [PATCH] test/kms_content_protection: Use generic debugfs name for HDCP caps Bhawanpreet Lakha
2019-09-24 9:54 ` [igt-dev] " Petri Latvala
2019-09-24 14:41 ` Lakha, Bhawanpreet
2019-09-24 15:41 ` Ramalingam C
2019-10-21 19:42 ` [PATCH i-g-t v2] tests/kms_content_protection: check i915 and " Bhawanpreet Lakha
2019-10-23 14:18 ` Harry Wentland
2019-10-23 14:18 ` [Intel-gfx] " Harry Wentland
2019-10-23 15:27 ` Ramalingam C [this message]
2019-10-23 15:27 ` Ramalingam C
2019-10-24 11:17 ` Petri Latvala
2019-10-24 11:17 ` [Intel-gfx] " Petri Latvala
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20191023152756.GE22201@intel.com \
--to=ramalingam.c@intel.com \
--cc=Bhawanpreet.Lakha@amd.com \
--cc=harry.wentland@amd.com \
--cc=igt-dev@lists.freedesktop.org \
--cc=intel-gfx@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox