Intel-GFX Archive on lore.kernel.org
 help / color / mirror / Atom feed
* [PATCH] test/kms_content_protection: Use generic debugfs name for HDCP caps
@ 2019-09-23 18:23 Bhawanpreet Lakha
  2019-09-24  9:54 ` [igt-dev] " Petri Latvala
  2019-10-21 19:42 ` [PATCH i-g-t v2] tests/kms_content_protection: check i915 and " Bhawanpreet Lakha
  0 siblings, 2 replies; 11+ messages in thread
From: Bhawanpreet Lakha @ 2019-09-23 18:23 UTC (permalink / raw)
  To: igt-dev, intel-gfx; +Cc: Bhawanpreet Lakha

Rename "i915_hdcp_sink_capability" to "hdcp_sink_capability"

The content protection tests only start if this debugfs entry exists.
Since the name is specific to intel driver these tests cannot be used with
other drivers.

Remove "i915" so the debugfs name is generic.

Signed-off-by: Bhawanpreet Lakha <Bhawanpreet.Lakha@amd.com>
---
 tests/kms_content_protection.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/tests/kms_content_protection.c b/tests/kms_content_protection.c
index e676b60b..a105c5de 100644
--- a/tests/kms_content_protection.c
+++ b/tests/kms_content_protection.c
@@ -554,7 +554,7 @@ static bool sink_hdcp_capable(igt_output_t *output)
 	if (fd < 0)
 		return false;
 
-	debugfs_read(fd, "i915_hdcp_sink_capability", buf);
+	debugfs_read(fd, "hdcp_sink_capability", buf);
 	close(fd);
 
 	igt_debug("Sink capability: %s\n", buf);
@@ -571,7 +571,7 @@ static bool sink_hdcp2_capable(igt_output_t *output)
 	if (fd < 0)
 		return false;
 
-	debugfs_read(fd, "i915_hdcp_sink_capability", buf);
+	debugfs_read(fd, "hdcp_sink_capability", buf);
 	close(fd);
 
 	igt_debug("Sink capability: %s\n", buf);
-- 
2.17.1

_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

^ permalink raw reply related	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2019-10-24 11:17 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2019-09-23 18:23 [PATCH] test/kms_content_protection: Use generic debugfs name for HDCP caps Bhawanpreet Lakha
2019-09-24  9:54 ` [igt-dev] " Petri Latvala
2019-09-24 14:41   ` Lakha, Bhawanpreet
2019-09-24 15:41   ` Ramalingam C
2019-10-21 19:42 ` [PATCH i-g-t v2] tests/kms_content_protection: check i915 and " Bhawanpreet Lakha
2019-10-23 14:18   ` Harry Wentland
2019-10-23 14:18     ` [Intel-gfx] " Harry Wentland
2019-10-23 15:27   ` Ramalingam C
2019-10-23 15:27     ` [Intel-gfx] " Ramalingam C
2019-10-24 11:17   ` Petri Latvala
2019-10-24 11:17     ` [Intel-gfx] " Petri Latvala

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox