From: Tvrtko Ursulin <tvrtko.ursulin@linux.intel.com>
To: "Goel, Akash" <akash.goel@intel.com>, intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 06/20] drm/i915: Handle log buffer flush interrupt event from GuC
Date: Fri, 12 Aug 2016 15:07:19 +0100 [thread overview]
Message-ID: <57ADD817.50309@linux.intel.com> (raw)
In-Reply-To: <670b6e54-9bc0-a30e-8fee-d5c9927c713f@intel.com>
On 12/08/16 14:45, Goel, Akash wrote:
>
>
> On 8/12/2016 6:47 PM, Tvrtko Ursulin wrote:
>>
>> On 12/08/16 07:25, akash.goel@intel.com wrote:
>>> From: Sagar Arun Kamble <sagar.a.kamble@intel.com>
>>>
>>> GuC ukernel sends an interrupt to Host to flush the log buffer
>>> and expects Host to correspondingly update the read pointer
>>> information in the state structure, once it has consumed the
>>> log buffer contents by copying them to a file or buffer.
>>> Even if Host couldn't copy the contents, it can still update the
>>> read pointer so that logging state is not disturbed on GuC side.
>>>
>>> v2:
>>> - Use a dedicated workqueue for handling flush interrupt. (Tvrtko)
>>> - Reduce the overall log buffer copying time by skipping the copy of
>>> crash buffer area for regular cases and copying only the state
>>> structure data in first page.
>>>
>>> v3:
>>> - Create a vmalloc mapping of log buffer. (Chris)
>>> - Cover the flush acknowledgment under rpm get & put.(Chris)
>>> - Revert the change of skipping the copy of crash dump area, as
>>> not really needed, will be covered by subsequent patch.
>>>
>>> v4:
>>> - Destroy the wq under the same condition in which it was created,
>>> pass dev_piv pointer instead of dev to newly added GuC function,
>>> add more comments & rename variable for clarity. (Tvrtko)
>>>
>>> Signed-off-by: Sagar Arun Kamble <sagar.a.kamble@intel.com>
>>> Signed-off-by: Akash Goel <akash.goel@intel.com>
>>> ---
>>> drivers/gpu/drm/i915/i915_drv.c | 14 +++
>>> drivers/gpu/drm/i915/i915_guc_submission.c | 150
>>> +++++++++++++++++++++++++++++
>>> drivers/gpu/drm/i915/i915_irq.c | 5 +-
>>> drivers/gpu/drm/i915/intel_guc.h | 3 +
>>> 4 files changed, 170 insertions(+), 2 deletions(-)
>>>
>>> diff --git a/drivers/gpu/drm/i915/i915_drv.c
>>> b/drivers/gpu/drm/i915/i915_drv.c
>>> index 0fcd1c0..fc2da32 100644
>>> --- a/drivers/gpu/drm/i915/i915_drv.c
>>> +++ b/drivers/gpu/drm/i915/i915_drv.c
>>> @@ -770,8 +770,20 @@ static int i915_workqueues_init(struct
>>> drm_i915_private *dev_priv)
>>> if (dev_priv->hotplug.dp_wq == NULL)
>>> goto out_free_wq;
>>>
>>> + if (HAS_GUC_SCHED(dev_priv)) {
>>
>> This just reminded me that a previous patch had:
>>
>> + if (HAS_GUC_UCODE(dev))
>> + dev_priv->pm_guc_events = GEN9_GUC_TO_HOST_INT_EVENT;
>>
>> In the interrupt setup. I don't think there is a bug right now, but
>> there is a disagreement between the two which would be good to resolve.
>>
>> This HAS_GUC_UCODE in the other patch should probably be HAS_GUC_SCHED
>> for correctness. I think.
>
> Sorry for inconsistency, Will use HAS_GUC_SCHED in the previous patch.
>
> As per Chris's comments will move the wq init/destroy to the GuC logging
> setup/teardown routines (guc_create_log_extras, guc_log_cleanup)
> You are fine with that ?.
Yes thats OK I think.
>>
>>> + /* Need a dedicated wq to process log buffer flush interrupts
>>> + * from GuC without much delay so as to avoid any loss of logs.
>>> + */
>>> + dev_priv->guc.log.wq =
>>> + alloc_ordered_workqueue("i915-guc_log", 0);
>>> + if (dev_priv->guc.log.wq == NULL)
>>> + goto out_free_hotplug_dp_wq;
>>> + }
>>> +
>>> return 0;
>>>
>>> +out_free_hotplug_dp_wq:
>>> + destroy_workqueue(dev_priv->hotplug.dp_wq);
>>> out_free_wq:
>>> destroy_workqueue(dev_priv->wq);
>>> out_err:
>>> @@ -782,6 +794,8 @@ out_err:
>>>
>>> static void i915_workqueues_cleanup(struct drm_i915_private *dev_priv)
>>> {
>>> + if (HAS_GUC_SCHED(dev_priv))
>>> + destroy_workqueue(dev_priv->guc.log.wq);
>>> destroy_workqueue(dev_priv->hotplug.dp_wq);
>>> destroy_workqueue(dev_priv->wq);
>>> }
>>> diff --git a/drivers/gpu/drm/i915/i915_guc_submission.c
>>> b/drivers/gpu/drm/i915/i915_guc_submission.c
>>> index c7c679f..2635b67 100644
>>> --- a/drivers/gpu/drm/i915/i915_guc_submission.c
>>> +++ b/drivers/gpu/drm/i915/i915_guc_submission.c
>>> @@ -172,6 +172,15 @@ static int host2guc_sample_forcewake(struct
>>> intel_guc *guc,
>>> return host2guc_action(guc, data, ARRAY_SIZE(data));
>>> }
>>>
>>> +static int host2guc_logbuffer_flush_complete(struct intel_guc *guc)
>>> +{
>>> + u32 data[1];
>>> +
>>> + data[0] = HOST2GUC_ACTION_LOG_BUFFER_FILE_FLUSH_COMPLETE;
>>> +
>>> + return host2guc_action(guc, data, 1);
>>> +}
>>> +
>>> /*
>>> * Initialise, update, or clear doorbell data shared with the GuC
>>> *
>>> @@ -840,6 +849,127 @@ err:
>>> return NULL;
>>> }
>>>
>>> +static void guc_move_to_next_buf(struct intel_guc *guc)
>>> +{
>>> + return;
>>> +}
>>> +
>>> +static void* guc_get_write_buffer(struct intel_guc *guc)
>>> +{
>>> + return NULL;
>>> +}
>>> +
>>> +static void guc_read_update_log_buffer(struct intel_guc *guc)
>>> +{
>>> + struct guc_log_buffer_state *log_buffer_state,
>>> *log_buffer_snapshot_state;
>>> + struct guc_log_buffer_state log_buffer_state_local;
>>> + void *src_data_ptr, *dst_data_ptr;
>>> + u32 i, buffer_size;
>>
>> unsigned int i if you can be bothered.
>
> Fine will do that for both i & buffer_size.
buffer_size can match the type of log_buffer_state_local.size or use
something else if more appropriate.
> But I remember earlier in one of the patch, you suggested to use u32 as
> a type for some variables.
> Please could you share the guideline.
> Should u32, u64 be used we are exactly sure of the range of the
> variable, like for variables containing the register values ?
Depends what the variable is. "i" in this case is just a standard
counter so not appropriate to use u32. It is not that wrong on x86, just
looks a bit out of place.
grep "u32 i;" has no hits in i915. :)
They can/should be used for variables tied with hardware or protocols.
Or in some cases where you really want to save space by using a small type.
>
>>
>>> +
>>> + if (!guc->log.buf_addr)
>>> + return;
>>
>> Can it hit this? If yes, I think better disable GuC logging when pin map
>> on the object fails rather than let it generate interrupts in vain.
>>
>>> +
>>> + /* Get the pointer to shared GuC log buffer */
>>> + log_buffer_state = src_data_ptr = guc->log.buf_addr;
>>> +
>>> + /* Get the pointer to local buffer to store the logs */
>>> + dst_data_ptr = log_buffer_snapshot_state =
>>> guc_get_write_buffer(guc);
>>> +
>>> + /* Actual logs are present from the 2nd page */
>>> + src_data_ptr += PAGE_SIZE;
>>> + dst_data_ptr += PAGE_SIZE;
>>> +
>>> + for (i = 0; i < GUC_MAX_LOG_BUFFER; i++) {
>>> + /* Make a copy of the state structure in GuC log buffer (which
>>> + * is uncached mapped) on the stack to avoid reading from it
>>> + * multiple times.
>>> + */
>>> + memcpy(&log_buffer_state_local, log_buffer_state,
>>> + sizeof(struct guc_log_buffer_state));
>>> + buffer_size = log_buffer_state_local.size;
>>
>> Needs checking (and logging) that a bad firmware or some other error
>> does not report a dangerous size (too big) which would then overwrite
>> memory pointed by dst_data_ptr memory. (And/or read from random memory.)
>>
> Have done the range checking for the read/write offset values, which are
> updated repeatedly by GuC firmware.
> The buffer size is updated only at init time by GuC firmware, hence less
> vulnerable.
>
> But nevertheless will add the checks.
Ok good.
>>> +
>>> + if (log_buffer_snapshot_state) {
>>> + /* First copy the state structure in local buffer */
>>
>> Maybe "destination buffer" would be clearer?
>
> Sorry my bad, well spotted.
>
>>
>>> + memcpy(log_buffer_snapshot_state, &log_buffer_state_local,
>>> + sizeof(struct guc_log_buffer_state));
>>> +
>>> + /* The write pointer could have been updated by the GuC
>>> + * firmware, after sending the flush interrupt to Host,
>>> + * for consistency set the write pointer value to same
>>> + * value of sampled_write_ptr in the snapshot buffer.
>>> + */
>>> + log_buffer_snapshot_state->write_ptr =
>>> + log_buffer_snapshot_state->sampled_write_ptr;
>>> +
>>> + log_buffer_snapshot_state++;
>>> +
>>> + /* Now copy the actual logs */
>>> + memcpy(dst_data_ptr, src_data_ptr, buffer_size);
>>> +
>>> + src_data_ptr += buffer_size;
>>> + dst_data_ptr += buffer_size;
>>> + }
>>> +
>>> + /* FIXME: invalidate/flush for log buffer needed */
>>
>> Yes no maybe? :)
>
> Will like to keep it, if you allow.
I think you need a really good justification to get r-b on patches with
FIXMEs, especially like this one. Do you maybe handle it or remove it in
a following patch or something?
Regards,
Tvrtko
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
next prev parent reply other threads:[~2016-08-12 14:08 UTC|newest]
Thread overview: 68+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-08-12 6:25 [PATCH v5 00/20] Support for sustained capturing of GuC firmware logs akash.goel
2016-08-12 6:25 ` [PATCH 01/20] drm/i915: Decouple GuC log setup from verbosity parameter akash.goel
2016-08-12 6:25 ` [PATCH 02/20] drm/i915: Add GuC ukernel logging related fields to fw interface file akash.goel
2016-08-12 6:25 ` [PATCH 03/20] drm/i915: New structure to contain GuC logging related fields akash.goel
2016-08-12 6:25 ` [PATCH 04/20] drm/i915: Add low level set of routines for programming PM IER/IIR/IMR register set akash.goel
2016-08-12 11:15 ` Tvrtko Ursulin
2016-08-12 6:25 ` [PATCH 05/20] drm/i915: Support for GuC interrupts akash.goel
2016-08-12 11:54 ` Tvrtko Ursulin
2016-08-12 13:10 ` Goel, Akash
2016-08-12 13:31 ` Tvrtko Ursulin
2016-08-12 14:31 ` Goel, Akash
2016-08-12 15:05 ` Tvrtko Ursulin
2016-08-12 15:32 ` Goel, Akash
2016-08-12 6:25 ` [PATCH 06/20] drm/i915: Handle log buffer flush interrupt event from GuC akash.goel
2016-08-12 6:28 ` Chris Wilson
2016-08-12 6:44 ` Goel, Akash
2016-08-12 6:51 ` Chris Wilson
2016-08-12 7:00 ` Goel, Akash
2016-08-12 13:17 ` Tvrtko Ursulin
2016-08-12 13:45 ` Goel, Akash
2016-08-12 14:07 ` Tvrtko Ursulin [this message]
2016-08-12 16:17 ` Goel, Akash
2016-08-12 6:25 ` [PATCH 07/20] relay: Use per CPU constructs for the relay channel buffer pointers akash.goel
2016-08-12 6:25 ` [PATCH 08/20] drm/i915: Add a relay backed debugfs interface for capturing GuC logs akash.goel
2016-08-12 13:53 ` Tvrtko Ursulin
2016-08-12 16:10 ` Goel, Akash
2016-08-12 6:25 ` [PATCH 09/20] drm/i915: New lock to serialize the Host2GuC actions akash.goel
2016-08-12 13:55 ` Tvrtko Ursulin
2016-08-12 15:01 ` Goel, Akash
2016-08-12 6:25 ` [PATCH 10/20] drm/i915: Add stats for GuC log buffer flush interrupts akash.goel
2016-08-12 14:26 ` Tvrtko Ursulin
2016-08-12 14:56 ` Goel, Akash
2016-08-12 6:25 ` [PATCH 11/20] drm/i915: Optimization to reduce the sampling time of GuC log buffer akash.goel
2016-08-12 14:42 ` Tvrtko Ursulin
2016-08-12 14:48 ` Goel, Akash
2016-08-12 15:06 ` Tvrtko Ursulin
2016-08-12 6:25 ` [PATCH 12/20] drm/i915: Increase GuC log buffer size to reduce flush interrupts akash.goel
2016-08-12 6:25 ` [PATCH 13/20] drm/i915: Augment i915 error state to include the dump of GuC log buffer akash.goel
2016-08-12 15:20 ` Tvrtko Ursulin
2016-08-12 15:32 ` Chris Wilson
2016-08-12 15:46 ` Goel, Akash
2016-08-12 15:52 ` Chris Wilson
2016-08-12 16:04 ` Goel, Akash
2016-08-12 16:09 ` Chris Wilson
2016-08-12 6:25 ` [PATCH 14/20] drm/i915: Forcefully flush GuC log buffer on reset akash.goel
2016-08-12 6:33 ` Chris Wilson
2016-08-12 7:02 ` Goel, Akash
2016-08-12 6:25 ` [PATCH 15/20] drm/i915: Debugfs support for GuC logging control akash.goel
2016-08-12 15:57 ` Tvrtko Ursulin
2016-08-12 17:08 ` Goel, Akash
2016-08-12 6:25 ` [PATCH 16/20] drm/i915: Support to create write combined type vmaps akash.goel
2016-08-12 10:49 ` Tvrtko Ursulin
2016-08-12 15:13 ` Goel, Akash
2016-08-12 15:16 ` Chris Wilson
2016-08-12 16:46 ` Goel, Akash
2016-08-12 6:25 ` [PATCH 17/20] drm/i915: Use uncached(WC) mapping for acessing the GuC log buffer akash.goel
2016-08-12 16:05 ` Tvrtko Ursulin
2016-08-12 6:25 ` [PATCH 18/20] drm/i915: Use SSE4.1 movntdqa to accelerate reads from WC memory akash.goel
2016-08-12 10:54 ` Tvrtko Ursulin
2016-08-12 12:22 ` Chris Wilson
2016-08-12 6:25 ` [PATCH 19/20] drm/i915: Use SSE4.1 movntdqa based memcpy for sampling GuC log buffer akash.goel
2016-08-12 16:06 ` Tvrtko Ursulin
2016-08-12 6:25 ` [PATCH 20/20] drm/i915: Early creation of relay channel for capturing boot time logs akash.goel
2016-08-12 16:22 ` Tvrtko Ursulin
2016-08-12 16:31 ` Goel, Akash
2016-08-15 9:20 ` Tvrtko Ursulin
2016-08-15 10:20 ` Goel, Akash
2016-08-12 6:58 ` ✗ Ro.CI.BAT: warning for Support for sustained capturing of GuC firmware logs (rev6) Patchwork
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=57ADD817.50309@linux.intel.com \
--to=tvrtko.ursulin@linux.intel.com \
--cc=akash.goel@intel.com \
--cc=intel-gfx@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox