From: Tvrtko Ursulin <tvrtko.ursulin@linux.intel.com>
To: akash.goel@intel.com, intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH 15/20] drm/i915: Debugfs support for GuC logging control
Date: Fri, 12 Aug 2016 16:57:02 +0100 [thread overview]
Message-ID: <57ADF1CE.5050306@linux.intel.com> (raw)
In-Reply-To: <1470983123-22127-16-git-send-email-akash.goel@intel.com>
On 12/08/16 07:25, akash.goel@intel.com wrote:
> From: Sagar Arun Kamble <sagar.a.kamble@intel.com>
>
> This patch provides debugfs interface i915_guc_output_control for
> on the fly enabling/disabling of logging in GuC firmware and controlling
> the verbosity level of logs.
> The value written to the file, should have bit 0 set to enable logging and
> bits 4-7 should contain the verbosity info.
>
> v2: Add a forceful flush, to collect left over logs, on disabling logging.
> Useful for Validation.
>
> v3: Besides minor cleanup, implement read method for the debugfs file and
> set the guc_log_level to -1 when logging is disabled. (Tvrtko)
>
> Signed-off-by: Sagar Arun Kamble <sagar.a.kamble@intel.com>
> Signed-off-by: Akash Goel <akash.goel@intel.com>
> ---
> drivers/gpu/drm/i915/i915_debugfs.c | 44 ++++++++++++++++++++-
> drivers/gpu/drm/i915/i915_guc_submission.c | 63 ++++++++++++++++++++++++++++++
> drivers/gpu/drm/i915/intel_guc.h | 1 +
> 3 files changed, 107 insertions(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/i915/i915_debugfs.c b/drivers/gpu/drm/i915/i915_debugfs.c
> index 14e0dcf..f472fbcd3 100644
> --- a/drivers/gpu/drm/i915/i915_debugfs.c
> +++ b/drivers/gpu/drm/i915/i915_debugfs.c
> @@ -2674,6 +2674,47 @@ static int i915_guc_log_dump(struct seq_file *m, void *data)
> return 0;
> }
>
> +static int i915_guc_log_control_get(void *data, u64 *val)
> +{
> + struct drm_device *dev = data;
> + struct drm_i915_private *dev_priv = to_i915(dev);
> +
> + if (!dev_priv->guc.log.obj)
> + return -EINVAL;
> +
> + *val = i915.guc_log_level;
> +
> + return 0;
> +}
> +
> +static int i915_guc_log_control_set(void *data, u64 val)
> +{
> + struct drm_device *dev = data;
> + struct drm_i915_private *dev_priv = to_i915(dev);
> + int ret;
> +
> + ret = mutex_lock_interruptible(&dev->struct_mutex);
> + if (ret)
> + return ret;
> +
> + if (!dev_priv->guc.log.obj) {
> + ret = -EINVAL;
> + goto end;
> + }
> +
> + intel_runtime_pm_get(dev_priv);
> + ret = i915_guc_log_control(dev_priv, val);
> + intel_runtime_pm_put(dev_priv);
> +
> +end:
> + mutex_unlock(&dev->struct_mutex);
> + return ret;
> +}
> +
> +DEFINE_SIMPLE_ATTRIBUTE(i915_guc_log_control_fops,
> + i915_guc_log_control_get, i915_guc_log_control_set,
> + "%lld\n");
> +
> static int i915_edp_psr_status(struct seq_file *m, void *data)
> {
> struct drm_info_node *node = m->private;
> @@ -5477,7 +5518,8 @@ static const struct i915_debugfs_files {
> {"i915_fbc_false_color", &i915_fbc_fc_fops},
> {"i915_dp_test_data", &i915_displayport_test_data_fops},
> {"i915_dp_test_type", &i915_displayport_test_type_fops},
> - {"i915_dp_test_active", &i915_displayport_test_active_fops}
> + {"i915_dp_test_active", &i915_displayport_test_active_fops},
> + {"i915_guc_log_control", &i915_guc_log_control_fops}
> };
>
> void intel_display_crc_init(struct drm_device *dev)
> diff --git a/drivers/gpu/drm/i915/i915_guc_submission.c b/drivers/gpu/drm/i915/i915_guc_submission.c
> index 4a75c16..041cf68 100644
> --- a/drivers/gpu/drm/i915/i915_guc_submission.c
> +++ b/drivers/gpu/drm/i915/i915_guc_submission.c
> @@ -195,6 +195,16 @@ static int host2guc_force_logbuffer_flush(struct intel_guc *guc)
> return host2guc_action(guc, data, 2);
> }
>
> +static int host2guc_logging_control(struct intel_guc *guc, u32 control_val)
> +{
> + u32 data[2];
> +
> + data[0] = HOST2GUC_ACTION_UK_LOG_ENABLE_LOGGING;
> + data[1] = control_val;
> +
> + return host2guc_action(guc, data, 2);
> +}
> +
> /*
> * Initialise, update, or clear doorbell data shared with the GuC
> *
> @@ -1538,3 +1548,56 @@ void i915_guc_register(struct drm_i915_private *dev_priv)
> guc_log_late_setup(&dev_priv->guc);
> mutex_unlock(&dev_priv->drm.struct_mutex);
> }
> +
> +int i915_guc_log_control(struct drm_i915_private *dev_priv, u64 control_val)
> +{
> + union guc_log_control log_param;
> + int ret;
> +
> + log_param.logging_enabled = control_val & 0x1;
> + log_param.verbosity = (control_val >> 4) & 0xF;
Maybe "log_param.value = control_val" would also work since
guc_log_control is conveniently defined as an union. Doesn't matter though.
> +
> + if (log_param.verbosity < GUC_LOG_VERBOSITY_MIN ||
> + log_param.verbosity > GUC_LOG_VERBOSITY_MAX)
> + return -EINVAL;
> +
> + /* This combination doesn't make sense & won't have any effect */
> + if (!log_param.logging_enabled && (i915.guc_log_level < 0))
> + return 0;
I wonder if it would work and maybe look nicer to generalize as:
int guc_log_level;
guc_log_level = log_param.logging_enabled ? log_param.verbosity : -1;
if (i915.guc_log_level == guc_log_level)
return 0;
> +
> + ret = host2guc_logging_control(&dev_priv->guc, log_param.value);
> + if (ret < 0) {
> + DRM_DEBUG_DRIVER("host2guc action failed %d\n", ret);
> + return ret;
> + }
> +
> + i915.guc_log_level = log_param.verbosity;
This would then become i915.guc_log_level = guc_log_level.
> +
> + /* If log_level was set as -1 at boot time, then the relay channel file
> + * wouldn't have been created by now and interrupts also would not have
> + * been enabled.
> + */
> + if (!dev_priv->guc.log.relay_chan) {
> + ret = guc_log_late_setup(&dev_priv->guc);
> + if (!ret)
> + gen9_enable_guc_interrupts(dev_priv);
> + } else if (!log_param.logging_enabled) {
> + /* Once logging is disabled, GuC won't generate logs & send an
> + * interrupt. But there could be some data in the log buffer
> + * which is yet to be captured. So request GuC to update the log
> + * buffer state and then collect the left over logs.
> + */
> + i915_guc_flush_logs(dev_priv);
> +
> + /* GuC would have updated the log buffer by now, so capture it */
> + i915_guc_capture_logs(dev_priv);
> +
> + /* As logging is disabled, update the log level to reflect that */
> + i915.guc_log_level = -1;
> + } else {
> + /* In case interrupts were disabled, enable them now */
> + gen9_enable_guc_interrupts(dev_priv);
> + }
And this block would need some adjustments with my guc_log_level idea.
Well not sure, see what you think. I am just attracted to the idea of
operating in the same value domain as much as possible for readability
and simplicity. Maybe it would not improve anything, I did not bother
with typing it all to check.
> +
> + return ret;
> +}
> diff --git a/drivers/gpu/drm/i915/intel_guc.h b/drivers/gpu/drm/i915/intel_guc.h
> index d3a5447..2f8c408 100644
> --- a/drivers/gpu/drm/i915/intel_guc.h
> +++ b/drivers/gpu/drm/i915/intel_guc.h
> @@ -186,5 +186,6 @@ void i915_guc_capture_logs(struct drm_i915_private *dev_priv);
> void i915_guc_flush_logs(struct drm_i915_private *dev_priv);
> void i915_guc_register(struct drm_i915_private *dev_priv);
> void i915_guc_unregister(struct drm_i915_private *dev_priv);
> +int i915_guc_log_control(struct drm_i915_private *dev_priv, u64 control_val);
>
> #endif
>
Patch looks correct as is, so:
Reviewed-by: Tvrtko Ursulin <tvrtko.ursulin@intel.com>
Although I would be happier though if my suggestion to use the same
value domain as for the module parameter was used. In other words:
{"i915_guc_log_level", &i915_guc_log_control_fops}
...
int i915_guc_log_control(struct drm_i915_private *dev_priv, u64 control_val)
...
int guc_log_level = (int)control_val;
...
log_param.logging_enabled = guc_log_level > -1;
log_param.verbosity = guc_log_level > -1 ? guc_log_level : 0;
...
It think it would be simpler for the user and developer to only have to
think about one set of values when dealing with guc logging.
But maybe extensions to guc_log_control are imminent and expected so it
would not be worth it in the long run. No idea.
Regards,
Tvrtko
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx
next prev parent reply other threads:[~2016-08-12 15:57 UTC|newest]
Thread overview: 68+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-08-12 6:25 [PATCH v5 00/20] Support for sustained capturing of GuC firmware logs akash.goel
2016-08-12 6:25 ` [PATCH 01/20] drm/i915: Decouple GuC log setup from verbosity parameter akash.goel
2016-08-12 6:25 ` [PATCH 02/20] drm/i915: Add GuC ukernel logging related fields to fw interface file akash.goel
2016-08-12 6:25 ` [PATCH 03/20] drm/i915: New structure to contain GuC logging related fields akash.goel
2016-08-12 6:25 ` [PATCH 04/20] drm/i915: Add low level set of routines for programming PM IER/IIR/IMR register set akash.goel
2016-08-12 11:15 ` Tvrtko Ursulin
2016-08-12 6:25 ` [PATCH 05/20] drm/i915: Support for GuC interrupts akash.goel
2016-08-12 11:54 ` Tvrtko Ursulin
2016-08-12 13:10 ` Goel, Akash
2016-08-12 13:31 ` Tvrtko Ursulin
2016-08-12 14:31 ` Goel, Akash
2016-08-12 15:05 ` Tvrtko Ursulin
2016-08-12 15:32 ` Goel, Akash
2016-08-12 6:25 ` [PATCH 06/20] drm/i915: Handle log buffer flush interrupt event from GuC akash.goel
2016-08-12 6:28 ` Chris Wilson
2016-08-12 6:44 ` Goel, Akash
2016-08-12 6:51 ` Chris Wilson
2016-08-12 7:00 ` Goel, Akash
2016-08-12 13:17 ` Tvrtko Ursulin
2016-08-12 13:45 ` Goel, Akash
2016-08-12 14:07 ` Tvrtko Ursulin
2016-08-12 16:17 ` Goel, Akash
2016-08-12 6:25 ` [PATCH 07/20] relay: Use per CPU constructs for the relay channel buffer pointers akash.goel
2016-08-12 6:25 ` [PATCH 08/20] drm/i915: Add a relay backed debugfs interface for capturing GuC logs akash.goel
2016-08-12 13:53 ` Tvrtko Ursulin
2016-08-12 16:10 ` Goel, Akash
2016-08-12 6:25 ` [PATCH 09/20] drm/i915: New lock to serialize the Host2GuC actions akash.goel
2016-08-12 13:55 ` Tvrtko Ursulin
2016-08-12 15:01 ` Goel, Akash
2016-08-12 6:25 ` [PATCH 10/20] drm/i915: Add stats for GuC log buffer flush interrupts akash.goel
2016-08-12 14:26 ` Tvrtko Ursulin
2016-08-12 14:56 ` Goel, Akash
2016-08-12 6:25 ` [PATCH 11/20] drm/i915: Optimization to reduce the sampling time of GuC log buffer akash.goel
2016-08-12 14:42 ` Tvrtko Ursulin
2016-08-12 14:48 ` Goel, Akash
2016-08-12 15:06 ` Tvrtko Ursulin
2016-08-12 6:25 ` [PATCH 12/20] drm/i915: Increase GuC log buffer size to reduce flush interrupts akash.goel
2016-08-12 6:25 ` [PATCH 13/20] drm/i915: Augment i915 error state to include the dump of GuC log buffer akash.goel
2016-08-12 15:20 ` Tvrtko Ursulin
2016-08-12 15:32 ` Chris Wilson
2016-08-12 15:46 ` Goel, Akash
2016-08-12 15:52 ` Chris Wilson
2016-08-12 16:04 ` Goel, Akash
2016-08-12 16:09 ` Chris Wilson
2016-08-12 6:25 ` [PATCH 14/20] drm/i915: Forcefully flush GuC log buffer on reset akash.goel
2016-08-12 6:33 ` Chris Wilson
2016-08-12 7:02 ` Goel, Akash
2016-08-12 6:25 ` [PATCH 15/20] drm/i915: Debugfs support for GuC logging control akash.goel
2016-08-12 15:57 ` Tvrtko Ursulin [this message]
2016-08-12 17:08 ` Goel, Akash
2016-08-12 6:25 ` [PATCH 16/20] drm/i915: Support to create write combined type vmaps akash.goel
2016-08-12 10:49 ` Tvrtko Ursulin
2016-08-12 15:13 ` Goel, Akash
2016-08-12 15:16 ` Chris Wilson
2016-08-12 16:46 ` Goel, Akash
2016-08-12 6:25 ` [PATCH 17/20] drm/i915: Use uncached(WC) mapping for acessing the GuC log buffer akash.goel
2016-08-12 16:05 ` Tvrtko Ursulin
2016-08-12 6:25 ` [PATCH 18/20] drm/i915: Use SSE4.1 movntdqa to accelerate reads from WC memory akash.goel
2016-08-12 10:54 ` Tvrtko Ursulin
2016-08-12 12:22 ` Chris Wilson
2016-08-12 6:25 ` [PATCH 19/20] drm/i915: Use SSE4.1 movntdqa based memcpy for sampling GuC log buffer akash.goel
2016-08-12 16:06 ` Tvrtko Ursulin
2016-08-12 6:25 ` [PATCH 20/20] drm/i915: Early creation of relay channel for capturing boot time logs akash.goel
2016-08-12 16:22 ` Tvrtko Ursulin
2016-08-12 16:31 ` Goel, Akash
2016-08-15 9:20 ` Tvrtko Ursulin
2016-08-15 10:20 ` Goel, Akash
2016-08-12 6:58 ` ✗ Ro.CI.BAT: warning for Support for sustained capturing of GuC firmware logs (rev6) Patchwork
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=57ADF1CE.5050306@linux.intel.com \
--to=tvrtko.ursulin@linux.intel.com \
--cc=akash.goel@intel.com \
--cc=intel-gfx@lists.freedesktop.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox