From: Eric Anholt <eric@anholt.net>
To: Eugeni Dodonov <eugeni@dodonov.net>,
Jesse Barnes <jbarnes@virtuousgeek.org>
Cc: intel-gfx@lists.freedesktop.org
Subject: Re: RFC: i915 arch changes to better support new chipsets
Date: Wed, 28 Mar 2012 13:29:26 -0700 [thread overview]
Message-ID: <87obrgbhax.fsf@eliezer.anholt.net> (raw)
In-Reply-To: <CAC7LmnuxCGwQXeW3cfYuDXp99OXJ1iX9StUDyiQTCK5mZL0m6w@mail.gmail.com>
[-- Attachment #1.1: Type: text/plain, Size: 1411 bytes --]
On Wed, 28 Mar 2012 16:59:15 -0300, Eugeni Dodonov <eugeni@dodonov.net> wrote:
> On Wed, Mar 28, 2012 at 16:46, Jesse Barnes <jbarnes@virtuousgeek.org>wrote:
>
> > > I guess we could have the gen-number stuff be a union of
> > > IS_IVB()/IS_HSW()/IS_VLV(), and switch chipset probing to using each of
> > > those instead of just gen >= 4.
> > >
> > > Does this sound sane?
> >
> > Yeah that might be better anyway, at least for the kernel where the
> > IS_GEN stuff is getting more and more overloaded and I'd like to move
> > away from it in some places.
> >
> > So if you're ok with it, that sounds like a good approach.
> >
>
> I think that we could move away from the IS_GEN checks in most places
> actually, and not just in some of them, by using the feature checks instead.
>
> My latest branch reports gives `grep IS_GEN * | wc -l` = 112; and if we
> look for recent chipsets, we have `grep IS_GEN[67] *` = 47. And most of
> those checks have sub-checks as well for specific chip features or names.
> So if we drop the IS_GEN macros, and just use the specific feature or GPU
> name checks instead we should improve both the readability and decrease the
> code complexity I think.
A grep for IS_GEN will be significantly under-counting the number of
places that gen numbers are used, given that Mesa uses intel->gen, and
the 2d driver tends to use INTEL_INFO(intel)->gen.
[-- Attachment #1.2: Type: application/pgp-signature, Size: 197 bytes --]
[-- Attachment #2: Type: text/plain, Size: 159 bytes --]
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/intel-gfx
next prev parent reply other threads:[~2012-03-28 20:29 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-03-20 18:13 RFC: i915 arch changes to better support new chipsets Jesse Barnes
2012-03-20 18:43 ` Daniel Vetter
2012-03-20 20:13 ` Jesse Barnes
2012-03-21 11:42 ` Eugeni Dodonov
2012-03-21 11:58 ` Chris Wilson
2012-03-21 20:41 ` Jesse Barnes
2012-03-28 19:35 ` Eric Anholt
2012-03-28 19:46 ` Jesse Barnes
2012-03-28 19:59 ` Eugeni Dodonov
2012-03-28 20:29 ` Eric Anholt [this message]
2012-03-28 20:37 ` Daniel Vetter
2012-03-29 1:02 ` Eugeni Dodonov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87obrgbhax.fsf@eliezer.anholt.net \
--to=eric@anholt.net \
--cc=eugeni@dodonov.net \
--cc=intel-gfx@lists.freedesktop.org \
--cc=jbarnes@virtuousgeek.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox