Kernel KVM virtualization development
 help / color / mirror / Atom feed
* [PATCH 01/14] kvm tools: Move disk image related code under disk directory
@ 2011-05-18  8:19 Asias He
  2011-05-18  8:19 ` [PATCH 02/14] kvm tools: Rename disk-image.c to core.c Asias He
                   ` (13 more replies)
  0 siblings, 14 replies; 20+ messages in thread
From: Asias He @ 2011-05-18  8:19 UTC (permalink / raw)
  To: Pekka Enberg
  Cc: Cyrill Gorcunov, Ingo Molnar, Sasha Levin, Prasad Joshi, kvm,
	Asias He

This patch removes disk-image.c and qcow.c under disk directory.

Signed-off-by: Asias He <asias.hejun@gmail.com>
---
 tools/kvm/Makefile                |    4 ++--
 tools/kvm/{ => disk}/disk-image.c |    0
 tools/kvm/{ => disk}/qcow.c       |    0
 3 files changed, 2 insertions(+), 2 deletions(-)
 rename tools/kvm/{ => disk}/disk-image.c (100%)
 rename tools/kvm/{ => disk}/qcow.c (100%)

diff --git a/tools/kvm/Makefile b/tools/kvm/Makefile
index 45897d5..8938f5f 100644
--- a/tools/kvm/Makefile
+++ b/tools/kvm/Makefile
@@ -15,7 +15,7 @@ TAGS = ctags
 OBJS	+= 8250-serial.o
 OBJS	+= cpuid.o
 OBJS	+= read-write.o
-OBJS	+= disk-image.o
+OBJS	+= disk/disk-image.o
 OBJS	+= interrupt.o
 OBJS	+= ioport.o
 OBJS	+= kvm.o
@@ -37,7 +37,7 @@ OBJS    += util/strbuf.o
 OBJS    += kvm-help.o
 OBJS    += kvm-cmd.o
 OBJS    += kvm-run.o
-OBJS    += qcow.o
+OBJS    += disk/qcow.o
 OBJS    += mptable.o
 OBJS    += threadpool.o
 OBJS    += irq.o
diff --git a/tools/kvm/disk-image.c b/tools/kvm/disk/disk-image.c
similarity index 100%
rename from tools/kvm/disk-image.c
rename to tools/kvm/disk/disk-image.c
diff --git a/tools/kvm/qcow.c b/tools/kvm/disk/qcow.c
similarity index 100%
rename from tools/kvm/qcow.c
rename to tools/kvm/disk/qcow.c
-- 
1.7.5.1


^ permalink raw reply related	[flat|nested] 20+ messages in thread

end of thread, other threads:[~2011-05-18  8:52 UTC | newest]

Thread overview: 20+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2011-05-18  8:19 [PATCH 01/14] kvm tools: Move disk image related code under disk directory Asias He
2011-05-18  8:19 ` [PATCH 02/14] kvm tools: Rename disk-image.c to core.c Asias He
2011-05-18  8:19 ` [PATCH 03/14] kvm tools: Split raw image and blk device code from disk/core.c Asias He
2011-05-18  8:19 ` [PATCH 04/14] kvm tools: Rename disk_image__{read, write}_sector_iov Asias He
2011-05-18  8:19 ` [PATCH 05/14] kvm tools: Remove dead coe disk_image__{read, write}_sector Asias He
2011-05-18  8:19 ` [PATCH 06/14] kvm tools: Consolidate disk_image__{new, new_readonly} Asias He
2011-05-18  8:19 ` [PATCH 07/14] kvm tools: Split blk device code from raw.c to blk.c Asias He
2011-05-18  8:19 ` [PATCH 08/14] kvm tools: Tune up ops in 'struct disk_image_operations' Asias He
2011-05-18  8:19 ` [PATCH 09/14] kvm tools: Rename struct disk_image_operations ops name for raw image Asias He
2011-05-18  8:19 ` [PATCH 10/14] kvm tools: Rename raw_image_ops to blk_dev_ops Asias He
2011-05-18  8:51   ` Ingo Molnar
2011-05-18  8:19 ` [PATCH 11/14] kvm tools: Remove unnecessary S_ISBLK check Asias He
2011-05-18  8:19 ` [PATCH 12/14] kvm tools: Do not use 'inline' for disk_image__flush Asias He
2011-05-18  8:19 ` [PATCH 13/14] kvm tools: Add debug info for disk_image__{read, write} Asias He
2011-05-18  8:19 ` [PATCH 14/14] kvm tools: Print debug info for qcow1_nowrite_sector Asias He
2011-05-18  8:45   ` Ingo Molnar
2011-05-18  8:46     ` Ingo Molnar
2011-05-18  8:47     ` Cyrill Gorcunov
2011-05-18  8:42 ` [PATCH 01/14] kvm tools: Move disk image related code under disk directory Ingo Molnar
2011-05-18  8:43   ` Ingo Molnar

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox