From: Serge Semin <fancer.lancer@gmail.com>
To: Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>
Cc: Bjorn Helgaas <bhelgaas@google.com>,
"jingoohan1@gmail.com" <jingoohan1@gmail.com>,
"mani@kernel.org" <mani@kernel.org>,
"gustavo.pimentel@synopsys.com" <gustavo.pimentel@synopsys.com>,
"lpieralisi@kernel.org" <lpieralisi@kernel.org>,
"robh+dt@kernel.org" <robh+dt@kernel.org>,
"kw@linux.com" <kw@linux.com>,
"kishon@kernel.org" <kishon@kernel.org>,
"marek.vasut+renesas@gmail.com" <marek.vasut+renesas@gmail.com>,
"linux-pci@vger.kernel.org" <linux-pci@vger.kernel.org>,
"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
"linux-renesas-soc@vger.kernel.org"
<linux-renesas-soc@vger.kernel.org>
Subject: Re: [PATCH v16 01/22] PCI: Add PCI_EXP_LNKCAP_MLW macros
Date: Mon, 5 Jun 2023 03:25:35 +0300 [thread overview]
Message-ID: <20230605002535.f75gn32artzoyiat@mobilestation> (raw)
In-Reply-To: <TYBPR01MB534183482CD31D122C4735C0D84DA@TYBPR01MB5341.jpnprd01.prod.outlook.com>
On Mon, Jun 05, 2023 at 12:14:26AM +0000, Yoshihiro Shimoda wrote:
> Hello Serge,
>
> > From: Serge Semin, Sent: Monday, June 5, 2023 7:51 AM
> >
> > On Wed, May 10, 2023 at 03:22:13PM +0900, Yoshihiro Shimoda wrote:
> > > Add macros defining Maximum Link Width bits in Link Capabilities
> > > Register.
> > >
> > > Signed-off-by: Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>
> > > Acked-by: Bjorn Helgaas <bhelgaas@google.com>
> >
> > You haven't been using these macros in the following up patches since
> > v9. Why do you keep submitting this change then? I would suggest to
> > drop the patch especially seeing the PCI_EXP_LNKCAP_MLW field directly
> > encodes the link width thus these macros unlikely will be of much use.
>
> Thank you for your review! You're correct. I didn't realized that
> the macros were not used on the patch series..
>
> However, I also realized that the patch 11/22 used the PCI_EXP_LNKSTA_NLW_SHIFT
> macro for the PCI_EXP_LNKCAP register. So, I'm thinking that I should modify
> this patch as adding PCI_EXP_LNKCAP_MLW_SHIFT instead. But, what do you think?
>
> --- on the patch 11/22 ---
> > + cap = dw_pcie_find_capability(pci, PCI_CAP_ID_EXP);
> > + val = dw_pcie_readl_dbi(pci, cap + PCI_EXP_LNKCAP);
> > + val &= ~PCI_EXP_LNKCAP_MLW;
> > + val |= num_lanes << PCI_EXP_LNKSTA_NLW_SHIFT;
>
> Perhaps, this should be PCI_EXP_LNKCAP_MLW_SHIFT instead.
I'll get to that patch tomorrow, but in any case there is no need in
defining an additional macro here. There is a handy helper FIELD_PREP()
for that: FIELD_PREP(PCI_EXP_LNKSTA_MLW, num_lanes).
IMO for the same reason the PCI_EXP_LNKSTA_NLW_* macros are
unnecessary and can be easily either dropped or replaced by the
FIELD_{PREP,GET} macros usage.
-Serge(y)
> ---
>
> Best regards,
> Yoshihiro Shimoda
>
> > -Serge(y)
> >
> > > ---
> > > include/uapi/linux/pci_regs.h | 6 ++++++
> > > 1 file changed, 6 insertions(+)
> > >
> > > diff --git a/include/uapi/linux/pci_regs.h b/include/uapi/linux/pci_regs.h
> > > index dc2000e0fe3a..5d48413ac28f 100644
> > > --- a/include/uapi/linux/pci_regs.h
> > > +++ b/include/uapi/linux/pci_regs.h
> > > @@ -538,6 +538,12 @@
> > > #define PCI_EXP_LNKCAP_SLS_16_0GB 0x00000004 /* LNKCAP2 SLS Vector bit 3 */
> > > #define PCI_EXP_LNKCAP_SLS_32_0GB 0x00000005 /* LNKCAP2 SLS Vector bit 4 */
> > > #define PCI_EXP_LNKCAP_SLS_64_0GB 0x00000006 /* LNKCAP2 SLS Vector bit 5 */
> > > +#define PCI_EXP_LNKCAP_MLW_X1 0x00000010 /* Maximum Link Width x1 */
> > > +#define PCI_EXP_LNKCAP_MLW_X2 0x00000020 /* Maximum Link Width x2 */
> > > +#define PCI_EXP_LNKCAP_MLW_X4 0x00000040 /* Maximum Link Width x4 */
> > > +#define PCI_EXP_LNKCAP_MLW_X8 0x00000080 /* Maximum Link Width x8 */
> > > +#define PCI_EXP_LNKCAP_MLW_X12 0x000000c0 /* Maximum Link Width x12 */
> > > +#define PCI_EXP_LNKCAP_MLW_X16 0x00000100 /* Maximum Link Width x16 */
> > > #define PCI_EXP_LNKCAP_MLW 0x000003f0 /* Maximum Link Width */
> > > #define PCI_EXP_LNKCAP_ASPMS 0x00000c00 /* ASPM Support */
> > > #define PCI_EXP_LNKCAP_ASPM_L0S 0x00000400 /* ASPM L0s Support */
> > > --
> > > 2.25.1
> > >
next prev parent reply other threads:[~2023-06-05 0:25 UTC|newest]
Thread overview: 69+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-05-10 6:22 [PATCH v16 00/22] PCI: rcar-gen4: Add R-Car Gen4 PCIe support Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 01/22] PCI: Add PCI_EXP_LNKCAP_MLW macros Yoshihiro Shimoda
2023-06-04 22:50 ` Serge Semin
2023-06-05 0:14 ` Yoshihiro Shimoda
2023-06-05 0:25 ` Serge Semin [this message]
2023-06-05 1:38 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 02/22] PCI: Add PCI_HEADER_TYPE_MULTI_FUNC Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 03/22] PCI: Add INTx Mechanism Messages macros Yoshihiro Shimoda
2023-06-04 23:07 ` Serge Semin
2023-06-05 2:10 ` Yoshihiro Shimoda
2023-06-05 7:24 ` Serge Semin
2023-06-05 7:53 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 04/22] PCI: Rename PCI_EPC_IRQ_LEGACY to PCI_EPC_IRQ_INTX Yoshihiro Shimoda
2023-06-04 23:22 ` Serge Semin
2023-06-05 2:16 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 05/22] PCI: dwc: Rename "legacy_irq" to "INTx_irq" Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 06/22] PCI: dwc: Change arguments of dw_pcie_prog_outbound_atu() Yoshihiro Shimoda
2023-06-04 23:56 ` Serge Semin
2023-07-04 5:18 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 07/22] PCI: dwc: Add outbound MSG TLPs support Yoshihiro Shimoda
2023-06-05 0:15 ` Serge Semin
2023-07-04 5:22 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 08/22] PCI: designware-ep: Add INTx IRQs support Yoshihiro Shimoda
2023-06-05 8:05 ` Serge Semin
2023-06-06 9:20 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 09/22] PCI: dwc: Add dw_pcie_link_set_max_link_width() Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 10/22] PCI: dwc: Modify PCIE_PORT_LINK_CONTROL handling Yoshihiro Shimoda
2023-06-05 10:53 ` Serge Semin
2023-06-06 9:28 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 11/22] PCI: dwc: Add dw_pcie_link_set_max_cap_width() Yoshihiro Shimoda
2023-06-05 10:58 ` Serge Semin
2023-06-06 9:32 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 12/22] PCI: tegra194: Drop PCI_EXP_LNKSTA_NLW setting Yoshihiro Shimoda
2023-06-05 11:06 ` Serge Semin
2023-05-10 6:22 ` [PATCH v16 13/22] PCI: dwc: Add EDMA_UNROLL capability flag Yoshihiro Shimoda
2023-06-05 11:15 ` Serge Semin
2023-06-06 9:37 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 14/22] PCI: dwc: Expose dw_pcie_ep_exit() to module Yoshihiro Shimoda
2023-06-05 11:28 ` Serge Semin
2023-05-10 6:22 ` [PATCH v16 15/22] PCI: dwc: Introduce .ep_pre_init() and .ep_deinit() Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 16/22] dt-bindings: PCI: dwc: Update maxItems of reg and reg-names Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 17/22] dt-bindings: PCI: renesas: Add R-Car Gen4 PCIe Host Yoshihiro Shimoda
2023-05-10 10:03 ` Krzysztof Kozlowski
2023-05-11 0:27 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 18/22] dt-bindings: PCI: renesas: Add R-Car Gen4 PCIe Endpoint Yoshihiro Shimoda
2023-05-10 10:03 ` Krzysztof Kozlowski
2023-05-11 0:23 ` Yoshihiro Shimoda
2023-05-11 5:03 ` Krzysztof Kozlowski
2023-06-05 14:50 ` Serge Semin
2023-05-10 6:22 ` [PATCH v16 19/22] PCI: rcar-gen4: Add R-Car Gen4 PCIe Host support Yoshihiro Shimoda
2023-06-05 14:39 ` Serge Semin
2023-06-07 2:59 ` Yoshihiro Shimoda
2023-06-07 12:15 ` Serge Semin
2023-06-08 8:47 ` Yoshihiro Shimoda
2023-06-08 12:11 ` Serge Semin
2023-06-09 6:29 ` Yoshihiro Shimoda
2023-06-09 10:54 ` Serge Semin
2023-06-12 13:19 ` Yoshihiro Shimoda
2023-06-12 19:51 ` Serge Semin
2023-06-14 2:30 ` Yoshihiro Shimoda
2023-06-14 11:39 ` Serge Semin
2023-06-14 19:31 ` Serge Semin
2023-06-20 12:02 ` Yoshihiro Shimoda
2023-06-20 12:36 ` Serge Semin
2023-05-10 6:22 ` [PATCH v16 20/22] PCI: rcar-gen4-ep: Add R-Car Gen4 PCIe Endpoint support Yoshihiro Shimoda
2023-06-05 15:06 ` Serge Semin
2023-05-10 6:22 ` [PATCH v16 21/22] MAINTAINERS: Update PCI DRIVER FOR RENESAS R-CAR for R-Car Gen4 Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 22/22] misc: pci_endpoint_test: Add Device ID for R-Car S4-8 PCIe controller Yoshihiro Shimoda
2023-05-31 11:29 ` [PATCH v16 00/22] PCI: rcar-gen4: Add R-Car Gen4 PCIe support Serge Semin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230605002535.f75gn32artzoyiat@mobilestation \
--to=fancer.lancer@gmail.com \
--cc=bhelgaas@google.com \
--cc=devicetree@vger.kernel.org \
--cc=gustavo.pimentel@synopsys.com \
--cc=jingoohan1@gmail.com \
--cc=kishon@kernel.org \
--cc=kw@linux.com \
--cc=linux-pci@vger.kernel.org \
--cc=linux-renesas-soc@vger.kernel.org \
--cc=lpieralisi@kernel.org \
--cc=mani@kernel.org \
--cc=marek.vasut+renesas@gmail.com \
--cc=robh+dt@kernel.org \
--cc=yoshihiro.shimoda.uh@renesas.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox