From: Serge Semin <fancer.lancer@gmail.com>
To: Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>
Cc: jingoohan1@gmail.com, mani@kernel.org,
gustavo.pimentel@synopsys.com, lpieralisi@kernel.org,
robh+dt@kernel.org, kw@linux.com, bhelgaas@google.com,
kishon@kernel.org, marek.vasut+renesas@gmail.com,
linux-pci@vger.kernel.org, devicetree@vger.kernel.org,
linux-renesas-soc@vger.kernel.org
Subject: Re: [PATCH v16 10/22] PCI: dwc: Modify PCIE_PORT_LINK_CONTROL handling
Date: Mon, 5 Jun 2023 13:53:22 +0300 [thread overview]
Message-ID: <20230605105322.orc3rtgu5rr3ovot@mobilestation> (raw)
In-Reply-To: <20230510062234.201499-11-yoshihiro.shimoda.uh@renesas.com>
On Wed, May 10, 2023 at 03:22:22PM +0900, Yoshihiro Shimoda wrote:
> To improve code readability, modify PCIE_PORT_LINK_CONTROL handling.
So basically you are doing the same update as in the Patch 9:
detaching the already implemented link width setups into a separate
method. Why do you split them up into the incremental updates? Just
squash this patch into the patch 9. The resultant patch would be an
atomic update and a preparation before adding the PCI_EXP_LNKCAP field
update. The later would lead to the fully coherent maximum link width
setup method in accordance with the DW PCIe hardware manual.
-Serge(y)
>
> Signed-off-by: Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>
> ---
> drivers/pci/controller/dwc/pcie-designware.c | 40 +++++++-------------
> 1 file changed, 13 insertions(+), 27 deletions(-)
>
> diff --git a/drivers/pci/controller/dwc/pcie-designware.c b/drivers/pci/controller/dwc/pcie-designware.c
> index 68aefbbcd68c..5dc423dd2f21 100644
> --- a/drivers/pci/controller/dwc/pcie-designware.c
> +++ b/drivers/pci/controller/dwc/pcie-designware.c
> @@ -721,28 +721,40 @@ static void dw_pcie_link_set_max_speed(struct dw_pcie *pci, u32 link_gen)
>
> static void dw_pcie_link_set_max_link_width(struct dw_pcie *pci, u32 num_lanes)
> {
> - u32 lwsc;
> + u32 lwsc, plc;
>
> if (!num_lanes)
> return;
>
> + /* Set the number of lanes */
> + plc = dw_pcie_readl_dbi(pci, PCIE_PORT_LINK_CONTROL);
> + plc &= ~PORT_LINK_MODE_MASK;
> +
> /* Set link width speed control register */
> lwsc = dw_pcie_readl_dbi(pci, PCIE_LINK_WIDTH_SPEED_CONTROL);
> lwsc &= ~PORT_LOGIC_LINK_WIDTH_MASK;
> switch (num_lanes) {
> case 1:
> + plc |= PORT_LINK_MODE_1_LANES;
> lwsc |= PORT_LOGIC_LINK_WIDTH_1_LANES;
> break;
> case 2:
> + plc |= PORT_LINK_MODE_2_LANES;
> lwsc |= PORT_LOGIC_LINK_WIDTH_2_LANES;
> break;
> case 4:
> + plc |= PORT_LINK_MODE_4_LANES;
> lwsc |= PORT_LOGIC_LINK_WIDTH_4_LANES;
> break;
> case 8:
> + plc |= PORT_LINK_MODE_8_LANES;
> lwsc |= PORT_LOGIC_LINK_WIDTH_8_LANES;
> break;
> + default:
> + dev_err(pci->dev, "num-lanes %u: invalid value\n", num_lanes);
> + return;
> }
> + dw_pcie_writel_dbi(pci, PCIE_PORT_LINK_CONTROL, plc);
> dw_pcie_writel_dbi(pci, PCIE_LINK_WIDTH_SPEED_CONTROL, lwsc);
> }
>
> @@ -1027,31 +1039,5 @@ void dw_pcie_setup(struct dw_pcie *pci)
> val |= PORT_LINK_DLL_LINK_EN;
> dw_pcie_writel_dbi(pci, PCIE_PORT_LINK_CONTROL, val);
>
> - if (!pci->num_lanes) {
> - dev_dbg(pci->dev, "Using h/w default number of lanes\n");
> - return;
> - }
> -
> - /* Set the number of lanes */
> - val &= ~PORT_LINK_MODE_MASK;
> - switch (pci->num_lanes) {
> - case 1:
> - val |= PORT_LINK_MODE_1_LANES;
> - break;
> - case 2:
> - val |= PORT_LINK_MODE_2_LANES;
> - break;
> - case 4:
> - val |= PORT_LINK_MODE_4_LANES;
> - break;
> - case 8:
> - val |= PORT_LINK_MODE_8_LANES;
> - break;
> - default:
> - dev_err(pci->dev, "num-lanes %u: invalid value\n", pci->num_lanes);
> - return;
> - }
> - dw_pcie_writel_dbi(pci, PCIE_PORT_LINK_CONTROL, val);
> -
> dw_pcie_link_set_max_link_width(pci, pci->num_lanes);
> }
> --
> 2.25.1
>
next prev parent reply other threads:[~2023-06-05 10:53 UTC|newest]
Thread overview: 69+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-05-10 6:22 [PATCH v16 00/22] PCI: rcar-gen4: Add R-Car Gen4 PCIe support Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 01/22] PCI: Add PCI_EXP_LNKCAP_MLW macros Yoshihiro Shimoda
2023-06-04 22:50 ` Serge Semin
2023-06-05 0:14 ` Yoshihiro Shimoda
2023-06-05 0:25 ` Serge Semin
2023-06-05 1:38 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 02/22] PCI: Add PCI_HEADER_TYPE_MULTI_FUNC Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 03/22] PCI: Add INTx Mechanism Messages macros Yoshihiro Shimoda
2023-06-04 23:07 ` Serge Semin
2023-06-05 2:10 ` Yoshihiro Shimoda
2023-06-05 7:24 ` Serge Semin
2023-06-05 7:53 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 04/22] PCI: Rename PCI_EPC_IRQ_LEGACY to PCI_EPC_IRQ_INTX Yoshihiro Shimoda
2023-06-04 23:22 ` Serge Semin
2023-06-05 2:16 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 05/22] PCI: dwc: Rename "legacy_irq" to "INTx_irq" Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 06/22] PCI: dwc: Change arguments of dw_pcie_prog_outbound_atu() Yoshihiro Shimoda
2023-06-04 23:56 ` Serge Semin
2023-07-04 5:18 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 07/22] PCI: dwc: Add outbound MSG TLPs support Yoshihiro Shimoda
2023-06-05 0:15 ` Serge Semin
2023-07-04 5:22 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 08/22] PCI: designware-ep: Add INTx IRQs support Yoshihiro Shimoda
2023-06-05 8:05 ` Serge Semin
2023-06-06 9:20 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 09/22] PCI: dwc: Add dw_pcie_link_set_max_link_width() Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 10/22] PCI: dwc: Modify PCIE_PORT_LINK_CONTROL handling Yoshihiro Shimoda
2023-06-05 10:53 ` Serge Semin [this message]
2023-06-06 9:28 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 11/22] PCI: dwc: Add dw_pcie_link_set_max_cap_width() Yoshihiro Shimoda
2023-06-05 10:58 ` Serge Semin
2023-06-06 9:32 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 12/22] PCI: tegra194: Drop PCI_EXP_LNKSTA_NLW setting Yoshihiro Shimoda
2023-06-05 11:06 ` Serge Semin
2023-05-10 6:22 ` [PATCH v16 13/22] PCI: dwc: Add EDMA_UNROLL capability flag Yoshihiro Shimoda
2023-06-05 11:15 ` Serge Semin
2023-06-06 9:37 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 14/22] PCI: dwc: Expose dw_pcie_ep_exit() to module Yoshihiro Shimoda
2023-06-05 11:28 ` Serge Semin
2023-05-10 6:22 ` [PATCH v16 15/22] PCI: dwc: Introduce .ep_pre_init() and .ep_deinit() Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 16/22] dt-bindings: PCI: dwc: Update maxItems of reg and reg-names Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 17/22] dt-bindings: PCI: renesas: Add R-Car Gen4 PCIe Host Yoshihiro Shimoda
2023-05-10 10:03 ` Krzysztof Kozlowski
2023-05-11 0:27 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 18/22] dt-bindings: PCI: renesas: Add R-Car Gen4 PCIe Endpoint Yoshihiro Shimoda
2023-05-10 10:03 ` Krzysztof Kozlowski
2023-05-11 0:23 ` Yoshihiro Shimoda
2023-05-11 5:03 ` Krzysztof Kozlowski
2023-06-05 14:50 ` Serge Semin
2023-05-10 6:22 ` [PATCH v16 19/22] PCI: rcar-gen4: Add R-Car Gen4 PCIe Host support Yoshihiro Shimoda
2023-06-05 14:39 ` Serge Semin
2023-06-07 2:59 ` Yoshihiro Shimoda
2023-06-07 12:15 ` Serge Semin
2023-06-08 8:47 ` Yoshihiro Shimoda
2023-06-08 12:11 ` Serge Semin
2023-06-09 6:29 ` Yoshihiro Shimoda
2023-06-09 10:54 ` Serge Semin
2023-06-12 13:19 ` Yoshihiro Shimoda
2023-06-12 19:51 ` Serge Semin
2023-06-14 2:30 ` Yoshihiro Shimoda
2023-06-14 11:39 ` Serge Semin
2023-06-14 19:31 ` Serge Semin
2023-06-20 12:02 ` Yoshihiro Shimoda
2023-06-20 12:36 ` Serge Semin
2023-05-10 6:22 ` [PATCH v16 20/22] PCI: rcar-gen4-ep: Add R-Car Gen4 PCIe Endpoint support Yoshihiro Shimoda
2023-06-05 15:06 ` Serge Semin
2023-05-10 6:22 ` [PATCH v16 21/22] MAINTAINERS: Update PCI DRIVER FOR RENESAS R-CAR for R-Car Gen4 Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 22/22] misc: pci_endpoint_test: Add Device ID for R-Car S4-8 PCIe controller Yoshihiro Shimoda
2023-05-31 11:29 ` [PATCH v16 00/22] PCI: rcar-gen4: Add R-Car Gen4 PCIe support Serge Semin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230605105322.orc3rtgu5rr3ovot@mobilestation \
--to=fancer.lancer@gmail.com \
--cc=bhelgaas@google.com \
--cc=devicetree@vger.kernel.org \
--cc=gustavo.pimentel@synopsys.com \
--cc=jingoohan1@gmail.com \
--cc=kishon@kernel.org \
--cc=kw@linux.com \
--cc=linux-pci@vger.kernel.org \
--cc=linux-renesas-soc@vger.kernel.org \
--cc=lpieralisi@kernel.org \
--cc=mani@kernel.org \
--cc=marek.vasut+renesas@gmail.com \
--cc=robh+dt@kernel.org \
--cc=yoshihiro.shimoda.uh@renesas.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox