From: Serge Semin <fancer.lancer@gmail.com>
To: Yoshihiro Shimoda <yoshihiro.shimoda.uh@renesas.com>
Cc: "jingoohan1@gmail.com" <jingoohan1@gmail.com>,
"mani@kernel.org" <mani@kernel.org>,
"gustavo.pimentel@synopsys.com" <gustavo.pimentel@synopsys.com>,
"lpieralisi@kernel.org" <lpieralisi@kernel.org>,
"robh+dt@kernel.org" <robh+dt@kernel.org>,
"kw@linux.com" <kw@linux.com>,
"bhelgaas@google.com" <bhelgaas@google.com>,
"kishon@kernel.org" <kishon@kernel.org>,
"marek.vasut+renesas@gmail.com" <marek.vasut+renesas@gmail.com>,
"linux-pci@vger.kernel.org" <linux-pci@vger.kernel.org>,
"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
"linux-renesas-soc@vger.kernel.org"
<linux-renesas-soc@vger.kernel.org>
Subject: Re: [PATCH v16 19/22] PCI: rcar-gen4: Add R-Car Gen4 PCIe Host support
Date: Wed, 14 Jun 2023 22:31:31 +0300 [thread overview]
Message-ID: <20230614193131.6nlqyzwmhpv23ksv@mobilestation> (raw)
In-Reply-To: <20230614113924.7ssdcl2njivdienp@mobilestation>
On Wed, Jun 14, 2023 at 02:39:29PM +0300, Serge Semin wrote:
> On Wed, Jun 14, 2023 at 02:30:13AM +0000, Yoshihiro Shimoda wrote:
> > Hello Serge,
> >
> > From: Serge Semin, Sent: Tuesday, June 13, 2023 4:52 AM
> > >
> > > On Mon, Jun 12, 2023 at 01:19:02PM +0000, Yoshihiro Shimoda wrote:
> > > > Hello Serge,
> > > >
> > > > > From: Serge Semin, Sent: Friday, June 9, 2023 7:54 PM
> > > > <snip>
> > > > > > > > static int rcar_gen4_pcie_start_link(struct dw_pcie *dw)
> > > > > > > > {
> > > > > > > > struct rcar_gen4_pcie *rcar = to_rcar_gen4_pcie(dw);
> > > > > > > > int i;
> > > > > > > >
> > > > > > > > rcar_gen4_pcie_ltssm_enable(rcar, true);
> > > > > > > >
> > > > > > > > /*
> > > > > > > > * Require direct speed change here. Otherwise RDLH_LINK_UP of
> > > > > > > > * PCIEINTSTS0 which is this controller specific register may not
> > > > > > > > * be set.
> > > > > > > > */
> > > > > > >
> > > > > > > > if (rcar->needs_speed_change) {
> > > > > > >
> > > > > > > Seeing this is specified for the root port only what about
> > > > > > > replacing the statement with just test whether the rcar_gen4_pcie.mode ==
> > > > > > > DW_PCIE_RC_TYPE? Thus you'll be ablt to drop the needs_speed_change field.
> > > > > >
> > > > > > Thank you for the comment. I'll fix it.
> > > > > >
> > > > > > > BTW Just curious. Why is the loop below enabled for the Root Port
> > > > > > > only? What about the end-point controller? It's the same hardware
> > > > > > > after all..
> > > > > >
> > > > > > This is reused from v16 and then it used "link retraining" which is only for
> > > > > > the Root Port. As you mentioned, it seems endpoint controller is also needed
> > > > > > if we use direct speed change.
> > > > > >
> > > > > > > > for (i = 0; i < SPEED_CHANGE_MAX_RETRIES; i++) {
> > > > > > > > rcar_gen4_pcie_speed_change(dw);
> > > > > > > > msleep(100);
> > > > > > > > if (rcar_gen4_pcie_check_current_link(dw))
> > > > > > > > return 0;
> > > > > > > > }
> > > > > > >
> > > > > > > Did you trace how many iterations this loop normally takes?
> > > > > >
> > > > > > i = 0 or 1 (if the max-link-speed is suitable for a connected device.)
> > > > > >
> > > > > > > Is it
> > > > > > > constant or varies for the same platform setup and a connected link
> > > > > > > partner? Does the number of iterations depend on the target link speed
> > > > > > > specified via the "max-link-speed" property?
> > > > > >
> > > > >
> > > > > > This is not related to the "max-link-speed". It seems to related to
> > > > > > a link partner.
> > > > > > LinkCap max-link-speed loop
> > > > > > Device A 4 4 1
> > > > > > Device A 4 3 1
> > > > > > Device B 3 3 0
> > > > >
> > > > > Great! If so I would have just left a single unconditional
> > > > > rcar_gen4_pcie_speed_change() call placed right after the
> > > > > rcar_gen4_pcie_ltssm_enable() method with no delays afterwards. These
> > > > > methods would have been invoked in the framework of
> > > > > dw_pcie_start_link() after which the dw_pcie_wait_for_link() method is
> > > > > called with several checks parted with the ~100ms delay. It will make
> > > > > sure that at least some link is up with the link state printed to the
> > > > > system log. If for some reason the performance degradation happens
> > > > > then it will be up to the system administrator to investigate what was
> > > > > wrong. Your driver did as much is it could to reach the best link gen.
> > > >
> > > > IIUC, is your suggestion like the following code?
> > > > ---
> > > > rcar_gen4_pcie_ltssm_enable(rcar, true);
> > > > if (!dw_pcie_wait_for_link(dw)) {
> > > > rcar_gen4_pcie_speed_change(dw);
> > > > return 0;
> > > > }
> > > > ---
> > > >
> > > > Unfortunately, it doesn't work correctly...
> > > > The following code can work correctly. The value of i is still 1 on the device A.
> > > > What do you think that the following code is acceptable?
> > > > ---
> > > > rcar_gen4_pcie_ltssm_enable(rcar, true);
> > > > for (i = 0; i < SPEED_CHANGE_MAX_RETRIES; i++) {
> > > > msleep(100);
> > > > rcar_gen4_pcie_speed_change(dw);
> > > > if (dw_pcie_link_up(dw)) {
> > > > printk("%s:%d\n", __func__, i);
> > > > return 0;
> > > > }
> > > > }
> > > > ---
> > >
> > > My idea was to implement something like this:
> > >
> > > +static int rcar_gen4_pcie_start_link(struct dw_pcie *dw)
> > > +{
> > > + struct rcar_gen4_pcie *rcar = to_rcar_gen4_pcie(dw);
> > > +
> > > + rcar_gen4_pcie_ltssm_enable(rcar, true);
> > > +
> > > + rcar_gen4_pcie_speed_change(dw);
> > > +
> > > + return 0;
> > > +}
> > >
> > > and retain the rcar_gen4_pcie_link_up() method as is.
> >
> > Unfortunately, such a code doesn't work on my environment...
> >
> > > * Note: originally your loop used to have the msleep() call performed
> > > after the first rcar_gen4_pcie_speed_change() invocation. Thus the
> > > delay can be dropped if there is only one iteration implemented (see
> > > further to understand why).
> >
> > Calling rcar_gen4_pcie_speed_change() multiple times is required on
> > my environment. I thought msleep(100) was quite long so that I tried
> > other wait interval like below:
> >
> > msleep(1) : about 5 loops is needed for link. (about 5 msec.)
> > usleep_range(100, 110) : about 400 loops is needed for link. (about 40 msec.)
> > usleep_range(500, 600) : about 80 loops is needed for link. (about 40 msec.)
> >
> > The delay timing doesn't seems important. Both cases below can work correctly.
> > --- case 1 ---
> > for (i = 0; i < SPEED_CHANGE_MAX_RETRIES; i++) {
> > rcar_gen4_pcie_speed_change(dw);
> > if (dw_pcie_link_up(dw)) {
> > printk("%s:%d\n", __func__, i); // will be removed
> > return 0;
> > }
>
> > msleep(1);
>
> Why? Just set it to 5 ms. In anyway please see the next message.
>
> > }
> > ---
> > --- case 2 ---
> > for (i = 0; i < SPEED_CHANGE_MAX_RETRIES; i++) {
> > rcar_gen4_pcie_speed_change(dw);
> > msleep(1);
> > if (dw_pcie_link_up(dw)) {
> > printk("%s:%d\n", __func__, i); // will be removed
> > return 0;
> > }
> > }
> > ---
> >
> > So, I'll use case 1 for it.
>
> Ah. I think I get it now. Your spreadsheet:
>
> LinkCap max-link-speed loop
> Device A 4 4 1
> Device A 4 3 1
> Device B 3 3 0
>
> actually meant (loop+1) iterations. So in case of Gen4 you'll need
> three speed changes (one already enabled in the dw_pcie_setup_rc()
> method and another two ones are performed in your loop). Similarly in
> case of Gen3 you'll need only one iteration. I bet you won't need to
> call rcar_gen4_pcie_speed_change() at all if gen2 needs to be trained.
> Could you try it out?
>
> Anyway based on what you discovered and on my experience working with
> that controller, there should be as many
> GEN2_CTRL_OFF.DIRECT_SPEED_CHANGE flag changes as the target speed
> value, i.e. no flag switch if Gen1 is required, one flag switch if
> Gen2 is required and so on. Although I failed to find any explicit
> statement about that in the HW-manual.
>
> In addition to the above I've found out that
> GEN2_CTRL_OFF.DIRECT_SPEED_CHANGE field is actually self cleared when
> the speed change occurs (see the register description in the HW
> reference manual). We can use it to implement the
> dw_pcie_link_up()-independent link training algorithm like this:
>
> +#define RCAR_RETRAIN_MAX_CHECK 10
> +#define RCAR_LINK_SPEED_MAX 4
> +
> +static bool rcar_gen4_pcie_speed_change(struct dw_pcie *dw)
> +{
> + u32 val;
> + int i;
> +
> + val = dw_pcie_readl_dbi(dw, PCIE_LINK_WIDTH_SPEED_CONTROL);
> + val &= ~PORT_LOGIC_SPEED_CHANGE;
> + dw_pcie_writel_dbi(dw, PCIE_LINK_WIDTH_SPEED_CONTROL, val);
> +
> + val |= PORT_LOGIC_SPEED_CHANGE;
> + dw_pcie_writel_dbi(dw, PCIE_LINK_WIDTH_SPEED_CONTROL, val);
> +
> + for (i = 0; i < RCAR_SPEED_CHANGE_WAIT_RETRIES; i++) {
> + val = dw_pcie_readl_dbi(dw, PCIE_LINK_WIDTH_SPEED_CONTROL);
> + if (!(val & PORT_LOGIC_SPEED_CHANGE))
> + return true;
> +
> + msleep(1);
> + }
> +
> + return false;
> +}
> +
> +static int rcar_gen4_pcie_start_link(struct dw_pcie *dw)
> +{
> + struct rcar_gen4_pcie *rcar = to_rcar_gen4_pcie(dw);
> + int i, changes;
> +
> + rcar_gen4_pcie_ltssm_enable(rcar, true);
> +
> + changes = min_not_zero(dw->link_gen, RCAR_LINK_SPEED_MAX);
This should have been:
+changes = min_not_zero(dw->link_gen, RCAR_LINK_SPEED_MAX) - 1;
because Gen1 doesn't need any speed change action.
But this part can be further improved. Instead of the code above the
next snipped can be implemented:
+changes = min_not_zero(dw->link_gen, RCAR_LINK_SPEED_MAX) - 1;
+if (changes && rcar->mode == DW_PCIE_RC_TYPE)
+ changes -= 1;
It takes into account that the GEN2_CTRL_OFF.DIRECT_SPEED_CHANGE
flag is already set in the dw_pcie_setup_rc() method. So Gen2 will be
trained with no need in addition actions. If it's supported of course.
-Serge(y)
> + for (i = 0; i < changes; ++i) {
> + if (!rcar_gen4_pcie_speed_change(dw))
> + break;
> + }
> +
> + return 0;
> +}
>
> Note 1. The actual link state will be checked in the framework of the
> dw_pcie_wait_for_link() function, by means of dw_pcie_link_up().
>
> Note 2. RCAR_LINK_SPEED_MAX is deliberately set to 4 because DW PCIe
> EP core driver doesn't set the PORT_LOGIC_SPEED_CHANGE flag. In case
> of the DW PCIe Root Port at most 3 iterations should be enough.
>
> Note 3. Please use the RCAR_ prefix for the vendor-specific macros.
> It concerns the entire series.
>
> Could you try out the code suggested above?
>
> -Serge(y)
>
> >
> > > You don't need to wait for the link to actually get up in the
> > > start_link() callback because there is the link_up() callback, which
> > > is called from the dw_pcie_wait_for_link() method during the generic
> > > DWC PCIe setup procedure. See:
> >
> > Since the procedure will call rcar_gen4_pcie_speed_change() from
> > ->start_link() once, my environment cannot work correctly...
> >
> > Best regards,
> > Yoshihiro Shimoda
> >
> > > dw_pcie_host_init():
> > > +-> ops->host_init()
> > > +-> ...
> > > +-> dw_pcie_setup_rc()
> > > | +-> ...
> > > | +-> dw_pcie_setup()
> > > | +-> ...
> > > +-> if !dw_pcie_link_up()
> > > | | +-> ops->link_up()
> > > | +-> dw_pcie_start_link()
> > > | +-> ops->start_link()
> > > +-> dw_pcie_wait_for_link(); // See, wait-procedure is already performed
> > > | +-> loop 10 times // for you in the core driver together
> > > | +-> dw_pcie_link_up() // with the delays between the checks
> > > | +-> ops->link_up()
> > > | +-> msleep(~100)
> > > +-> ...
> > >
> > > -Serge(y)
> > >
> > > >
> > > > Best regards,
> > > > Yoshihiro Shimoda
> > > >
> > > > > -Serge(y)
> > > >
next prev parent reply other threads:[~2023-06-14 19:31 UTC|newest]
Thread overview: 69+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-05-10 6:22 [PATCH v16 00/22] PCI: rcar-gen4: Add R-Car Gen4 PCIe support Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 01/22] PCI: Add PCI_EXP_LNKCAP_MLW macros Yoshihiro Shimoda
2023-06-04 22:50 ` Serge Semin
2023-06-05 0:14 ` Yoshihiro Shimoda
2023-06-05 0:25 ` Serge Semin
2023-06-05 1:38 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 02/22] PCI: Add PCI_HEADER_TYPE_MULTI_FUNC Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 03/22] PCI: Add INTx Mechanism Messages macros Yoshihiro Shimoda
2023-06-04 23:07 ` Serge Semin
2023-06-05 2:10 ` Yoshihiro Shimoda
2023-06-05 7:24 ` Serge Semin
2023-06-05 7:53 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 04/22] PCI: Rename PCI_EPC_IRQ_LEGACY to PCI_EPC_IRQ_INTX Yoshihiro Shimoda
2023-06-04 23:22 ` Serge Semin
2023-06-05 2:16 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 05/22] PCI: dwc: Rename "legacy_irq" to "INTx_irq" Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 06/22] PCI: dwc: Change arguments of dw_pcie_prog_outbound_atu() Yoshihiro Shimoda
2023-06-04 23:56 ` Serge Semin
2023-07-04 5:18 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 07/22] PCI: dwc: Add outbound MSG TLPs support Yoshihiro Shimoda
2023-06-05 0:15 ` Serge Semin
2023-07-04 5:22 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 08/22] PCI: designware-ep: Add INTx IRQs support Yoshihiro Shimoda
2023-06-05 8:05 ` Serge Semin
2023-06-06 9:20 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 09/22] PCI: dwc: Add dw_pcie_link_set_max_link_width() Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 10/22] PCI: dwc: Modify PCIE_PORT_LINK_CONTROL handling Yoshihiro Shimoda
2023-06-05 10:53 ` Serge Semin
2023-06-06 9:28 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 11/22] PCI: dwc: Add dw_pcie_link_set_max_cap_width() Yoshihiro Shimoda
2023-06-05 10:58 ` Serge Semin
2023-06-06 9:32 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 12/22] PCI: tegra194: Drop PCI_EXP_LNKSTA_NLW setting Yoshihiro Shimoda
2023-06-05 11:06 ` Serge Semin
2023-05-10 6:22 ` [PATCH v16 13/22] PCI: dwc: Add EDMA_UNROLL capability flag Yoshihiro Shimoda
2023-06-05 11:15 ` Serge Semin
2023-06-06 9:37 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 14/22] PCI: dwc: Expose dw_pcie_ep_exit() to module Yoshihiro Shimoda
2023-06-05 11:28 ` Serge Semin
2023-05-10 6:22 ` [PATCH v16 15/22] PCI: dwc: Introduce .ep_pre_init() and .ep_deinit() Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 16/22] dt-bindings: PCI: dwc: Update maxItems of reg and reg-names Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 17/22] dt-bindings: PCI: renesas: Add R-Car Gen4 PCIe Host Yoshihiro Shimoda
2023-05-10 10:03 ` Krzysztof Kozlowski
2023-05-11 0:27 ` Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 18/22] dt-bindings: PCI: renesas: Add R-Car Gen4 PCIe Endpoint Yoshihiro Shimoda
2023-05-10 10:03 ` Krzysztof Kozlowski
2023-05-11 0:23 ` Yoshihiro Shimoda
2023-05-11 5:03 ` Krzysztof Kozlowski
2023-06-05 14:50 ` Serge Semin
2023-05-10 6:22 ` [PATCH v16 19/22] PCI: rcar-gen4: Add R-Car Gen4 PCIe Host support Yoshihiro Shimoda
2023-06-05 14:39 ` Serge Semin
2023-06-07 2:59 ` Yoshihiro Shimoda
2023-06-07 12:15 ` Serge Semin
2023-06-08 8:47 ` Yoshihiro Shimoda
2023-06-08 12:11 ` Serge Semin
2023-06-09 6:29 ` Yoshihiro Shimoda
2023-06-09 10:54 ` Serge Semin
2023-06-12 13:19 ` Yoshihiro Shimoda
2023-06-12 19:51 ` Serge Semin
2023-06-14 2:30 ` Yoshihiro Shimoda
2023-06-14 11:39 ` Serge Semin
2023-06-14 19:31 ` Serge Semin [this message]
2023-06-20 12:02 ` Yoshihiro Shimoda
2023-06-20 12:36 ` Serge Semin
2023-05-10 6:22 ` [PATCH v16 20/22] PCI: rcar-gen4-ep: Add R-Car Gen4 PCIe Endpoint support Yoshihiro Shimoda
2023-06-05 15:06 ` Serge Semin
2023-05-10 6:22 ` [PATCH v16 21/22] MAINTAINERS: Update PCI DRIVER FOR RENESAS R-CAR for R-Car Gen4 Yoshihiro Shimoda
2023-05-10 6:22 ` [PATCH v16 22/22] misc: pci_endpoint_test: Add Device ID for R-Car S4-8 PCIe controller Yoshihiro Shimoda
2023-05-31 11:29 ` [PATCH v16 00/22] PCI: rcar-gen4: Add R-Car Gen4 PCIe support Serge Semin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20230614193131.6nlqyzwmhpv23ksv@mobilestation \
--to=fancer.lancer@gmail.com \
--cc=bhelgaas@google.com \
--cc=devicetree@vger.kernel.org \
--cc=gustavo.pimentel@synopsys.com \
--cc=jingoohan1@gmail.com \
--cc=kishon@kernel.org \
--cc=kw@linux.com \
--cc=linux-pci@vger.kernel.org \
--cc=linux-renesas-soc@vger.kernel.org \
--cc=lpieralisi@kernel.org \
--cc=mani@kernel.org \
--cc=marek.vasut+renesas@gmail.com \
--cc=robh+dt@kernel.org \
--cc=yoshihiro.shimoda.uh@renesas.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox