From: "Krzysztof Wilczyński" <kwilczynski@kernel.org>
To: Bjorn Helgaas <bhelgaas@google.com>
Cc: Bjorn Helgaas <helgaas@kernel.org>,
Manivannan Sadhasivam <mani@kernel.org>,
Lorenzo Pieralisi <lpieralisi@kernel.org>,
linux-pci@vger.kernel.org
Subject: Re: [PATCH 0/3] PCI/sysfs: Follow-up to the static attribute conversion
Date: Sat, 1 Aug 2026 13:09:56 +0900 [thread overview]
Message-ID: <20260801040935.GH3183355@rocinante> (raw)
In-Reply-To: <20260721020427.1541197-1-kwilczynski@kernel.org>
Hello,
> This series is a follow-up to the PCI sysfs static attribute
> conversion [1], carrying the clean-up changes from its v8 revision.
>
> The v7 revision of the series was applied and went out with the PCI
> pull request for 7.2 [2], so the changes from v8 did not land in time
> to make the 7.2 release.
>
> The series consists of three clean-ups:
>
> - Add the pci_ prefix to the generated PCI resource attribute names
> dev_resourceN_{io,uc,wc}_attr, for consistency with the macros
> that generate them and the arrays that collect them.
>
> - Make the attribute name suffix the first parameter of Alpha's
> __pci_dev_resource_attr() macro, resolving a checkpatch.pl
> complaint about two consecutive commas.
>
> - Add the pci_legacy_resource_{io,mem}_attr() macros, and use them
> for the legacy I/O and memory attribute definitions instead of
> open-coding each struct bin_attribute.
>
> These correspond to the items listed under "Changes in v8" in the v8
> cover letter [1].
>
> No functional changes intended.
>
> 1. https://lore.kernel.org/linux-pci/20260619085200.3729431-1-kwilczynski@kernel.org/
> 2. https://lore.kernel.org/linux-pci/20260624110021.GA996382@bhelgaas/
Applied to the sysfs branch.
Thank you!
Krzysztof
prev parent reply other threads:[~2026-08-01 4:09 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-07-21 2:04 [PATCH 0/3] PCI/sysfs: Follow-up to the static attribute conversion Krzysztof Wilczyński
2026-07-21 2:04 ` [PATCH 1/3] PCI/sysfs: Add pci_ prefix to static PCI resource attribute names Krzysztof Wilczyński
2026-07-21 2:07 ` sashiko-bot
2026-07-21 2:04 ` [PATCH 2/3] alpha/PCI: Make the suffix the first __pci_dev_resource_attr() parameter Krzysztof Wilczyński
2026-07-21 2:07 ` sashiko-bot
2026-07-21 2:04 ` [PATCH 3/3] PCI/sysfs: Add legacy I/O and memory attribute macros Krzysztof Wilczyński
2026-07-21 2:11 ` sashiko-bot
2026-08-01 4:09 ` Krzysztof Wilczyński [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20260801040935.GH3183355@rocinante \
--to=kwilczynski@kernel.org \
--cc=bhelgaas@google.com \
--cc=helgaas@kernel.org \
--cc=linux-pci@vger.kernel.org \
--cc=lpieralisi@kernel.org \
--cc=mani@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox