Linux PCI subsystem development
 help / color / mirror / Atom feed
* [PATCH 0/3] PCI/sysfs: Follow-up to the static attribute conversion
@ 2026-07-21  2:04 Krzysztof Wilczyński
  2026-07-21  2:04 ` [PATCH 1/3] PCI/sysfs: Add pci_ prefix to static PCI resource attribute names Krzysztof Wilczyński
                   ` (3 more replies)
  0 siblings, 4 replies; 8+ messages in thread
From: Krzysztof Wilczyński @ 2026-07-21  2:04 UTC (permalink / raw)
  To: Bjorn Helgaas
  Cc: Bjorn Helgaas, Manivannan Sadhasivam, Lorenzo Pieralisi,
	linux-pci

Hello,

This series is a follow-up to the PCI sysfs static attribute
conversion [1], carrying the clean-up changes from its v8 revision.

The v7 revision of the series was applied and went out with the PCI
pull request for 7.2 [2], so the changes from v8 did not land in time
to make the 7.2 release.

The series consists of three clean-ups:

  - Add the pci_ prefix to the generated PCI resource attribute names
    dev_resourceN_{io,uc,wc}_attr, for consistency with the macros
    that generate them and the arrays that collect them.

  - Make the attribute name suffix the first parameter of Alpha's
    __pci_dev_resource_attr() macro, resolving a checkpatch.pl
    complaint about two consecutive commas.

  - Add the pci_legacy_resource_{io,mem}_attr() macros, and use them
    for the legacy I/O and memory attribute definitions instead of
    open-coding each struct bin_attribute.

These correspond to the items listed under "Changes in v8" in the v8
cover letter [1].

No functional changes intended.

1. https://lore.kernel.org/linux-pci/20260619085200.3729431-1-kwilczynski@kernel.org/
2. https://lore.kernel.org/linux-pci/20260624110021.GA996382@bhelgaas/

Krzysztof Wilczyński (3):
  PCI/sysfs: Add pci_ prefix to static PCI resource attribute names
  alpha/PCI: Make the suffix the first __pci_dev_resource_attr()
    parameter
  PCI/sysfs: Add legacy I/O and memory attribute macros

 arch/alpha/kernel/pci-sysfs.c |  26 ++++----
 drivers/pci/pci-sysfs.c       | 119 ++++++++++++++++------------------
 2 files changed, 68 insertions(+), 77 deletions(-)

-- 
2.55.0


^ permalink raw reply	[flat|nested] 8+ messages in thread

end of thread, other threads:[~2026-08-01  4:09 UTC | newest]

Thread overview: 8+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2026-07-21  2:04 [PATCH 0/3] PCI/sysfs: Follow-up to the static attribute conversion Krzysztof Wilczyński
2026-07-21  2:04 ` [PATCH 1/3] PCI/sysfs: Add pci_ prefix to static PCI resource attribute names Krzysztof Wilczyński
2026-07-21  2:07   ` sashiko-bot
2026-07-21  2:04 ` [PATCH 2/3] alpha/PCI: Make the suffix the first __pci_dev_resource_attr() parameter Krzysztof Wilczyński
2026-07-21  2:07   ` sashiko-bot
2026-07-21  2:04 ` [PATCH 3/3] PCI/sysfs: Add legacy I/O and memory attribute macros Krzysztof Wilczyński
2026-07-21  2:11   ` sashiko-bot
2026-08-01  4:09 ` [PATCH 0/3] PCI/sysfs: Follow-up to the static attribute conversion Krzysztof Wilczyński

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox