Linux RDMA and InfiniBand development
 help / color / mirror / Atom feed
From: Saeed Mahameed <saeedm@mellanox.com>
To: Saeed Mahameed <saeedm@mellanox.com>,
	Leon Romanovsky <leonro@mellanox.com>
Cc: "netdev@vger.kernel.org" <netdev@vger.kernel.org>,
	"linux-rdma@vger.kernel.org" <linux-rdma@vger.kernel.org>
Subject: [PATCH mlx5-next 00/18] Mellanox, mlx5 E-Switch and low level updates
Date: Fri, 28 Jun 2019 22:35:46 +0000	[thread overview]
Message-ID: <20190628223516.9368-1-saeedm@mellanox.com> (raw)

Hi All,

This series includes some low level updates mainly in the E-Switch
netdev and rdma vport representors areas.

From Parav and Huy:
 1) Added hardware bits and structures definitions for sub-functions
 2) Small code cleanup and improvement for PF pci driver.

From Bodong:
 3) Use the correct name semantics of vport index and vport number
 4) Cleanup the rep and netdev reference when unloading IB rep.
 5) Bluefield (ECPF) updates and refactoring for better E-Switch 
    management on ECPF embedded CPU NIC:
    5.1) Consolidate querying eswitch number of VFs
    5.2) Register event handler at the correct E-Switch init stage
    5.3) Setup PF's inline mode and vlan pop when the ECPF is the
         E-Swtich manager ( the host PF is basically a VF ).
    5.4) Handle Vport UC address changes in switchdev mode.

From Shay:
 6) Add support for MCQI and MCQS hardware registers.

In case of no objections these patches will be applied to mlx5-next and
will be sent later as pull request to both rdma-next and net-next trees.

Thanks,
Saeed.

---

Bodong Wang (12):
  net/mlx5: E-Switch, Use vport index when init rep
  {IB, net}/mlx5: E-Switch, Use index of rep for vport to IB port
    mapping
  RDMA/mlx5: Cleanup rep when doing unload
  net/mlx5: Don't handle VF func change if host PF is disabled
  net/mlx5: E-Switch, Use correct flags when configuring vlan
  net/mlx5: Handle host PF vport mac/guid for ECPF
  net/mlx5: E-Switch, Refactor eswitch SR-IOV interface
  net/mlx5: E-Switch, Consolidate eswitch function number of VFs
  net/mlx5: E-Switch, Reg/unreg function changed event at correct stage
  net/mlx5: E-Switch, Use iterator for vlan and min-inline setups
  net/mlx5: E-Switch, Consider host PF for inline mode and vlan pop
  net/mlx5: E-Switch, Handle UC address change in switchdev mode

Huy Nguyen (1):
  net/mlx5: Rename mlx5_pci_dev_type to mlx5_coredev_type

Parav Pandit (4):
  net/mlx5: Add hardware definitions for sub functions
  net/mlx5: Move pci status reg access mutex to mlx5_pci_init
  net/mlx5: Limit scope of mlx5_get_next_phys_dev() to PCI PF devices
  net/mlx5: Reduce dependency on enabled_vfs counter and num_vfs

Shay Agroskin (1):
  net/mlx5: Added MCQI and MCQS registers' description to ifc

 drivers/infiniband/hw/mlx5/ib_rep.c           |  22 +-
 drivers/infiniband/hw/mlx5/ib_rep.h           |   2 +-
 drivers/infiniband/hw/mlx5/main.c             |   2 +-
 drivers/infiniband/hw/mlx5/mlx5_ib.h          |   1 -
 drivers/net/ethernet/mellanox/mlx5/core/dev.c |   9 +-
 .../ethernet/mellanox/mlx5/core/en_dcbnl.c    |   2 +-
 .../net/ethernet/mellanox/mlx5/core/en_main.c |   4 +-
 .../net/ethernet/mellanox/mlx5/core/en_rep.c  |   8 +-
 .../net/ethernet/mellanox/mlx5/core/en_tc.c   |   2 +-
 .../net/ethernet/mellanox/mlx5/core/eswitch.c | 151 ++++++++------
 .../net/ethernet/mellanox/mlx5/core/eswitch.h |  44 +++-
 .../mellanox/mlx5/core/eswitch_offloads.c     | 196 ++++++++----------
 .../ethernet/mellanox/mlx5/core/fpga/conn.c   |   2 +-
 drivers/net/ethernet/mellanox/mlx5/core/lag.c |   4 +-
 .../net/ethernet/mellanox/mlx5/core/main.c    |   7 +-
 .../net/ethernet/mellanox/mlx5/core/rdma.c    |   2 +-
 .../net/ethernet/mellanox/mlx5/core/sriov.c   |  27 +--
 .../net/ethernet/mellanox/mlx5/core/vport.c   |  28 ++-
 include/linux/mlx5/driver.h                   |  13 +-
 include/linux/mlx5/eswitch.h                  |   8 +-
 include/linux/mlx5/mlx5_ifc.h                 | 161 +++++++++++++-
 include/linux/mlx5/vport.h                    |   4 +-
 22 files changed, 446 insertions(+), 253 deletions(-)

-- 
2.21.0


             reply	other threads:[~2019-06-28 22:35 UTC|newest]

Thread overview: 20+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-06-28 22:35 Saeed Mahameed [this message]
2019-06-28 22:35 ` [PATCH mlx5-next 01/18] net/mlx5: Add hardware definitions for sub functions Saeed Mahameed
2019-06-28 22:35 ` [PATCH mlx5-next 02/18] net/mlx5: Added MCQI and MCQS registers' description to ifc Saeed Mahameed
2019-06-28 22:35 ` [PATCH mlx5-next 03/18] net/mlx5: E-Switch, Use vport index when init rep Saeed Mahameed
2019-06-28 22:35 ` [PATCH mlx5-next 04/18] {IB, net}/mlx5: E-Switch, Use index of rep for vport to IB port mapping Saeed Mahameed
2019-06-28 22:35 ` [PATCH mlx5-next 05/18] RDMA/mlx5: Cleanup rep when doing unload Saeed Mahameed
2019-06-28 22:35 ` [PATCH mlx5-next 06/18] net/mlx5: Rename mlx5_pci_dev_type to mlx5_coredev_type Saeed Mahameed
2019-06-28 22:36 ` [PATCH mlx5-next 07/18] net/mlx5: Move pci status reg access mutex to mlx5_pci_init Saeed Mahameed
2019-06-28 22:36 ` [PATCH mlx5-next 08/18] net/mlx5: Limit scope of mlx5_get_next_phys_dev() to PCI PF devices Saeed Mahameed
2019-06-28 22:36 ` [PATCH mlx5-next 09/18] net/mlx5: Don't handle VF func change if host PF is disabled Saeed Mahameed
2019-06-28 22:36 ` [PATCH mlx5-next 10/18] net/mlx5: Reduce dependency on enabled_vfs counter and num_vfs Saeed Mahameed
2019-06-28 22:36 ` [PATCH mlx5-next 11/18] net/mlx5: E-Switch, Use correct flags when configuring vlan Saeed Mahameed
2019-06-28 22:36 ` [PATCH mlx5-next 12/18] net/mlx5: Handle host PF vport mac/guid for ECPF Saeed Mahameed
2019-06-28 22:36 ` [PATCH mlx5-next 13/18] net/mlx5: E-Switch, Refactor eswitch SR-IOV interface Saeed Mahameed
2019-06-28 22:36 ` [PATCH mlx5-next 14/18] net/mlx5: E-Switch, Consolidate eswitch function number of VFs Saeed Mahameed
2019-06-28 22:36 ` [PATCH mlx5-next 15/18] net/mlx5: E-Switch, Reg/unreg function changed event at correct stage Saeed Mahameed
2019-06-28 22:36 ` [PATCH mlx5-next 16/18] net/mlx5: E-Switch, Use iterator for vlan and min-inline setups Saeed Mahameed
2019-06-28 22:36 ` [PATCH mlx5-next 17/18] net/mlx5: E-Switch, Consider host PF for inline mode and vlan pop Saeed Mahameed
2019-06-28 22:36 ` [PATCH mlx5-next 18/18] net/mlx5: E-Switch, Handle UC address change in switchdev mode Saeed Mahameed
2019-07-01 23:46 ` [PATCH mlx5-next 00/18] Mellanox, mlx5 E-Switch and low level updates Saeed Mahameed

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20190628223516.9368-1-saeedm@mellanox.com \
    --to=saeedm@mellanox.com \
    --cc=leonro@mellanox.com \
    --cc=linux-rdma@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox