Linux SCSI subsystem development
 help / color / mirror / Atom feed
* [PATCH 00/20] libfc callback cleanup
@ 2016-10-18  8:01 Hannes Reinecke
  2016-10-18  8:01 ` [PATCH 01/20] libfc: Replace ->seq_els_rsp_send callback with function call Hannes Reinecke
                   ` (21 more replies)
  0 siblings, 22 replies; 50+ messages in thread
From: Hannes Reinecke @ 2016-10-18  8:01 UTC (permalink / raw)
  To: Martin K. Petersen
  Cc: Johannes Thumshirn, Christoph Hellwig, Bart van Assche,
	James Bottomley, linux-scsi, Hannes Reinecke

Hi all,

it has been bugging me for a while that libfc has tons of callbacks
in an attempt to abstract things away. But as it turned out
no-one ever used those, rendering them quite pointless.
As I got some time to kill on the train back from Vienna I've decided
to finally kill them and call the functions directly.

As usual, comments and reviews are welcome.

Hannes Reinecke (20):
  libfc: Replace ->seq_els_rsp_send callback with function call
  libfc: Replace ->lport_reset callback with function call
  libfc: Replace ->lport_recv with function call
  libfc: Replace ->exch_seq_send callback with function call
  libfc: Replace ->rport_destroy callback with function call
  libfc: Replace ->rport_lookup callback with function call
  scsi_transport_fc: rename 'fc_rport_create' to 'fc_remote_port_create'
  libfc: Replace ->rport_create callback with function call
  libfc: Replace ->rport_login callback with function call
  libfc: Replace ->rport_logoff callback with function call
  libfc: Replace ->rport_recv_req callback with function call
  libfc: Replace ->rport_flush_queue callback with function call
  libfc: Remove fc_rport_init()
  libfc: Replace ->seq_send callback with function call
  libfc: Replace ->seq_exch_abort callback with function call
  libfc: Replace ->exch_done callback with function call
  libfc: Replace ->seq_start_next callback with function call
  libfc: Replace ->seq_set_resp callback with direct function call
  libfc: Replace ->seq_assign callback with function call
  libfc: Replace ->seq_release callback with function call

 drivers/scsi/bnx2fc/bnx2fc_fcoe.c |   1 -
 drivers/scsi/bnx2fc/bnx2fc_tgt.c  |   3 +-
 drivers/scsi/fcoe/fcoe_ctlr.c     |  35 ++++---
 drivers/scsi/fnic/fnic_scsi.c     |   2 +-
 drivers/scsi/libfc/fc_disc.c      |  33 ++++---
 drivers/scsi/libfc/fc_elsct.c     |   2 +-
 drivers/scsi/libfc/fc_exch.c      | 104 ++++++++++----------
 drivers/scsi/libfc/fc_fcp.c       |  45 ++++-----
 drivers/scsi/libfc/fc_libfc.c     |   2 +-
 drivers/scsi/libfc/fc_lport.c     |  62 ++++++------
 drivers/scsi/libfc/fc_rport.c     | 167 ++++++++++++++------------------
 drivers/scsi/scsi_transport_fc.c  |   8 +-
 drivers/target/tcm_fc/tfc_cmd.c   |  20 ++--
 drivers/target/tcm_fc/tfc_io.c    |   4 +-
 include/scsi/libfc.h              | 195 ++++++--------------------------------
 15 files changed, 254 insertions(+), 429 deletions(-)

-- 
1.8.5.6


^ permalink raw reply	[flat|nested] 50+ messages in thread

end of thread, other threads:[~2016-10-25  0:38 UTC | newest]

Thread overview: 50+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
2016-10-18  8:01 [PATCH 00/20] libfc callback cleanup Hannes Reinecke
2016-10-18  8:01 ` [PATCH 01/20] libfc: Replace ->seq_els_rsp_send callback with function call Hannes Reinecke
2016-10-18  8:27   ` Johannes Thumshirn
2016-10-18  8:37   ` Johannes Thumshirn
2016-10-18  8:01 ` [PATCH 02/20] libfc: Replace ->lport_reset " Hannes Reinecke
2016-10-18  8:41   ` Johannes Thumshirn
2016-10-18  8:01 ` [PATCH 03/20] libfc: Replace ->lport_recv " Hannes Reinecke
2016-10-18  8:42   ` Johannes Thumshirn
2016-10-18  8:01 ` [PATCH 04/20] libfc: Replace ->exch_seq_send callback " Hannes Reinecke
2016-10-18  8:45   ` Johannes Thumshirn
2016-10-18  8:01 ` [PATCH 05/20] libfc: Replace ->rport_destroy " Hannes Reinecke
2016-10-18  8:47   ` Johannes Thumshirn
2016-10-18  8:01 ` [PATCH 06/20] libfc: Replace ->rport_lookup " Hannes Reinecke
2016-10-18  8:48   ` Johannes Thumshirn
2016-10-18  8:01 ` [PATCH 07/20] scsi_transport_fc: rename 'fc_rport_create' to 'fc_remote_port_create' Hannes Reinecke
2016-10-18 11:17   ` Johannes Thumshirn
2016-10-18 16:00   ` James Smart
     [not found]     ` <CAGH8bx6+ZPAQRM1hWbEnzWj8qRJAcF7g3ne6oTbeWvbkXNtnvA@mail.gmail.com>
     [not found]       ` <CAGH8bx4Aut8NJ4t48yXv6+LJxfKvXFMOtzEm7UBuCqo-BwSEMA@mail.gmail.com>
2016-10-18 17:29         ` James Smart
2016-10-18  8:01 ` [PATCH 08/20] libfc: Replace ->rport_create callback with function call Hannes Reinecke
2016-10-18  8:54   ` Johannes Thumshirn
2016-10-18 10:23     ` Hannes Reinecke
2016-10-18 10:26       ` Johannes Thumshirn
2016-10-18  8:01 ` [PATCH 09/20] libfc: Replace ->rport_login " Hannes Reinecke
2016-10-18  8:55   ` Johannes Thumshirn
2016-10-18  8:01 ` [PATCH 10/20] libfc: Replace ->rport_logoff " Hannes Reinecke
2016-10-18  8:58   ` Johannes Thumshirn
2016-10-19 12:54   ` Chad Dupuis
2016-10-18  8:01 ` [PATCH 11/20] libfc: Replace ->rport_recv_req " Hannes Reinecke
2016-10-18  8:58   ` Johannes Thumshirn
2016-10-18  8:01 ` [PATCH 12/20] libfc: Replace ->rport_flush_queue " Hannes Reinecke
2016-10-18  8:59   ` Johannes Thumshirn
2016-10-18  8:01 ` [PATCH 13/20] libfc: Remove fc_rport_init() Hannes Reinecke
2016-10-18  8:59   ` Johannes Thumshirn
2016-10-19 12:55   ` Chad Dupuis
2016-10-18  8:01 ` [PATCH 14/20] libfc: Replace ->seq_send callback with function call Hannes Reinecke
2016-10-18  9:01   ` Johannes Thumshirn
2016-10-18  8:01 ` [PATCH 15/20] libfc: Replace ->seq_exch_abort " Hannes Reinecke
2016-10-18  9:02   ` Johannes Thumshirn
2016-10-18  8:01 ` [PATCH 16/20] libfc: Replace ->exch_done " Hannes Reinecke
2016-10-18  9:03   ` Johannes Thumshirn
2016-10-18  8:01 ` [PATCH 17/20] libfc: Replace ->seq_start_next " Hannes Reinecke
2016-10-18  9:04   ` Johannes Thumshirn
2016-10-18  8:01 ` [PATCH 18/20] libfc: Replace ->seq_set_resp callback with direct " Hannes Reinecke
2016-10-18  9:04   ` Johannes Thumshirn
2016-10-18  8:01 ` [PATCH 19/20] libfc: Replace ->seq_assign callback with " Hannes Reinecke
2016-10-18  9:05   ` Johannes Thumshirn
2016-10-18  8:01 ` [PATCH 20/20] libfc: Replace ->seq_release " Hannes Reinecke
2016-10-18  9:07   ` Johannes Thumshirn
2016-10-19 12:49 ` [PATCH 00/20] libfc callback cleanup Chad Dupuis
2016-10-25  0:37 ` Martin K. Petersen

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox