The Linux Kernel Mailing List
 help / color / mirror / Atom feed
From: Mike Rapoport <rppt@kernel.org>
To: Muchun Song <muchun.song@linux.dev>
Cc: Muchun Song <songmuchun@bytedance.com>,
	Andrew Morton <akpm@linux-foundation.org>,
	Oscar Salvador <osalvador@suse.de>,
	David Hildenbrand <david@kernel.org>,
	linux-mm@kvack.org, Vlastimil Babka <vbabka@kernel.org>,
	Lorenzo Stoakes <ljs@kernel.org>, Michal Hocko <mhocko@suse.com>,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 06/17] mm/sparse-vmemmap: support section-based vmemmap accounting
Date: Thu, 16 Jul 2026 09:23:59 +0300	[thread overview]
Message-ID: <alh4_wc42_46Xaim@kernel.org> (raw)
In-Reply-To: <FB36B71D-0972-4EF4-9887-C765CAC33E12@linux.dev>

On Wed, Jul 15, 2026 at 10:44:51PM +0800, Muchun Song wrote:
> > On Jul 15, 2026, at 13:08, Mike Rapoport <rppt@kernel.org> wrote:
> > 
> >> section_nr_vmemmap_pages() is used to account the vmemmap pages consumed by a
> >> memory section, but it currently only understands the ordinary case and the
> >> pgmap-provided optimization case. That is not enough for section-based vmemmap
> >> optimization, where the compound page order is carried by the memory section
> >> itself and tail vmemmap pages may be shared.
> >> 
> >> Make the helper report the actual vmemmap footprint of a section, so it can be
> >> used as the common accounting path for both ordinary and optimized sections.
> >> 
> >> Teach section_nr_vmemmap_pages() to use the section order when there is no
> >> pgmap, and to account only the vmemmap pages that are actually needed for an
> >> optimizable section. This keeps the accounting consistent with section-based
> >> vmemmap optimization.
> >> 
> >> Signed-off-by: Muchun Song <songmuchun@bytedance.com>
> >> 
> >> diff --git a/include/linux/mmzone.h b/include/linux/mmzone.h
> >> index 6fa6e7f0abf9..41a1ebbe5e85 100644
> >> --- a/include/linux/mmzone.h
> >> +++ b/include/linux/mmzone.h
> >> @@ -2403,6 +2403,14 @@ static inline unsigned int section_order(const struct mem_section *section)
> >> }
> >> #endif
> >> 
> >> +static inline bool section_vmemmap_optimizable(const struct mem_section *section)
> >> +{
> >> + 	if (!is_power_of_2(sizeof(struct page)))
> >> + 		return false;
> >> +
> >> + 	return section_order(section) >= OPTIMIZABLE_FOLIO_MIN_ORDER;
> > 
> > Like with page_vmemmap_optimizable() I think it's not obvious that
> > section_order() is enough to gate vmemmap optimization.
> 
> page_vmemmap_optimizable() checks the optimizability of an individual page.
> section_vmemmap_optimizable() checks whether the optimization can be applied
> to a section. Some people may think that section_vmemmap_optimizable() checks
> the optimizability of all pages within an entire section. You are referring
> to that ambiguity, right?
> 
> What do you think about renaming it to section_vmemmap_optimization_eligible()?
> Would that clear up the ambiguity? Or should we add a comment to
> section_vmemmap_optimizableto explain its purpose?
 
The name is fine, IMHO.
What I meant is that it would be clearer if there was a check for
HUGETLB_PAGE_OPTIMIZE_VMEMMAP.
 
-- 
Sincerely yours,
Mike.

  reply	other threads:[~2026-07-16  6:24 UTC|newest]

Thread overview: 57+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-07-02  9:38 [PATCH 00/17] mm: Introduce section-based vmemmap optimization for HugeTLB Muchun Song
2026-07-02  9:38 ` [PATCH 01/17] mm/sparse: drop power-of-2 size requirement for struct mem_section Muchun Song
2026-07-15  5:08   ` Mike Rapoport
2026-07-15  9:34   ` David Laight
2026-07-15 13:15     ` Muchun Song
2026-07-15 15:52       ` David Laight
2026-07-16  6:51         ` Muchun Song
2026-07-02  9:38 ` [PATCH 02/17] mm/sparse-vmemmap: track compound page order in " Muchun Song
2026-07-15  5:08   ` Mike Rapoport
2026-07-15  6:42     ` Muchun Song
2026-07-15  9:45       ` Mike Rapoport
2026-07-16  9:15   ` David Laight
2026-07-02  9:38 ` [PATCH 03/17] mm/sparse-vmemmap: introduce folio-oriented vmemmap optimization macros Muchun Song
2026-07-15  5:08   ` Mike Rapoport
2026-07-16  7:38     ` Muchun Song
2026-07-16 10:04       ` Mike Rapoport
2026-07-02  9:38 ` [PATCH 04/17] mm/mm_init: skip initializing shared vmemmap tail pages Muchun Song
2026-07-09 10:45   ` Mike Rapoport
2026-07-09 12:31     ` Muchun Song
2026-07-09 13:05       ` Mike Rapoport
2026-07-09 13:23         ` Muchun Song
2026-07-15  5:08   ` Mike Rapoport
2026-07-15  9:11     ` Muchun Song
2026-07-15  9:47       ` Mike Rapoport
2026-07-02  9:38 ` [PATCH 05/17] mm/sparse-vmemmap: initialize shared tail vmemmap pages on allocation Muchun Song
2026-07-02  9:38 ` [PATCH 06/17] mm/sparse-vmemmap: support section-based vmemmap accounting Muchun Song
2026-07-15  5:08   ` Mike Rapoport
2026-07-15 14:44     ` Muchun Song
2026-07-16  6:23       ` Mike Rapoport [this message]
2026-07-16  6:48         ` Muchun Song
2026-07-02  9:38 ` [PATCH 07/17] mm/sparse-vmemmap: support section-based vmemmap optimization Muchun Song
2026-07-15  5:08   ` Mike Rapoport
2026-07-16  7:19     ` Muchun Song
2026-07-02  9:38 ` [PATCH 08/17] mm/sparse: mark memory sections present earlier Muchun Song
2026-07-09 10:54   ` Mike Rapoport
2026-07-09 12:35     ` Muchun Song
2026-07-15  5:08   ` Mike Rapoport
2026-07-16  7:15     ` Muchun Song
2026-07-02  9:38 ` [PATCH 09/17] mm/hugetlb: switch HugeTLB to section-based vmemmap optimization Muchun Song
2026-07-15  5:08   ` Mike Rapoport
2026-07-02  9:38 ` [PATCH 10/17] mm/mm_init: factor out pfn_to_zone() Muchun Song
2026-07-15  5:08   ` Mike Rapoport
2026-07-16  7:18     ` Muchun Song
2026-07-02  9:38 ` [PATCH 11/17] mm/sparse-vmemmap: remove SPARSEMEM_VMEMMAP_PREINIT support Muchun Song
2026-07-15  5:08   ` Mike Rapoport
2026-07-02  9:38 ` [PATCH 12/17] mm/sparse: inline usemap allocation into sparse_init_nid() Muchun Song
2026-07-15  5:08   ` Mike Rapoport
2026-07-02  9:38 ` [PATCH 13/17] mm/sparse: remove section_map_size() Muchun Song
2026-07-15  5:08   ` Mike Rapoport
2026-07-02  9:38 ` [PATCH 14/17] mm/hugetlb: remove HUGE_BOOTMEM_HVO Muchun Song
2026-07-15  5:08   ` Mike Rapoport
2026-07-02  9:38 ` [PATCH 15/17] mm/hugetlb: remove HUGE_BOOTMEM_CMA Muchun Song
2026-07-15  5:08   ` Mike Rapoport
2026-07-02  9:38 ` [PATCH 16/17] mm/hugetlb: localize struct huge_bootmem_page Muchun Song
2026-07-15  5:08   ` Mike Rapoport
2026-07-02  9:38 ` [PATCH 17/17] mm/hugetlb: localize HUGE_BOOTMEM_ZONES_VALID Muchun Song
2026-07-15  5:08   ` Mike Rapoport

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alh4_wc42_46Xaim@kernel.org \
    --to=rppt@kernel.org \
    --cc=akpm@linux-foundation.org \
    --cc=david@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=ljs@kernel.org \
    --cc=mhocko@suse.com \
    --cc=muchun.song@linux.dev \
    --cc=osalvador@suse.de \
    --cc=songmuchun@bytedance.com \
    --cc=vbabka@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox