Netdev List
 help / color / mirror / Atom feed
From: Willem de Bruijn <willemdebruijn.kernel@gmail.com>
To: Wang Zhan <wang.zhan@smartx.com>,
	 netdev@vger.kernel.org,
	 Willem de Bruijn <willemdebruijn.kernel@gmail.com>
Cc: davem@davemloft.net,  edumazet@google.com,  kuba@kernel.org,
	 pabeni@redhat.com,  horms@kernel.org,  keyong.sun@smartx.com,
	 Wang Zhan <wang.zhan@smartx.com>,
	 Jason Wang <jasowangio@gmail.com>,
	 Andrew Lunn <andrew+netdev@lunn.ch>,
	 Aaron Conole <aconole@redhat.com>,
	 Eelco Chaudron <echaudro@redhat.com>,
	 Ilya Maximets <i.maximets@ovn.org>,
	 dev@openvswitch.org,  Daniel Borkmann <daniel@iogearbox.net>,
	 Neal Cardwell <ncardwell@google.com>,
	 Kuniyuki Iwashima <kuniyu@google.com>,
	 Alice Mikityanska <alice@isovalent.com>,
	 David Laight <david.laight.linux@gmail.com>
Subject: Re: [PATCH net-next v3 5/5] net: net_test: add tests for bounded GSO segmentation
Date: Tue, 29 Sep 2026 11:01:56 -0400	[thread overview]
Message-ID: <willemdebruijn.kernel.3b6c39ab87f82@gmail.com> (raw)
In-Reply-To: <20260929103008.2006188-1-wang.zhan@smartx.com>

Wang Zhan wrote:
> On Mon, 28 Sep 2026 19:59:54 -0400 Willem de Bruijn wrote:
> > > +	GSO_TEST_BOUNDED,
> > > +	GSO_TEST_BOUNDED_MULTI,
> > > +	GSO_TEST_BOUNDED_ONE_MSS,
> >
> > nit: bound is not a helpful name for this feature.
> >
> > The default segments to a stream of skbs of MSS 1, so segmenting to
> > a stream of skbs larger MSS to me is not bounding. Quite the opposite.
> >
> > Not a comment only about this test patch.
> >
> > Perhaps partial or re-segmentation better captures it.
> 
> Agreed.  I think re-segmentation is descriptive enough.  Partial is
> already for NETIF_F_GSO_PARTIAL.

Come to think of it, that may have always been the intention of partial?
Segment, but not yet fully.

Technically this would more be pre-segment than resegment.

Anyway, I don't mean to bikeshed this and don't have a better name.
Either will do.
 
> > > +	{
> > > +		/*
> > > +		 * One MSS per skb is what the unbounded path produces, so a
> > > +		 * bound of a single segment must not change the output.
> > > +		 */
> >
> > so setting max_segs = 0 is equivalent to setting max_segs = 1.
> 
> Right.  The default is one MSS per skb, so 0 and 1 behave the same.

  reply	other threads:[~2026-09-29 15:02 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-28  4:40 [PATCH net-next v3 0/5] net: resegment oversized TCP GSO skbs Wang Zhan
2026-09-28  4:40 ` [PATCH net-next v3 1/5] net: core: use the packet's L3 protocol for the GSO size limit Wang Zhan
2026-09-28 23:36   ` Willem de Bruijn
2026-09-29  3:44     ` Wang Zhan
2026-09-29  4:01     ` Wang Zhan
2026-09-29 14:59       ` Willem de Bruijn
2026-09-28  4:40 ` [PATCH net-next v3 2/5] net: core: factor out the GSO device limit check Wang Zhan
2026-09-28 23:37   ` Willem de Bruijn
2026-09-29  7:47   ` Paolo Abeni
2026-09-28  4:41 ` [PATCH net-next v3 3/5] net: gso: support bounded TCP segmentation Wang Zhan
2026-09-28 23:39   ` Willem de Bruijn
2026-09-30  4:41   ` netdev-bot+sashiko
2026-09-28  4:41 ` [PATCH net-next v3 4/5] net: core: resegment oversized TCP GSO skbs Wang Zhan
2026-09-28 23:47   ` Willem de Bruijn
2026-09-29 10:25     ` Wang Zhan
2026-09-29 15:00       ` Willem de Bruijn
2026-09-30  4:41   ` netdev-bot+sashiko
2026-09-28  4:41 ` [PATCH net-next v3 5/5] net: net_test: add tests for bounded GSO segmentation Wang Zhan
2026-09-28 23:59   ` Willem de Bruijn
2026-09-29 10:30     ` Wang Zhan
2026-09-29 15:01       ` Willem de Bruijn [this message]
2026-09-30  4:41   ` netdev-bot+sashiko
2026-09-28  4:45 ` [PATCH net-next v3 0/5] net: resegment oversized TCP GSO skbs netdev-bot+sinfo
2026-09-28  5:49   ` Wang Zhan
2026-09-28 23:34     ` Willem de Bruijn
2026-09-29  7:27       ` Paolo Abeni
2026-09-29 11:50       ` Wang Zhan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=willemdebruijn.kernel.3b6c39ab87f82@gmail.com \
    --to=willemdebruijn.kernel@gmail.com \
    --cc=aconole@redhat.com \
    --cc=alice@isovalent.com \
    --cc=andrew+netdev@lunn.ch \
    --cc=daniel@iogearbox.net \
    --cc=davem@davemloft.net \
    --cc=david.laight.linux@gmail.com \
    --cc=dev@openvswitch.org \
    --cc=echaudro@redhat.com \
    --cc=edumazet@google.com \
    --cc=horms@kernel.org \
    --cc=i.maximets@ovn.org \
    --cc=jasowangio@gmail.com \
    --cc=keyong.sun@smartx.com \
    --cc=kuba@kernel.org \
    --cc=kuniyu@google.com \
    --cc=ncardwell@google.com \
    --cc=netdev@vger.kernel.org \
    --cc=pabeni@redhat.com \
    --cc=wang.zhan@smartx.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox