* Re: [oe-commits] Joshua Lock : packaged-staging: enhancements from Poky for fetching and relocatability
[not found] <E1NxKhE-0007AF-AE@melo.openembedded.org>
@ 2010-04-01 22:21 ` Tom Rini
2010-04-06 14:35 ` Joshua Lock
0 siblings, 1 reply; 6+ messages in thread
From: Tom Rini @ 2010-04-01 22:21 UTC (permalink / raw)
To: openembedded-devel
On Thu, 2010-04-01 at 13:44 +0000, git version control wrote:
> Module: openembedded.git
> Branch: rpurdie/work-in-progress
> Commit: ccbb586b3cfdc723ccad73dd71d85f6d41f0e6a3
> URL: http://gitweb.openembedded.net/?p=openembedded.git&a=commit;h=ccbb586b3cfdc723ccad73dd71d85f6d41f0e6a3
>
> Author: Joshua Lock <josh@linux.intel.com>
> Date: Wed Mar 31 11:22:02 2010 +0100
>
> packaged-staging: enhancements from Poky for fetching and relocatability
Question. Do we really want to rename DEPLOY_DIR_PSTAGE to PSTAGE_DIR.
Is that really a nomenclature change like that? I see it's still soft
assign so outsideof TMPDIR can work still, so it's fine otherwise. Just
checking.
--
Tom Rini <tom_rini@mentor.com>
Mentor Graphics Corporation
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [oe-commits] Joshua Lock : packaged-staging: enhancements from Poky for fetching and relocatability
2010-04-01 22:21 ` [oe-commits] Joshua Lock : packaged-staging: enhancements from Poky for fetching and relocatability Tom Rini
@ 2010-04-06 14:35 ` Joshua Lock
2010-04-06 15:09 ` Tom Rini
0 siblings, 1 reply; 6+ messages in thread
From: Joshua Lock @ 2010-04-06 14:35 UTC (permalink / raw)
To: openembedded-devel
On Thu, 2010-04-01 at 15:21 -0700, Tom Rini wrote:
> On Thu, 2010-04-01 at 13:44 +0000, git version control wrote:
> > Module: openembedded.git
> > Branch: rpurdie/work-in-progress
> > Commit: ccbb586b3cfdc723ccad73dd71d85f6d41f0e6a3
> > URL: http://gitweb.openembedded.net/?p=openembedded.git&a=commit;h=ccbb586b3cfdc723ccad73dd71d85f6d41f0e6a3
> >
> > Author: Joshua Lock <josh@linux.intel.com>
> > Date: Wed Mar 31 11:22:02 2010 +0100
> >
> > packaged-staging: enhancements from Poky for fetching and relocatability
>
> Question. Do we really want to rename DEPLOY_DIR_PSTAGE to PSTAGE_DIR.
> Is that really a nomenclature change like that? I see it's still soft
> assign so outsideof TMPDIR can work still, so it's fine otherwise. Just
> checking.
>
I changed the name because we now have two pstage directories and wanted
the change to be apparent and I dropped the DEPLOY_ prefix as I moved
the default location outside of the deploy dir.
Does that seem reasonable?
Cheers,
Joshua
--
Joshua Lock
Intel Open Source Technology Centre
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [oe-commits] Joshua Lock : packaged-staging: enhancements from Poky for fetching and relocatability
2010-04-06 14:35 ` Joshua Lock
@ 2010-04-06 15:09 ` Tom Rini
2010-04-06 15:25 ` Chris Larson
0 siblings, 1 reply; 6+ messages in thread
From: Tom Rini @ 2010-04-06 15:09 UTC (permalink / raw)
To: openembedded-devel
On Tue, 2010-04-06 at 15:35 +0100, Joshua Lock wrote:
> On Thu, 2010-04-01 at 15:21 -0700, Tom Rini wrote:
> > On Thu, 2010-04-01 at 13:44 +0000, git version control wrote:
> > > Module: openembedded.git
> > > Branch: rpurdie/work-in-progress
> > > Commit: ccbb586b3cfdc723ccad73dd71d85f6d41f0e6a3
> > > URL: http://gitweb.openembedded.net/?p=openembedded.git&a=commit;h=ccbb586b3cfdc723ccad73dd71d85f6d41f0e6a3
> > >
> > > Author: Joshua Lock <josh@linux.intel.com>
> > > Date: Wed Mar 31 11:22:02 2010 +0100
> > >
> > > packaged-staging: enhancements from Poky for fetching and relocatability
> >
> > Question. Do we really want to rename DEPLOY_DIR_PSTAGE to PSTAGE_DIR.
> > Is that really a nomenclature change like that? I see it's still soft
> > assign so outsideof TMPDIR can work still, so it's fine otherwise. Just
> > checking.
> >
>
> I changed the name because we now have two pstage directories and wanted
> the change to be apparent and I dropped the DEPLOY_ prefix as I moved
> the default location outside of the deploy dir.
>
> Does that seem reasonable?
I think so, but I must be missing something. Are you talking about the
dir where we assemble packages as the 2nd one? Or something else?
Haven't made my coffee yet today...
--
Tom Rini <tom_rini@mentor.com>
Mentor Graphics Corporation
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [oe-commits] Joshua Lock : packaged-staging: enhancements from Poky for fetching and relocatability
2010-04-06 15:09 ` Tom Rini
@ 2010-04-06 15:25 ` Chris Larson
2010-04-06 16:22 ` Joshua Lock
0 siblings, 1 reply; 6+ messages in thread
From: Chris Larson @ 2010-04-06 15:25 UTC (permalink / raw)
To: openembedded-devel
On Tue, Apr 6, 2010 at 8:09 AM, Tom Rini <tom_rini@mentor.com> wrote:
> On Tue, 2010-04-06 at 15:35 +0100, Joshua Lock wrote:
> > On Thu, 2010-04-01 at 15:21 -0700, Tom Rini wrote:
> > > On Thu, 2010-04-01 at 13:44 +0000, git version control wrote:
> > > > Module: openembedded.git
> > > > Branch: rpurdie/work-in-progress
> > > > Commit: ccbb586b3cfdc723ccad73dd71d85f6d41f0e6a3
> > > > URL:
> http://gitweb.openembedded.net/?p=openembedded.git&a=commit;h=ccbb586b3cfdc723ccad73dd71d85f6d41f0e6a3
> > > >
> > > > Author: Joshua Lock <josh@linux.intel.com>
> > > > Date: Wed Mar 31 11:22:02 2010 +0100
> > > >
> > > > packaged-staging: enhancements from Poky for fetching and
> relocatability
> > >
> > > Question. Do we really want to rename DEPLOY_DIR_PSTAGE to PSTAGE_DIR.
> > > Is that really a nomenclature change like that? I see it's still soft
> > > assign so outsideof TMPDIR can work still, so it's fine otherwise.
> Just
> > > checking.
> > >
> >
> > I changed the name because we now have two pstage directories and wanted
> > the change to be apparent and I dropped the DEPLOY_ prefix as I moved
> > the default location outside of the deploy dir.
> >
> > Does that seem reasonable?
>
> I think so, but I must be missing something. Are you talking about the
> dir where we assemble packages as the 2nd one? Or something else?
> Haven't made my coffee yet today...
I haven't looked at the patches in a while, but from what I recall, he
splits the dir where the pstage .ipk files go from the rest of the files
that cluttered up DEPLOY_DIR_PSTAGE. I could be remembering incorrectly, of
course (do that a *lot* :).
--
Christopher Larson
clarson at kergoth dot com
Founder - BitBake, OpenEmbedded, OpenZaurus
Maintainer - Tslib
Senior Software Engineer, Mentor Graphics
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [oe-commits] Joshua Lock : packaged-staging: enhancements from Poky for fetching and relocatability
2010-04-06 15:25 ` Chris Larson
@ 2010-04-06 16:22 ` Joshua Lock
2010-04-06 17:21 ` Tom Rini
0 siblings, 1 reply; 6+ messages in thread
From: Joshua Lock @ 2010-04-06 16:22 UTC (permalink / raw)
To: openembedded-devel
On Tue, 2010-04-06 at 08:25 -0700, Chris Larson wrote:
> On Tue, Apr 6, 2010 at 8:09 AM, Tom Rini <tom_rini@mentor.com> wrote:
>
> > On Tue, 2010-04-06 at 15:35 +0100, Joshua Lock wrote:
> > > On Thu, 2010-04-01 at 15:21 -0700, Tom Rini wrote:
> > > > On Thu, 2010-04-01 at 13:44 +0000, git version control wrote:
> > > > > Module: openembedded.git
> > > > > Branch: rpurdie/work-in-progress
> > > > > Commit: ccbb586b3cfdc723ccad73dd71d85f6d41f0e6a3
> > > > > URL:
> > http://gitweb.openembedded.net/?p=openembedded.git&a=commit;h=ccbb586b3cfdc723ccad73dd71d85f6d41f0e6a3
> > > > >
> > > > > Author: Joshua Lock <josh@linux.intel.com>
> > > > > Date: Wed Mar 31 11:22:02 2010 +0100
> > > > >
> > > > > packaged-staging: enhancements from Poky for fetching and
> > relocatability
> > > >
> > > > Question. Do we really want to rename DEPLOY_DIR_PSTAGE to PSTAGE_DIR.
> > > > Is that really a nomenclature change like that? I see it's still soft
> > > > assign so outsideof TMPDIR can work still, so it's fine otherwise.
> > Just
> > > > checking.
> > > >
> > >
> > > I changed the name because we now have two pstage directories and wanted
> > > the change to be apparent and I dropped the DEPLOY_ prefix as I moved
> > > the default location outside of the deploy dir.
> > >
> > > Does that seem reasonable?
> >
> > I think so, but I must be missing something. Are you talking about the
> > dir where we assemble packages as the 2nd one? Or something else?
> > Haven't made my coffee yet today...
>
>
> I haven't looked at the patches in a while, but from what I recall, he
> splits the dir where the pstage .ipk files go from the rest of the files
> that cluttered up DEPLOY_DIR_PSTAGE. I could be remembering incorrectly, of
> course (do that a *lot* :).
My memory is recalling the same thing ;-)
Cheers,
Joshua
--
Joshua Lock
Intel Open Source Technology Centre
^ permalink raw reply [flat|nested] 6+ messages in thread
* Re: [oe-commits] Joshua Lock : packaged-staging: enhancements from Poky for fetching and relocatability
2010-04-06 16:22 ` Joshua Lock
@ 2010-04-06 17:21 ` Tom Rini
0 siblings, 0 replies; 6+ messages in thread
From: Tom Rini @ 2010-04-06 17:21 UTC (permalink / raw)
To: openembedded-devel
On Tue, 2010-04-06 at 17:22 +0100, Joshua Lock wrote:
> On Tue, 2010-04-06 at 08:25 -0700, Chris Larson wrote:
> > On Tue, Apr 6, 2010 at 8:09 AM, Tom Rini <tom_rini@mentor.com> wrote:
> >
> > > On Tue, 2010-04-06 at 15:35 +0100, Joshua Lock wrote:
> > > > On Thu, 2010-04-01 at 15:21 -0700, Tom Rini wrote:
> > > > > On Thu, 2010-04-01 at 13:44 +0000, git version control wrote:
> > > > > > Module: openembedded.git
> > > > > > Branch: rpurdie/work-in-progress
> > > > > > Commit: ccbb586b3cfdc723ccad73dd71d85f6d41f0e6a3
> > > > > > URL:
> > > http://gitweb.openembedded.net/?p=openembedded.git&a=commit;h=ccbb586b3cfdc723ccad73dd71d85f6d41f0e6a3
> > > > > >
> > > > > > Author: Joshua Lock <josh@linux.intel.com>
> > > > > > Date: Wed Mar 31 11:22:02 2010 +0100
> > > > > >
> > > > > > packaged-staging: enhancements from Poky for fetching and
> > > relocatability
> > > > >
> > > > > Question. Do we really want to rename DEPLOY_DIR_PSTAGE to PSTAGE_DIR.
> > > > > Is that really a nomenclature change like that? I see it's still soft
> > > > > assign so outsideof TMPDIR can work still, so it's fine otherwise.
> > > Just
> > > > > checking.
> > > > >
> > > >
> > > > I changed the name because we now have two pstage directories and wanted
> > > > the change to be apparent and I dropped the DEPLOY_ prefix as I moved
> > > > the default location outside of the deploy dir.
> > > >
> > > > Does that seem reasonable?
> > >
> > > I think so, but I must be missing something. Are you talking about the
> > > dir where we assemble packages as the 2nd one? Or something else?
> > > Haven't made my coffee yet today...
> >
> >
> > I haven't looked at the patches in a while, but from what I recall, he
> > splits the dir where the pstage .ipk files go from the rest of the files
> > that cluttered up DEPLOY_DIR_PSTAGE. I could be remembering incorrectly, of
> > course (do that a *lot* :).
>
> My memory is recalling the same thing ;-)
Sounds fine then.
--
Tom Rini <tom_rini@mentor.com>
Mentor Graphics Corporation
^ permalink raw reply [flat|nested] 6+ messages in thread
end of thread, other threads:[~2010-04-06 17:25 UTC | newest]
Thread overview: 6+ messages (download: mbox.gz follow: Atom feed
-- links below jump to the message on this page --
[not found] <E1NxKhE-0007AF-AE@melo.openembedded.org>
2010-04-01 22:21 ` [oe-commits] Joshua Lock : packaged-staging: enhancements from Poky for fetching and relocatability Tom Rini
2010-04-06 14:35 ` Joshua Lock
2010-04-06 15:09 ` Tom Rini
2010-04-06 15:25 ` Chris Larson
2010-04-06 16:22 ` Joshua Lock
2010-04-06 17:21 ` Tom Rini
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.